Karmic has Likewise-Open 4.1 in main and 5.0 in universe, because migrating from 4.1 to 5.0 requires manually leaving / rejoining the domain. For Lucid we want to only support the latest upstream version (5.4) and provide a clean migration path from all previous versions.

Release Note

N/A. It is a new upstream version, and migration should happen automatically.


Likewise upstream already did/will do all the migration/upstream/packaging/testing work; the only thing left for us to do is review and sponsoring.

The packages will upgrade automatically from all previously packaged versions (4.0, 4.1, 5.0).


At UDS Lucid they gave a presentation about the current status:

  • version 5 had many more binaries, but can't install them independently; thus they got merged back into just 2 packages: likewise-open-gui, likewise-open
  • upgrade path is in place:
    • backing up files and info
    • leave domain
    • push configs back in
    • requires a restart, part of a dist-upgrade
  • Hardy 4.0.5 to 5.4 testing is in progress (should work, just needs to be tested)
  • Karmic 4.1 to 5.4: works and tested
  • Karmic 5.0 to 5.4: in progress; complete 5.0 to 5.4 upgrade path not currently supported officially (5.0 is in universe), but will most probably be done by upstream as well.


  • December 7th: patches for libraries filed to LP (or branch proposal) (action: LW)
  • December 14th: libraries released (action: Server team)
  • January 7: new likewise-open packages need to land (action: LW)
  • January 7th: review/sponsoring (action: Desktop team)


DesktopTeam/Specs/Lucid/LikewiseOpenMigration (last edited 2009-11-26 12:10:09 by pitti)