LTS-Proposal

Differences between revisions 6 and 7
Revision 6 as of 2011-11-10 16:41:13
Size: 757
Editor: jonathan
Comment:
Revision 7 as of 2011-11-28 12:25:47
Size: 821
Editor: jonathan
Comment:
Deletions are marked like this. Additions are marked like this.
Line 2: Line 2:

This page has status: '''draft'''.
Line 7: Line 5:
The Edubuntu team is proposing supporting the Edubuntu 12.04 release for 3 or 5 years, depending on how long Kubuntu will be supported. The Edubuntu team is proposing that the Edubuntu 12.04 release be supported for 5 years as an LTS release.
Line 11: Line 9:
 * '''Kubuntu LTS Support Cycle'''. If Kubuntu is supported for 5 years, it will cover many packages in Edubuntu. If Kubuntu 12.04 LTS will be supported for 3 years, then we're only applying for 3 years.
 * '''Dropped Packages''', certain packages will be dropped. Since Mono won't be supported in Ubuntu anymore, we will be dropping Mono as well as GBrainy since we aren't willing to support that for 5 years. It will still be available in universe and possibly in an extras meta-package.
 * '''Kubuntu LTS Support Cycle'''. Many of the packages shipped in Edubuntu that are not shipped in Ubuntu are covered by Kubuntu. Kubuntu is applying for LTS status as well with 5 years of support for critical security updates.
 * '''Dropped Packages'''. Certain packages may prove a challenge to support for 5 years and we will be dropping them. Since Mono won't be shipped in Ubuntu anymore, we will be dropping Mono as well. This means that we'll be dropping GBrainy since we aren't willing to support its mono dependencies for 5 years. It will still be available in universe and possibly in an extras meta-package.

Edubuntu 12.04 LTS

The Edubuntu team is proposing that the Edubuntu 12.04 release be supported for 5 years as an LTS release.

Considerations

  • Kubuntu LTS Support Cycle. Many of the packages shipped in Edubuntu that are not shipped in Ubuntu are covered by Kubuntu. Kubuntu is applying for LTS status as well with 5 years of support for critical security updates.

  • Dropped Packages. Certain packages may prove a challenge to support for 5 years and we will be dropping them. Since Mono won't be shipped in Ubuntu anymore, we will be dropping Mono as well. This means that we'll be dropping GBrainy since we aren't willing to support its mono dependencies for 5 years. It will still be available in universe and possibly in an extras meta-package.

Edubuntu/12.04/LTS-Proposal (last edited 2012-01-10 12:29:39 by jonathan)