Packages

Revision 12 as of 2009-08-04 16:16:33

Clear message

Dep level

Package

Highlights

Reviewer

0

antlr3

unconfirmed

0

eucalyptus-commons-ext-java* (eucalyptus-commons-ext-java)

0

groovy

not-just-java

0

janino

not-just-java

0

asm2 (libasm2-java)

0

libaxiom-java* (libaxiom-java)

not-in-debian

0

c3p0 (libc3p0-java)

0

cglib2.1 (libcglib2.1-java)

0

libcommons-cli-java

unconfirmed

0

libcommons-fileupload-java

unconfirmed

0

commons-io (libcommons-io-java)

unconfirmed

0

libcommons-jxpath-java

unconfirmed

0

dnsjava* (libdnsjava-java)

not-in-debian

0

drools* (libdrools-core-java)

unconfirmed

0

excalibur-logkit (libexcalibur-logkit-java)

unconfirmed

0

libezmorph-java

unconfirmed

0

geronimo-ejb-3.0-spec* (libgeronimo-ejb-3.0-spec-java)

not-in-debian

0

geronimo-j2ee-connector-1.5-spec* (libgeronimo-j2ee-connector-1.5-spec-java)

not-in-debian

0

geronimo-jms-1.1-spec (libgeronimo-jms-1.1-spec-java)

not-in-debian

0

geronimo-jpa-3.0-spec* (libgeronimo-jpa-3.0-spec-java)

not-in-debian

0

geronimo-jta-1.0.1b-spec (libgeronimo-jta-1.0.1b-spec-java)

not-in-debian

0

geronimo-jacc-1.1-spec* (libgeronimo-jacc-1.1-spec-java)

not-in-debian

0

geronimo-interceptor-3.0-spec* (libgeronimo-interceptor-3.0-spec-java)

not-in-debian

0

libgoogle-collections-java

unconfirmed

0

gwt* (libgwt-java)

security-review

0

javassist (libjavassist-java)

0

jetty6* (libjetty-java)

security-review

0

libjibx-java

0

libjson-java

unconfirmed

0

jug* (libjug-asl-java)

not-in-debian

0

mvel* (libmvel-java)

not-in-debian

0

netty* (libnetty-java)

not-in-debian

0

libslf4j-java

0

wss4j* (libwss4j-java)

not-in-debian

0

libxml-security-java

1

ivy [for groovy]

1

jruby1.1 [for eucalyptus-commons-ext-java]

unconfirmed

1

junit4 [for groovy]

1

libaopalliance-java [for eucalyptus-commons-ext-java]

unconfirmed

1

asm (libasm-java) [for libcglib2.1-java, eucalyptus-commons-ext-java]

1

aspectwerkz2 (libaspectwerkz2-java) [for libcglib2.1-java]

no-default-jdk

1

libcommons-attributes-java [for eucalyptus-commons-ext-java]

unconfirmed

1

libjamon-java [for eucalyptus-commons-ext-java]

unconfirmed

1

jexcelapi (libjexcelapi-java) [for drools]

unconfirmed

1

mockobjects (libmockobjects-java) [for groovy]

1

ow-util-ant-tasks (libow-util-ant-tasks-java) [for libasm2-java]

1

qdox (libqdox-java) [for libjibx-java]

1

stringtemplate (libstringtemplate-java) [for antlr3]

unconfirmed

1

swt-gtk (libswt-gtk-3.4-java) [for gwt]

not-just-java

1

libxstream-java [for drools, groovy, eucalyptus-commons-ext-java]

2

commons-vfs (libcommons-vfs-java) [for ivy]

no-default-jdk

2

concurrent-dfsg (libconcurrent-java) [for libaspectwerkz2-java]

2

libhamcrest-java [for junit4]

2

jarjar (libjarjar-java) [for libaspectwerkz2-java]

no-default-jdk

2

jmock (libjmock-java) [for libqdox-java]

2

libjoda-time-java [for libxstream-java]

no-default-jdk

2

jrexx (libjrexx-java) [for libaspectwerkz2-java]

no-default-jdk

2

trove (libtrove-java) [for libaspectwerkz2-java]

no-default-jdk

2

asm3 (libasm3-java) [for libjarjar-java]

no-default-jdk

2

easymock (libeasymock-java) [for libhamcrest-java]

MIR sets

1: jibx asm2 janino / qdox jmock libow-util-ant-tasks (LP: #405715)
2: libaxiom-java dnsjava netty jug mvel slf4j xmlsecurity wss4j javassist (LP: #406346)
3: groovy / junit4 mockobjects xstream ivy commons-vfs libhamcrest-java easymock libjoda-time-java jarjar asm3
4: cglib2.1 / aspectwerkz2 concurrent-dfsg jrexx trove asm
5: geronimo-* (6 or 7)
6: jetty gwt / swt-gtk

Unconfirmed sets

Dep level

Package

Highlights

Reviewer

?

euca-commons-ext

?

Expected exceptional ones in there:

Dep level

Package

Highlights

Reviewer

?

euca-commons-ext

not-in-debian code-duplication security-review

?

jruby1.1

not-just-java

What could be expected to be refused inclusion to main

  • Active upstream criteria
    • Annogen
    • OpenSAML
    • WSS4J?
  • Known to be insecure
    • Nothing obvious
  • Partial builds (because of non-free dependencies)
    • Mule
    • We don't really care

Safety net

  • Keep a eucalyptus-javadeps package to drop in any problematic parts which can't be fixed (hibernate?).
    • One tiny part of Drools