FeistyToolchainRoadmap

Differences between revisions 1 and 4 (spanning 3 versions)
Revision 1 as of 2006-10-26 12:49:47
Size: 894
Editor: dslb-088-073-093-228
Comment: new spec
Revision 4 as of 2006-11-06 19:28:21
Size: 1916
Editor: 207
Comment: add implementation
Deletions are marked like this. Additions are marked like this.
Line 11: Line 11:
Define features and versions to use in feisty, demoting/removing old compiler versions, ...

==
Rationale ==

== Use cases ==

== Sc
ope ==

== Design ==
Define features and versions to use in feisty, demoting/removing old compiler versions; use
the upstream versions which are available now.
Line 23: Line 16:
=== Code ===

=== Data preservation and migration ===

== Unresolved issues ==
 * glibc: 2.5, as available in feisty.
 * binutils-2.17.0.50.6, as available in feisty.
 * gcc: 4.1, as available in feisty; upgrade to the 4.1.2 release or the 4.1.2 branch until UVF.
   * C++: backport the C++ visibility changes to 4.1; needs changes in packages to use this feature (i.e. KDE).
 * gcj: Decide before UVF about gcj-4.2 or gcj-4.1, depending on the upstream 4.2 release date. If 4.2 is released/in prerelease state, the java packages and libgcc[14] will be built from the gcj-4.2 sources.
 * Change the long double data type on sparc and powerpc from 64bit to 128bit.
   * Requires rebuild of packages exposing "long double" in the API of the package (Ldbl128Main, Ldbl128Universe)
   * Requires rebuild of packages using the changed ABI.
 * Demote gcc-3.4 from main; requires dropping g77 from main, and using gfortran to satisfy build-dependencies in main (fftw3, lapack3, python-numarray, python-numeric, refblas3).
Line 34: Line 31:
   * gcc-4.0
   * gcc-3.4 ?
 * long-double-128 change on powerpc and sparc
   * Ldbl128Main
   * Ldbl128Universe
 * Demote g77 to universe, build stuff using gfortran in main?

Please check the status of this specification in Launchpad before editing it. If it is Approved, contact the Assignee or another knowledgeable person before making changes.

  • Launchpad entry: none yet

  • Packages affected: gcc*, gcj*, glibc, binutils

Summary

Define features and versions to use in feisty, demoting/removing old compiler versions; use the upstream versions which are available now.

Implementation

  • glibc: 2.5, as available in feisty.
  • binutils-2.17.0.50.6, as available in feisty.
  • gcc: 4.1, as available in feisty; upgrade to the 4.1.2 release or the 4.1.2 branch until UVF.
    • C++: backport the C++ visibility changes to 4.1; needs changes in packages to use this feature (i.e. KDE).
  • gcj: Decide before UVF about gcj-4.2 or gcj-4.1, depending on the upstream 4.2 release date. If 4.2 is released/in prerelease state, the java packages and libgcc[14] will be built from the gcj-4.2 sources.
  • Change the long double data type on sparc and powerpc from 64bit to 128bit.
    • Requires rebuild of packages exposing "long double" in the API of the package (Ldbl128Main, Ldbl128Universe)

    • Requires rebuild of packages using the changed ABI.
  • Demote gcc-3.4 from main; requires dropping g77 from main, and using gfortran to satisfy build-dependencies in main (fftw3, lapack3, python-numarray, python-numeric, refblas3).

BoF agenda and discussion


CategorySpec

FeistyToolchainRoadmap (last edited 2008-08-06 16:28:12 by localhost)