Gwibber

Differences between revisions 9 and 11 (spanning 2 versions)
Revision 9 as of 2010-11-17 16:51:16
Size: 3236
Editor: davanum
Comment:
Revision 11 as of 2011-05-13 12:40:37
Size: 0
Editor: business-89-133-214-82
Comment: Very out of date!!!
Deletions are marked like this. Additions are marked like this.
Line 1: Line 1:
#format wiki
#language en
== Installing Gwibber ==

This is a guide to install the Gwibber micro-blogging client on Ubuntu.

=== From Universe for 9.04 Jaunty Jackalope ===

Gwibber is now available directly from Universe in Jaunty onwards.

Click [[apt:gwibber|here]] to install the ''gwibber'' package

=== From PPA for 8.10 Intrepid Ibex ===

Create a file called {{{/etc/apt/sources.list.d/gwibber.list}}}. It should contain the Gwibber PPA:

{{{
deb http://ppa.launchpad.net/gwibber-team/ubuntu intrepid main
deb-src http://ppa.launchpad.net/gwibber-team/ubuntu intrepid main
}}}

Now install the GPG key for Launchpad
{{{
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 5AFADBD4AA1C92B0 |sudo apt-key add -
}}}
that command should be run as one line.

Update your repository database list
{{{
sudo apt-get update
}}}

Then install the package ''gwibber''.

{{{
sudo apt-get install gwibber
}}}

=== From PPA for 8.04 Hardy Heron ===

----
{{{#!wiki
'''Caution'''

We recommend upgrading to Intrepid or Jaunty if you wish to use Gwibber. Installation on Hardy is currently unsupported.
}}}
----

Create a file called {{{/etc/apt/sources.list.d/gwibber.list}}}. It should contain the gwibber PPA:

{{{
deb http://ppa.launchpad.net/gwibber-team/ubuntu hardy main
deb-src http://ppa.launchpad.net/gwibber-team/ubuntu hardy main
}}}
and then the Webkit PPA:
{{{
deb http://ppa.launchpad.net/webkit-team/ubuntu hardy main
deb-src http://ppa.launchpad.net/webkit-team/ubuntu hardy main
}}}

Then install packages for libwebkit-1.0-1 python-webkitgtk python-egenix-mxdatetime and gwibber.

=== From Sources ===
 1. Install bazaar and subversion to download app and some needed libraries.
   {{{
sudo apt-get install bzr subversion
}}}
 1. ''(Hardy 8.04 only)'' Add the following PPA for Webkit to apt sources.list (/etc/apt/sources.list) or via '''System -> Administration -> Software Sources'''.
   {{{
deb http://ppa.launchpad.net/stemp/ubuntu hardy main
}}}
 1. Update
   {{{
$ sudo apt-get update
}}}
 1. Install webkit and development libraries
   {{{
$ sudo apt-get install libwebkit-1.0-1 libwebkit-dev
}}}
 1. Download pywebkitgtk
   {{{
$ svn checkout http://pywebkitgtk.googlecode.com/svn/trunk/ pywebkitgtk-read-only
}}}
 1. Install needed libraries and programs to compile pywebkitgtk.
   {{{
$ sudo apt-get install build-essential autoconf automake libtool libgtk2.0-dev python-dev python-gtk2 python-gtk2-dev libsexy2 libsexy-dev python-sexy libxslt1-dev
}}}
 1. Goto pywebkitgtk-read-only directory - Configure, compile and install pywebkitgtk.
   {{{
$ . cd pywebkitgtk-read-only
$ ./autogen.sh --prefix=/usr/local
$ make
$ sudo make install
}}}
 1. Install need libraries and programs for gwibber
   {{{
$ sudo apt-get install python-cairo-dev python-simplejson python-egenix-mxdatetime python-feedparser python-wnck python-desktopcouch
}}}
 1. Download gwibber webkitui
   {{{
$ cd ~
$ bzr branch lp:gwibber
}}}
 1. Goto /gwibber/bin directory to run gwibber
   {{{
$ cd ~/gwibber/
$ ./bin/gwibber-service &
$ ./bin/gwibber
}}}
 1. or install
   {{{
sudo python setup.py install
}}}

Gwibber (last edited 2011-05-24 12:57:37 by redtux2000)