Gwibber

Revision 4 as of 2009-03-23 13:35:16

Clear message

Installing Gwibber

This is a guide to install the Gwibber micro-blogging client on Ubuntu.

From Universe for 9.04 Jaunty Jackalope

Gwibber is now available directly from Universe in Jaunty onwards.

http://packages.ubuntu.com/jaunty/gwibber

From PPA for 8.10 Intrepid Ibex

Create a file called /etc/apt/sources.list.d/gwibber.list. It should contain the gwibber PPA:

deb http://ppa.launchpad.net/gwibber-team/ubuntu intrepid main
deb-src http://ppa.launchpad.net/gwibber-team/ubuntu intrepid main

Now install the GPG key for Launchpad

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com         5AFADBD4AA1C92B0 |sudo apt-key add -

that command should be run as one line.

Update your repository database list

sudo apt-get update

Then install the package gwibber. You don't need the webkit PPA or anything like that.

sudo apt-get install gwibber

From PPA for 8.04 Hardy Heron

Create a file called /etc/apt/sources.list.d/gwibber.list. It should contain the gwibber PPA:

deb http://ppa.launchpad.net/gwibber-team/ubuntu hardy main
deb-src http://ppa.launchpad.net/gwibber-team/ubuntu hardy main

and then the Webkit PPA:

deb http://ppa.launchpad.net/webkit-team/ubuntu hardy main
deb-src http://ppa.launchpad.net/webkit-team/ubuntu hardy main

Then install packages for libwebkit-1.0-1 python-webkitgtk python-egenix-mxdatetime and gwibber.

From Sources

  1. Install bazaar and subversion to download app and some needed libraries.
    • sudo apt-get install bzr subversion
  2. (Hardy 8.04 only) Add the following PPA for Webkit to apt sources.list (/etc/apt/sources.list) or via System -> Administration -> Software Sources.

    • deb http://ppa.launchpad.net/stemp/ubuntu hardy main
  3. Update
    • $ sudo apt-get update
  4. Install webkit and development libraries
    • $ sudo apt-get install libwebkit-1.0-1 libwebkit-dev
  5. Download pywebkitgtk
    • $ svn checkout http://pywebkitgtk.googlecode.com/svn/trunk/ pywebkitgtk-read-only
  6. Install needed libraries and programs to compile pywebkitgtk.
    • $ sudo apt-get install build-essential autoconf automake libtool libgtk2.0-dev python-dev python-gtk2 python-gtk2-dev libsexy2 libsexy-dev python-sexy libxslt1-dev 
  7. Goto pywebkitgtk-read-only directory - Configure, compile and install pywebkitgtk.
    • $ . cd pywebkitgtk-read-only
      $ ./autogen.sh --prefix=/usr/local
      $ make
      $ sudo make install
  8. Install need libraries and programs for gwibber
    • $ sudo apt-get install python-cairo-dev python-simplejson python-egenix-mxdatetime python-feedparser
  9. Download gwibber webkitui
    • $ cd ~
      $ bzr branch lp:gwibber
  10. Goto /gwibber/bin directory to run gwibber
    • $ cd ~/gwibber/bin
      $ ./gwibber
  11. or install
    • sudo python setup.py install