fr

Differences between revisions 22 and 24 (spanning 2 versions)
Revision 22 as of 2008-10-31 13:22:36
Size: 26829
Editor: rab34-1-82-224-146-64
Comment:
Revision 24 as of 2008-10-31 16:46:10
Size: 24025
Editor: rab34-1-82-224-146-64
Comment:
Deletions are marked like this. Additions are marked like this.
Line 18: Line 18:
Si un utilisateur parcours un disque dur en mode « Live CD » avant l'installation, Ubiquity ne permettra pas l'installation sur ce disque car les disques ne peuvent pas être partitionnés s'ils ont des partitions montées. Vous devre d'abord démonter ces partitions avant de pouvoir effectuer une installation. Si un utilisateur parcours un disque dur en mode « Live CD » avant l'installation, Ubiquity ne permettra pas l'installation sur ce disque car les disques ne peuvent pas être partitionnés s'ils ont des partitions montées. Vous devrez d'abord démonter ces partitions avant de pouvoir effectuer une installation.
Line 38: Line 38:
L'outil de configuration OEM pour l'utilisateur final gère mal la sélection de langues qui n'utilisent pas les jeux de caractères ASCII ou ISO-8859-1, et l'utilisateur final se retrouvera sans traduction après avoir sélectionné une de ces langues. La liste des langues connues comme fonctionelles est la suivante : basque, catalan, danois,néerlandais, anglais, finnois, français, galicien, allemand, indonesien, italien, sami du Nord, norvégien bokmål, norvégien nynorsk, portugais, portugais (Brésil), espagnol, suédois, tagalog. L'outil de configuration OEM pour l'utilisateur final gère mal la sélection de langues qui n'utilisent pas les jeux de caractères ASCII ou ISO-8859-1, et l'utilisateur final se retrouvera sans traduction après avoir sélectionné une de ces langues. La liste des langues connues comme fonctionnelles est la suivante : basque, catalan, danois,néerlandais, anglais, finnois, français, galicien, allemand, indonésien, italien, sami du Nord, norvégien bokmål, norvégien nynorsk, portugais, portugais (Brésil), espagnol, suédois, tagalog.
Line 42: Line 42:
== MID image requires a network for successful installation ==

When trying to install the Ubuntu MID (Mobile Internet Device) image without a network, the installer displays a pop-up dialog in a loop near the end of the installation while scanning the archive. The only way to break this loop is to connect to a network ([[https://launchpad.net/bugs/288320|bug 288320]]).
== Échec de l'installation MID sans réseau ==

Lorsque l'on essaie d'installer une image Ubuntu MID (Mobile Internet Device) sans réseau, l'installeur affiche en boucle une boîte de dialogue lors de l'analyse de l'archive vers la fin de l'installation. La seule manière de sortie de cette boucle est de se connecter à un réseau ([[https://launchpad.net/bugs/288320|bug 288320]]).
Line 48: Line 49:
En accord avec le guide de la politique Debian (qui indique que le champ « recommandés » doit lister les paquets qui devraient toujours être installés avec celui-ci, sauf cas exceptionnel), le système de gestion des paquets installe maintenant par défaut aussi bien les paquets listés dans le champ « recommandés » que ceux ceux du champ « dépendances ». Si vous voulez éviter ceci pour certains paquets, utilisez `apt-get --no-install-recommends`. Si vous voulez rendre cela définitif, modifiez l'entrée `APT::Install-Recommends` du fichier `/etc/apt/apt.conf`, mais soyez conscient que des fonctionnalités risquent d'être alors absentes dans certains logiciels. En accord avec le guide de la politique Debian (qui indique que le champ « recommandés » doit lister les paquets qui devraient toujours être installés avec celui-ci, sauf cas exceptionnel), le système de gestion des paquets installe maintenant par défaut aussi bien les paquets listés dans le champ « recommandés » que ceux ceux du champ « dépendances ». Si vous voulez éviter ceci pour certains paquets, utilisez `apt-get --no-install-recommends`. Si vous voulez rendre cela définitif, ajoutez l'entrée `APT::Install-Recommends "false"` au fichier `/etc/apt/apt.conf` (créez ce fichier s'il n'existe pas), mais soyez conscient que des fonctionnalités risquent d'être alors absentes dans certains logiciels.
Line 52: Line 53:

Users of the alternate/server installation who choose a password containing a "%" or a "-" will end up with an encrypted ~/Private directory that will not mount on reboot and subsequent logins. To fix this, affected users will need to do the following in the newly installed system:
 1. Update ecryptfs-utils to at least version 53-1ubuntu12 (as soon as it becomes available as a package update)
 2. Run: {{{$ ecryptfs-setup-private --force}}}
Line 61: Line 58:
Pour plus d'information sur ce bogue et un début de solution voir [[https://launchpad.net/bugs/290445|bug #290445]].

== Problème d'installation sur PlayStation 3 ==

There are some non-fatal issues with installation from the alternate install CD on Play``Station 3 systems. See the [[http://psubuntu.com/wiki/IntrepidReleaseNotes|PS3 release notes]] for more details.
Pour plus d'informations sur ce bogue et un début de solution voir [[https://launchpad.net/bugs/290445|bug #290445]].

== Problèmes d'installation sur PlayStation 3 ==
Line 75: Line 70:
Line 79: Line 73:
Line 90: Line 83:
Line 95: Line 87:
Line 100: Line 91:
== Toshiba laptop hotkey support ==

The {{{tlsup}}} kernel driver included in Linux 2.6.27 for support for Toshiba laptops is not compatible with the X.Org 1.5 event model, as a result of which hotkeys on these laptops are not usable with Ubuntu 8.10. This will be addressed in a post-release kernel update to reintroduce the {{{toshiba_acpi}}} driver.

== Echec au démarrage avec des cartes mères Intel D945 ==

Des utilisateurs ont signalé une détection plus lente que d'habitude des disques durs SATA sur les systèmes a base de carte mère Intel D945 avec Ubuntu 8.10. Cela peut bloquer le système sur l'invite de commande « busybox » de l'''initramfs'' avec une erreur "Gave up waiting for root device." (Abandon de l'attente du périphérique racine). Patientez une minute ou deux et quittez la console initramfs en tapant « exit ».
== Gestion des touches spéciales sur les portables Toshiba ==

Le pilote du noyau {{{tlsup}}} inclus dans Linux 2.6.27 pour la prise en charge des portables Toshiba n'est pas compatible avec le modèle évenementiel de X.Org 1.5. En conséquence, les touches spéciales de ces portables ne seront pas utilisables sous Ubuntu 8.10. Ce problème sera traité dans une future mise à jour du noyau qui réintroduira le pilote {{{toshiba_acpi}}}.

== Échec au démarrage avec des cartes mères Intel D945 ==

Des utilisateurs ont signalé une détection plus lente que d'habitude des disques durs SATA sur les systèmes a base de carte mère Intel D945 avec Ubuntu 8.10. Cela peut bloquer le système sur l'invite de commande « busybox » de l'initramfs' avec une erreur « Gave up waiting for root device » (Abandon de l'attente du périphérique racine). Patientez une minute ou deux et quittez la console initramfs en tapant « exit ».
Line 116: Line 107:
After an upgrade from Kubuntu 8.04 KDE 4 Remix, logging in will return directory to the login screen again. The {{{x-session-manager}}} alternative link is not correctly updated. Select "KDE" from the Session Menu before logging in and fix it with {{{update-alternatives --set x-session-manager /usr/bin/startkde}}}. ([[https://launchpad.net/bugs/287488|Bug 287488]])

Après une mise à jour depuis Kubuntu 8.04 KDE 4 Remix, la saisie de vos identifiants vous ramenera à l'écran de connexion. Le lien alternatif {{{x-session-manager}}} n'est pas correctement mis à jour. Choisissez "KDE3 depuis le Menu Session avant de vous connecter et corriger le avec un {{{update-alternatives --set x-session-manager /usr/bin/startkde}}}. ([[https://launchpad.net/bugs/287488|Bug 287488]])


== Support for ssl/blowfish-v0.2, version 2:0:1 not in encfs ==

Compatibility for this old algorithm was dropped in the 1.4.x version of {{{encfs}}} included in Ubuntu 8.10. Before upgrading, users of this algorithm will have to manually migrate their encfs volumes to a new one created with the new version. Alternatively, you may stay at an old version of encfs to be able to read the volumes.
Après une mise à jour depuis Kubuntu 8.04 KDE 4 Remix, la saisie de vos identifiants vous ramenera à l'écran de connexion. Le lien alternatif {{{x-session-manager}}} n'est pas correctement mis à jour. Choisissez « KDE » depuis le menu « Session » avant de vous connecter et corrigez-le avec la commande {{{update-alternatives --set x-session-manager /usr/bin/startkde}}}. ([[https://launchpad.net/bugs/287488|Bug 287488]])


== Pas de prise en charge ssl/blowfish-v0.2, version 2:0:1 dans encfs ==

La compatibilité avec cet ancien algorithme a été abandonnée dans la version 1.4 de {{{encfs}} fournie avec Ubuntu 8.10. Avant de mettre à jour, les utilisateurs de cet algorithme devront migrer manuellement leurs volumes encfs vers de nouveaux volumes créés avec la nouvelle version. Vous pouvez également conserver l'ancienne version encfs pour pouvoir accéder à vos volumes.
Line 127: Line 117:
The graphical boot splash must be turned off when upgrading Play``Station 3 systems from Ubuntu 8.04 ([[https://launchpad.net/bugs/285218|bug 285218]]). See the [[http://psubuntu.com/wiki/IntrepidReleaseNotes|PS3 release notes]] for more details.

L'image de démarrage graphique a du être désactivé lors de la mise à jour depuis Ubuntu 8.04 sur les systèmes Play``Station 3([[https://launchpad.net/bugs/285218|bug 285218]]). Voir [[http://psubuntu.com/wiki/IntrepidReleaseNotes|PS3 release notes]] pour plus de détails.

== Applet de déconnexion GNOME ==

Le bouton « Déconnexion » qui apparaissait par défaut en haut à droite de l'écran dans les versions précédentes d'Ubuntu n'offre plus désormais les options Éteindre/Redémarrer/Hiberner/Suspendre. Il est recommandé de supprimer cet applet et de le remplacer par l'applet « Changement d'utilisateur » qui combine les anciens applets « Changement d'utilisateur » et « Déconnexion ». Cette modification n'est pas encore automatisée durant la mise à jour (https://bugs.launchpad.net/bugs/274146).
L'écran graphique de démarrage doit être désactivé lors de la mise à jour depuis Ubuntu 8.04 sur les systèmes Play``Station 3([[https://launchpad.net/bugs/285218|bug 285218]]). Consultez [[http://psubuntu.com/wiki/IntrepidReleaseNotes|PS3 release notes]] pour plus de détails.
Line 142: Line 127:
== Blocage du système avec le wifi Intel 4965 ==

The version of the {{{iwlagn}}} wireless driver for Intel 4965 wireless chipsets included in Linux kernel version 2.6.27 causes kernel panics when used with 802.11n or 802.11g networks. Users affected by this issue can install the {{{linux-backports-modules-intrepid}}} package, to install a newer version of this driver that corrects the bug. (Because the known fix requires a new version of the driver, it is not expected to be possible to include this fix in the main kernel package.)

La version du pilotes wifi {{{iwlagn}}} pour les circuits Intel 4965 contenus dans le noyau Linux 2.6.27 provoques des paniques du noyau
quand il est employé avec des réseaux 802.11n ou 802.11g. les utilisateurs touchés par ce problème peuvent installer le paquet {{{linux-backports-modules-intrepid}}}, pour installer une nouvelle version du pilote qui corrige ce bogue. (Car le correctif connu requiert une nouvelle version du pilote, et qu'il n'est pas prévu d'inclure ce correctif dans le paquet principal du noyau.)
== Blocage du système avec les périphériques réseau sans-fil Intel 4965 ==

La version du pilote wifi {{{iwlagn}}} pour les circuits Intel 4965 inclus dans le noyau Linux 2.6.27 provoque des erreurs graves du noyau (kernel panic) quand il est employé avec des réseaux 802.11n ou 802.11g. Les utilisateurs touchés par ce problème peuvent installer le paquet {{{linux-backports-modules-intrepid}}}, pour installer une version plus récente du pilote qui corrige ce bogue. (Car le correctif connu requiert une nouvelle version du pilote, et qu'il n'est pas prévu d'inclure ce correctif dans le paquet principal du noyau.)
Line 152: Line 135:
== Le pilote wifi Atheros ath5k n'est pas activé par défaut ==

The version of the {{{ath5k}}} driver for Atheros wireless devices included in Linux 2.6.27 interferes with the use of the {{{madwifi}}} driver for some wireless devices and as a result has been disabled by default. Many Atheros chipsets will work correctly with the {{{madwifi}}} driver, but some newer chipsets may not, and the {{{madwifi}}} driver may not work with WPA authentication. If you have an Atheros device that does not work with {{{madwifi}}}, you will want to install the {{{linux-backports-modules-intrepid-generic}}} package, which includes an updated version of the {{{ath5k}}} driver. While not installed by default, this {{{linux-backports-modules-intrepid-generic}}} package is included on the Ubuntu 8.10 CD and DVD images for ease of installation.

La version du pilote wifi {{{ath5k}}} pour les périphériques Atheros inclus dans Linux 2.6.27 interfère avec l'utilisation du pilotes {{{madwifi}}} pour quelques périphériques wifi et par voie de conséquence a été désactivé par défaut. De nombreux circuits Atheros fonctionneront correctement avec le pilote {{{madwifi}}}, mais des circuits plus récents non, et le pilote {{{madwifi}}} ne fonctionnera pas avec l'authentification WPA. Si vous avez un périphérique Atheros qui ne fonctionne pas avec {{{madwifi}}}, vous voudrez installer le paquet {{{linux-backports-modules-intrepid-generic}}} qui contient une version plus à jour du pilote {{{ath5k}}}. Bien qu'il ne soit pas installé par défaut, le paquet {{{linux-backports-modules-intrepid-generic}}} est contenu sur les images CD et DVD d'Ubuntu 8.10 pour simplifier son installation.
== Le pilote réseau sans-fil Atheros ath5k n'est pas activé par défaut ==

La version du pilote wifi {{{ath5k}}} pour les périphériques Atheros inclus dans Linux 2.6.27 interfère avec l'utilisation du pilote {{{madwifi}}} pour certains périphériques réseau sans-fi. Il a donc été désactivé par défaut. De nombreux circuits Atheros fonctionneront correctement avec le pilote {{{madwifi}}}, mais des circuits plus récents non, et le pilote {{{madwifi}}} ne fonctionnera pas avec l'authentification WPA. Si vous avez un périphérique Atheros qui ne fonctionne pas avec {{{madwifi}}}, vous pourrez installer le paquet {{{linux-backports-modules-intrepid-generic}}} qui contient une version plus récente du pilote {{{ath5k}}}. Bien qu'il ne soit pas installé par défaut, le paquet {{{linux-backports-modules-intrepid-generic}}} est présent sur les images CD et DVD d'Ubuntu 8.10 pour faciliter son installation.


Contents

  1. Configuration minimale
  2. Installation
    1. Les disques durs pourraient ne pas s'afficher en mode « Live CD »
    2. L'option « logiciels libres seulement » installe des logiciels propriétaires
    3. Démarrage lent durant l'étape « Sélectionner et installer des logiciels » dans l'installateur en mode texte
    4. oem-config n'arrive pas à gérer certaines langues correctement
    5. Échec de l'installation MID sans réseau
    6. Paquets recommandés installés par défaut
    7. Limitation de mots de passe avec ecryptfs
    8. Problèmes d'installation sur PlayStation 3
  3. Mise à niveau
    1. Prise en charge des anciennes cartes Nvidia
    2. Prise en charge des cartes ATI avec « fglrx »
    3. Périphériques d'entrée pour X.Org
    4. Incompatibilité X.Org entre evdev et xmodmap
    5. Prise en charge du noyau temps réel (rt) pour UbuntuStudio
    6. Gestion des touches spéciales sur les portables Toshiba
    7. Échec au démarrage avec des cartes mères Intel D945
    8. Kubuntu KDE4 remix
      1. Impossible de se connecter après la mise à jour depuis Kubuntu 8.04 KDE 4 Remix
    9. Pas de prise en charge ssl/blowfish-v0.2, version 2:0:1 dans encfs
    10. Problème de mise à jour sur PlayStation 3
  4. Autres problèmes connus
    1. Blocage du système avec les périphériques réseau sans-fil Intel 4965
    2. Cannot reactivate Intel 3945/4965 wireless if booting with killswitch enabled
    3. Le pilote réseau sans-fil Atheros ath5k n'est pas activé par défaut
    4. Limited support for Wacom tablet hotplugging
    5. iSCSI boot order
    6. Cannot mount more than one iSCSI target
    7. Wireless doesn't work after suspend with ath_pci driver
    8. Systems installed from pre-release daily images may be missing some files
    9. Kubuntu Bluetooth support
    10. KNetworkManager cannot manage connections with static IPs
    11. Utiliser l'outil usb-creator avec des images 8.04.1 (Hardy)
    12. Only US wireless channels enabled by default on Intel 3945
    13. Cyrus SASL database created with incorrect permissions
    14. Accès au Java Runtime Environment
    15. CD eject problems
    16. Hangs with desktop effects on Intel 830MG and 845G video cards
    17. PlayStation 3 issues
    18. iSCSI boot order

Ces notes de publication recensent les problèmes connus pour Ubuntu 8.10 et ses variantes.

Configuration minimale

Ubuntu 8.10 requiert un minimum de 256 Mo de mémoire. (Notez bien qu'une partie de la mémoire de votre ordinateur peut être utilisée par la carte graphique et ne pas être disponible pour le système.)

Si vous ne disposez que du minimum de mémoire requis, l'installation prendra plus de temps mais s'achèvera normalement, et le système fonctionnera correctement une fois installé. Si votre système dispose de peu de mémoire, nous vous conseillons de procéder à l'installation en sélectionnant « Installer Ubuntu » depuis le menu de démarrage du CD « Desktop », plutôt que de lancer l'environnement de bureau complet en sélectionnant « Essayer Ubuntu sans rien modifier sur l'ordinateur ».

Installation

Les disques durs pourraient ne pas s'afficher en mode « Live CD »

Si un utilisateur parcours un disque dur en mode « Live CD » avant l'installation, Ubiquity ne permettra pas l'installation sur ce disque car les disques ne peuvent pas être partitionnés s'ils ont des partitions montées. Vous devrez d'abord démonter ces partitions avant de pouvoir effectuer une installation.

L'option « logiciels libres seulement » installe des logiciels propriétaires

L'option « logiciels libres seulement » disponible en appuyant deux fois sur F6 au premier écran du CD/DVD « desktop », installera le paquet restreint linux-restricted-modules-2.6.27-7-generic par erreur. Ceci peut être contourné en désinstallant le paquet linux-restricted-modules-2.6.27-7-generic une fois l'installation du système terminée.

L'option « logiciels libres seulement » n'installera aucun autre logiciel propriétaire.

Pour plus de renseignements, consultez le Bug 290925 [en]

Démarrage lent durant l'étape « Sélectionner et installer des logiciels » dans l'installateur en mode texte

L'étape « Sélectionner et installer des logiciels » durant l'installation sur CD en mode texte pourrait se bloquer à quelques pour cents. Ceci est particulièrement le cas pour les installations en réseau (netboot), où il n'y aura pas de barre de progression durant le téléchargement des paquets. Ceci est dû à un problème d'interaction entre l'installateur et apt-get qui fut diagnostiqué trop tard pour être corrigé dans Ubuntu 8.10 : bug 290234.

Vous pouvez savoir si l'installateur est en cours d'avancement en utilisant Alt-F4 pour passer dans la console de suivi ; Alt-F1 permet de revenir à l'installation principale. (Si vous faites une installation dans QEMU ou KVM, assure-vous d'avoir utilisé la combinaison de touches Ctrl+Alt ou d'avoir cliqué dans la fenêtre pour que l'émulateur ait le focus avant d'utiliser Alt+F4, sinon vous fermerez l'émulateur !)

oem-config n'arrive pas à gérer certaines langues correctement

L'outil de configuration OEM pour l'utilisateur final gère mal la sélection de langues qui n'utilisent pas les jeux de caractères ASCII ou ISO-8859-1, et l'utilisateur final se retrouvera sans traduction après avoir sélectionné une de ces langues. La liste des langues connues comme fonctionnelles est la suivante : basque, catalan, danois,néerlandais, anglais, finnois, français, galicien, allemand, indonésien, italien, sami du Nord, norvégien bokmål, norvégien nynorsk, portugais, portugais (Brésil), espagnol, suédois, tagalog.

Pour le moment, les OEMs touchés par ce problème devront appliquer ce patch (la partie scripts/tzsetup) sur le fichier /usr/lib/oem-config/timezone/tzsetup avant de lancer « Préparer pour la livraison pour l'utilisateur final ». Nous comptons publier une mise à jour pour ceci d'ici peu, qui sera installable via le système de paquets au même moment.

Échec de l'installation MID sans réseau

Lorsque l'on essaie d'installer une image Ubuntu MID (Mobile Internet Device) sans réseau, l'installeur affiche en boucle une boîte de dialogue lors de l'analyse de l'archive vers la fin de l'installation. La seule manière de sortie de cette boucle est de se connecter à un réseau (bug 288320).

Paquets recommandés installés par défaut

En accord avec le guide de la politique Debian (qui indique que le champ « recommandés » doit lister les paquets qui devraient toujours être installés avec celui-ci, sauf cas exceptionnel), le système de gestion des paquets installe maintenant par défaut aussi bien les paquets listés dans le champ « recommandés » que ceux ceux du champ « dépendances ». Si vous voulez éviter ceci pour certains paquets, utilisez apt-get --no-install-recommends. Si vous voulez rendre cela définitif, ajoutez l'entrée APT::Install-Recommends "false" au fichier /etc/apt/apt.conf (créez ce fichier s'il n'existe pas), mais soyez conscient que des fonctionnalités risquent d'être alors absentes dans certains logiciels.

Limitation de mots de passe avec ecryptfs

Les utilisateurs des installations « alternate/server » qui choisissent un mot de passe contenant un "%" ou un "-" obtiendront un repertoire chiffré ~/Private qui ne sera pas monté au redémarrage ni aux connexions suivantes. Pour corriger cela, les utisateurs touchés devront effectuer les étapes suivantes sur un système fraîchement installé :

  1. mettre à jour ecryptfs-utils en version 53-1ubuntu12 au minimum (dès que le paquet de mise à jour sera disponible) ;
  2. exécuter : $ ecryptfs-setup-private --force.

Pour plus d'informations sur ce bogue et un début de solution voir bug #290445.

Problèmes d'installation sur PlayStation 3

Il y a quelques problèmes non bloquants avec l'installation depuis le CD alternate sur les PlayStation 3. Voir PS3 release notes pour plus de détails.

Mise à niveau

Les utilisateurs d'Ubuntu 8.04 LTS peuvent mettre à niveau leur distribution vers la version 8.10 grâce à un processus automatisé. Pour ceux qui utilisent une version plus ancienne, il faudra d'abord effectuer une mise à niveau vers Ubuntu 8.04 LTS, puis vers la version 8.10. Les instructions complètes peuvent être consultées sur http://www.ubuntu.com/getubuntu/upgrading [en].

Prise en charge des anciennes cartes Nvidia

Les séries 71 et 96 des pilotes propriétaires nVidia, proposés par les paquets nvidia-glx-legacy et nvidia-glx dans Ubuntu 8.04 LTS, ne sont pas compatibles avec la version du serveur X.Org incluse dans Ubuntu 8.10. Les utilisateurs de cartes graphiques à base de nVidia TNT, TNT2, TNT Ultra, GeForce, GeForce2, GeForce3, et GeForce4 sont concernés, et leur pilote sera remplacé par le pilote libre nv lors de la mise à jour. Ce pilote ne prend pas en charge l'accélération 3D.

Les utilisateurs dont les cartes graphiques sont prises en charge par les pilotes des séries 173 ou 177 se verront proposer les paquets nvidia-glx-173 ou nvidia-glx-177 à la place. Cependant, à la différence des pilotes 96 et 71, les pilotes 173 et 177 ne sont compatibles qu'avec les processeurs gérant les SSE (les Intel Pentium III, AMD Athlon XP ou plus récent). Les systèmes avec des processeurs plus anciens seront configurés pour utiliser le pilote nv durant la mise à jour.

Prise en charge des cartes ATI avec « fglrx »

Le pilote graphique ATI dans Ubuntu 8.10 abandonne la prise en charge des cartes basées sur les circuits r300 (les séries de cartes Radeon 9500 - X600). Si vous avez une telle carte, veuillez utiliser « Pilotes de périphériques » dans le menu Système/Administration pour le désactiver avant la mise à jour. Consultez bug 284408 pour plus d'informations.

Périphériques d'entrée pour X.Org

Le fichier de configuration de X.org (/etc/X11/xorg.conf) contient toujours les entrées InputDevice pour la souris et le clavier, mais celles-ci sont désormais ignorées et remplacées par une détection automatique du périphérique lors de son branchement. Les réglages du clavier proviennent maintenant de /etc/default/console-setup ; pour les modifier veuillez employer sudo dpkg-reconfigure console-setup. Après quoi, HAL et X devront être redemarrés (par exemple en redémarrant votre système).

Incompatibilité X.Org entre evdev et xmodmap

Les codes de touche X générés par le nouveau pilote evdev dans X.Org 1.5 ne sont pas compatibles avec ceux générés dans Ubuntu 8.04 LTS (et versions précédentes). Si vous aviez créé des combinaisons de touches (keybindings) spécifiques à l'aide de ~/.Xmodmap, vous devrez les convertir ou les désactiver à la main.

Prise en charge du noyau temps réel (rt) pour UbuntuStudio

Aucune version temps réel du noyau Linux 2.6.27 n'est disponible dans Ubuntu 8.10. Nous recommandons aux utilisateurs d'UbuntuStudio 8.04 qui ont besoin d'un noyau temps réel de ne pas mettre à jour vers UbuntuStudio 8.10.

Gestion des touches spéciales sur les portables Toshiba

Le pilote du noyau tlsup inclus dans Linux 2.6.27 pour la prise en charge des portables Toshiba n'est pas compatible avec le modèle évenementiel de X.Org 1.5. En conséquence, les touches spéciales de ces portables ne seront pas utilisables sous Ubuntu 8.10. Ce problème sera traité dans une future mise à jour du noyau qui réintroduira le pilote toshiba_acpi.

Échec au démarrage avec des cartes mères Intel D945

Des utilisateurs ont signalé une détection plus lente que d'habitude des disques durs SATA sur les systèmes a base de carte mère Intel D945 avec Ubuntu 8.10. Cela peut bloquer le système sur l'invite de commande « busybox » de l'initramfs' avec une erreur « Gave up waiting for root device » (Abandon de l'attente du périphérique racine). Patientez une minute ou deux et quittez la console initramfs en tapant « exit ». Le démarrage devrait continuer normalement. Si ce n'est pas le cas, attendez un peu plus et réessayez. Une fois que le système démarre, modifiez le fichier /boot/grub/menu.lst en ajoutant rootdelay=90 à la ligne kernel concernant votre noyau actuel. (Bug 290153).

Kubuntu KDE4 remix

Dans certains cas la mise à jour depuis une Kubuntu 8.04 KDE 4 Remix vers Kubuntu 8.10 ne mettra pas toutes les applications à jour. Ceci arrivera si le paquet kubuntu-desktop a été supprimé. Nous vous recommandons de vous assurer de la présence de kubuntu-desktop, et si KDE 4 est aussi installé que kubuntu-kde4-desktop est installé, avant la mise à jour. Si vous utilisez l'outil de mise à jour, cela sera géré automatiquement.

Impossible de se connecter après la mise à jour depuis Kubuntu 8.04 KDE 4 Remix

Après une mise à jour depuis Kubuntu 8.04 KDE 4 Remix, la saisie de vos identifiants vous ramenera à l'écran de connexion. Le lien alternatif x-session-manager n'est pas correctement mis à jour. Choisissez « KDE » depuis le menu « Session » avant de vous connecter et corrigez-le avec la commande update-alternatives --set x-session-manager /usr/bin/startkde. (Bug 287488)

Pas de prise en charge ssl/blowfish-v0.2, version 2:0:1 dans encfs

La compatibilité avec cet ancien algorithme a été abandonnée dans la version 1.4 de {encfs fournie avec Ubuntu 8.10. Avant de mettre à jour, les utilisateurs de cet algorithme devront migrer manuellement leurs volumes encfs vers de nouveaux volumes créés avec la nouvelle version. Vous pouvez également conserver l'ancienne version encfs pour pouvoir accéder à vos volumes.

Problème de mise à jour sur PlayStation 3

L'écran graphique de démarrage doit être désactivé lors de la mise à jour depuis Ubuntu 8.04 sur les systèmes PlayStation 3(bug 285218). Consultez PS3 release notes pour plus de détails.

Autres problèmes connus

Blocage du système avec les périphériques réseau sans-fil Intel 4965

La version du pilote wifi iwlagn pour les circuits Intel 4965 inclus dans le noyau Linux 2.6.27 provoque des erreurs graves du noyau (kernel panic) quand il est employé avec des réseaux 802.11n ou 802.11g. Les utilisateurs touchés par ce problème peuvent installer le paquet linux-backports-modules-intrepid, pour installer une version plus récente du pilote qui corrige ce bogue. (Car le correctif connu requiert une nouvelle version du pilote, et qu'il n'est pas prévu d'inclure ce correctif dans le paquet principal du noyau.)

Cannot reactivate Intel 3945/4965 wireless if booting with killswitch enabled

On laptops with Intel 3945 or Intel 4965 wireless chipsets and a killswitch for the wireless antenna, starting the system with the killswitch enabled (i.e., with wireless disabled) will prevent re-enabling the wireless by toggling the killswitch. As a workaround, users should boot the system with the killswitch disabled. A future kernel update is expected to address this issue.

Le pilote réseau sans-fil Atheros ath5k n'est pas activé par défaut

La version du pilote wifi ath5k pour les périphériques Atheros inclus dans Linux 2.6.27 interfère avec l'utilisation du pilote madwifi pour certains périphériques réseau sans-fi. Il a donc été désactivé par défaut. De nombreux circuits Atheros fonctionneront correctement avec le pilote madwifi, mais des circuits plus récents non, et le pilote madwifi ne fonctionnera pas avec l'authentification WPA. Si vous avez un périphérique Atheros qui ne fonctionne pas avec madwifi, vous pourrez installer le paquet linux-backports-modules-intrepid-generic qui contient une version plus récente du pilote ath5k. Bien qu'il ne soit pas installé par défaut, le paquet linux-backports-modules-intrepid-generic est présent sur les images CD et DVD d'Ubuntu 8.10 pour faciliter son installation.

Limited support for Wacom tablet hotplugging

X.Org 1.5 includes support for autodetection of input devices, but for Wacom tablets this is currently limited to detecting the stylus only. Users of tablet devices who wish to use other input features will need to statically configure their input devices in /etc/X11/xorg.conf.

A complete discussion of this issue can be found in bug 282203.

iSCSI boot order

File systems hosted on iSCSI targets may not be mounted automatically at boot time, even if they have an entry in /etc/fstab, if a bridged or bonded Ethernet interface is required to reach the iSCSI target. As a work-around, you would have to restart the open-iscsi service and manually mount the file system in question after system boot, once the required network interface have been brought up. Systems equipped with a plain Ethernet interface are not affected.

See bug 227848.

Cannot mount more than one iSCSI target

Mounting multiple iSCSI targets at the same time is currently not supported. Systems configured to use more than one iSCSI targets should not be upgraded to Ubuntu 8.10.

For more information on the bug and solution approach see bug 289470.

Wireless doesn't work after suspend with ath_pci driver

Wireless devices that use the ath_pci kernel driver, such as the Atheros AR5212 wireless card, will be unable to connect to the network after using suspend and resume. To work around this issue, users can create a file /etc/pm/config.d/madwifi containing the single line:

   SUSPEND_MODULES=ath_pci

This will cause the module to be unloaded before suspend and reloaded on resume.

Systems installed from pre-release daily images may be missing some files

A bug present in pre-release daily desktop images caused some files related to language support to be missing from installed systems. Uninstalling and reinstalling the language support packages should correct this issue.

This issue does not affect users who installed using the Ubuntu 8.10 Beta or Release Candidate.

Kubuntu Bluetooth support

Bluetooth is not supported in Kubuntu 8.10 because KDE does not yet support the bluez 4.x stack required for compatibility with the kernel used in 8.10. A fix for this is being evaluated as a post-release update. (Bug 280997)

KNetworkManager cannot manage connections with static IPs

KNetworkManager in Kubuntu 8.10 sometimes fails with network connections that require static IP address configuration (bug 280762). Connections which use DHCP for IP address configuration are not affected by this problem.

Utiliser l'outil usb-creator avec des images 8.04.1 (Hardy)

Persistence support in 8.04.1 images is broken. Creating a USB disk with usb-creator and an 8.04.1 image results in a busybox prompt if the persistence option is checked.

Le support de la persistence pour les images 8.04.1 est cassé. Créer un disque USB avec l'usb-creator et une image de 8.04.1 résulterat en une invite busybox si la option de persistence est cochée.

Only US wireless channels enabled by default on Intel 3945

The iwl3945 wireless driver defaults to the US regulatory domain for wireless, so wireless networks on channels forbidden by US regulations but permitted by European or Japanese regulations will not work out of the box. This affects IEEE 802.11b/g channels 12 (Europe and Japan), 13 (Europe and Japan), and 14 (Japan only), as well as all 802.11a channels. (Some other wireless drivers may be affected; this is the only one we are sure of so far.)

To work around this, add the following line to the /etc/modprobe.d/options file if you use this driver and need to use European wireless channels:

options cfg80211 ieee80211_regdom=EU

Alternatively, add the following line if you use this driver and need to use Japanese wireless channels:

options cfg80211 ieee80211_regdom=JP

Cyrus SASL database created with incorrect permissions

Cyrus SASL creates the database for its sasldb2 plugin with incorrect permissions. As a result, other users of this database, such as cyrus-imap, will not be able to access it and will fail. This does not affect upgrades of existing databases from a previous release. The workaround is to manually change the group of /etc/sasldb2 to sasl:

$ sudo chgrp sasl /etc/sasldb2

See bug 288478 for details.

Accès au Java Runtime Environment

To use Java programs, you need to install the openjdk-6-jre package whch contains the Java Runtime Environment. If you want to develop Java programs, then install the openjdk-6-jdk package. To work with Java applets in the Firefox browser and compatible browsers on x86 architectures, you need to install the icedtea6-plugin package by hand.

Pour utiliser des programmes en Java, vous devez installer le paquet openjdk-6-jre qui contient le Java Runtime Environment. Si vous voulez développer des programmes en Java, alors il faut installer le paquet openjdk-6-jdk. Pour travailler avec les appliquettes Java dans le navigateur Firefox et des navigateurs compatibles sur les architectures x86, vous devez installer manuellement le paquet icedtea6-plugin.

The JRE and the Java applet plugin are installed by default in the live session on the Ubuntu DVD, but are not currently installed elsewhere due to space constraints. However, a missing feature in the installer means that these packages will not be installed when installing using the graphical installer on the DVD, so you will need to install them afterwards.

Les paquets JRE et greffon pour appliquettes Java sont installés par défaut dans la session Live du DVD Ubuntu, mais ne le sont pas ailleurs pour des raisons d'espace. Cependant une [[https://launchpad.net/bugs/290400|fonctionnalité manquante] dans l'installateur signifie que les paquets ne seront pas installé avec l'installateur graphique du DVD, et que donc il faudra les installer par la suite.

CD eject problems

After ejecting a CD tray containing a disc, the tray will be immediately retracted, making it difficult to remove the disc (bug 283316). This can be worked around by pressing the eject button again before the disc is fully mounted, after which it will stay open. We expect to fix this in a post-release update.

Hangs with desktop effects on Intel 830MG and 845G video cards

There is a bug in the Intel video driver for the older intel 830 and 845 integrated video cards that are used on laptops like the IBM R30. Desktop effects with compiz will not work on those chips and will freeze the system. For new installations, please install using the safe graphics mode (press F4 in the startup screen) on these systems and disable desktop effects via System -> Preferences -> Appearance, clicking on "Visual effects" and choosing "None".

PlayStation 3 issues

There are a variety of other known issues affecting PlayStation 3 systems, documented in more detail in the PS3 release notes. They include:

  • To get back to the Sony PlayStation 3 XMB operating system from the boot prompt, users need to type game and press the Return key (bug 277839). If this is for some reason not possible, carrying out a hard-reset (see PS3 instruction manual) will return to the XMB on next run.

  • Users may occasionally see an intermittent shutdown hang with a message like "IRQ 50: nobody cared". The problem has been reported upstream. Press and hold the PS3 power button until you hear 2 beeps will force power off. The system will boot normally on next run (bug 220370).

  • NetworkManager does not list available wireless networks, although it is possible to connect to a wireless network with a known SSID using the "connect to hidden wireless network" option (bug 289977); and it cannot connect to WPA/WPA2 wireless networks, although WEP works (bug 289982).

iSCSI boot order

Les systèmes de fichiers placés sur des ressources iSCSI peuvent ne pas être montés automatiquement lors de démarrage, même s'ils sont déclarés dans /etc/fstab, si une interface Ethernet de type pont (bridged) ou de type lié (bonded) est requis pour accéder à la ressource iSCSI. Pour contourner cela, vous devrez relancer le service open-iscsi et monter manuellement le système de fichier en question après que l'interface Ethernet ait été activée. Les systèmes disposant d'une Interface Ethernet classique ne sont pas affectés.

Consultez bug #227848 [en].

IntrepidReleaseNotes/fr (last edited 2008-11-02 13:58:22 by jean-peyratout)