0.0+svn1002781-0ubuntu1~ppa1

Install plasma-widget-networkmanagement from https://edge.launchpad.net/~jr/+archive/ppa and run knetworkmanager

Keep failed tests please at the top of each result table. In general keep success and fails grouped together (the former at the bottom and the latter at the top of each table).

Case 0.0 / Ethernet / DHCP

  1. Plug in ethernet cable
  2. Icon should form cycle
  3. Icon should show "plugged-in"
  4. Click Widget and check shown data
  5. Unplug ethernet cable
  6. Icon should show "unplugged"

Tester

Broken

Details

Same problem in 9.04

Bug number

Comment

JontheEchidna

No

worked fine

N/A

N/A

Works fine, just like it did in 9.04

djmaze

No

worked fine

N/A

N/A

Works fine

Case 0.1 / Ethernet / Manual

  1. Manage connections; and add a new wired connection with manual IP
  2. Check that icon shows "plugged-in"
  3. Check that the connection uses that IP (ifconfig)
  4. Unplug cable and plug it in again; is the manual IP still being used.
  5. Restart the computer; is the settings remembered and gets used

Tester

Broken

Details

Same problem in 9.04

Bug number

Comment

djmaze

Yes

dhclient gone, DHCP address continues to be active

No

N/A

daemon.log says "Policy set 'Auto eth0' (eth0) as default for routing and DNS" upon plugging in

Case 1.0 / Wireless / DHCP

  1. Ensure WiFi network is not protected

  2. Click Widget
  3. Select WiFi network to connect to

  4. Icon should form cycle
  5. Icon should form antenna
  6. Click Widget and check shown data
  7. Move further away from AccessPoint

  8. Ensure signal strength display gets updated after some time

Tester

Broken

Details

Same problem in 9.04

Bug number

Comment

Case 1.1 / Wireless(protected) / DHCP

  1. Use same test-procedure as in case 1.0
  2. Do you get asked about the connection-details for the network and gets connected to the network
  3. After being disconnected from the network is your connection details remembered (clicking the network next time works without providing password an extra time)

note: Please list which encryption is used under details

Tester

Broken

Details

Same problem in 9.04

Bug number

Comment

bernardo-bandos

Yes

WPA2 PSK

No

#392593

According to syslog, fails on 4-way association

djmaze

Yes

WPA PSK

No

#392593

Same problem as bernardo-bandos. Error messages like in bug report

JonathanRiddell

No

WEP Hex

Case 1.2 / Wireless(hidden) / DHCP

  1. Add a new wireless connection to a hidden essid
  2. Do you get asked about the connection-details for the network and gets connected to the network
  3. After being disconnected from the network is your connection details remembered (clicking the network next time works without providing password an extra time)

note: Please list which encryption is used under details

Tester

Broken

Details

Same problem in 9.04

Bug number

Comment

Case 2.0 / VPN / DHCP

  1. Can anyone get this to work?

Tester

Broken

Details

Same problem in 9.04

Bug number

Comment

_lucas_

Yes Broken

https://bugs.kde.org/show_bug.cgi?id=188489

Kubuntu/PlasmaWidgetNetworkManager/0.0+svn1002781-0ubuntu1~ppa1 (last edited 2009-07-31 16:16:35 by maze)