MSI X320

Laptop model

Hardware details

  • Processor: Intel Atom Z530 1.6GHz
  • Memory: 2Gb DDR667
  • Chipset: Intel US15W (Poulsbo)
  • Video: Intel GMA500
  • Screen: 13.4" 16:9 Wide Screen 1366x768
  • Hard Disk: 320GB 7200rpm SATA
  • WLan: Ralink RL-3090 802.11b/g/n PCIe
  • Lan: ASIX AX88xxx Based USB 2.0 (internal)
  • Mouse: Touchpad
  • Bluetooth: V2.0 VDR
  • Sound: Intel HDA (ALC888)
  • Webcam: 1.3Mpx
  • SD Card Reader

Current Issues

Front microphone doesn't work neither after installation nor updates. Annoying messages about mmc card timeouts - in fact you can't use text console because of it. And your syslog just swells up.

System Info

system-manufacturer: Micro-Star International

system-product-name: X320

system-version: Ver 1.000

Finally after all

Screen & Monitors

Device

Works?

Bug #

Karmic Coala 9.10

Screen

GOOD

Correct resolution?

YES

Correct refresh rate?

YES

3D Acceleration

YES

External monitor works?

Untested

External monitor - mirrors

Untested

External monitor - extend desktop

Untested

Power Management

Battery detected?

YES

Hibernates?

YES

Suspend

YES (but doesn't wake up)

Dim monitor on battery

YES

Blank monitor on inactivity

YES

Lid Close

YES (see suspend)

Cpu frequency scaling

Untested

Sound

Sound works?

YES

Correct volume?

YES

Hardware volume switch

YES

Headphone jack

YES

Mic front

NO

Mic jack

YES

Networking

Wired NIC

YES

Wireless NIC

YES

Bluetooth

YES

Touchpad & Mice

Touchpad

YES

Touchpad - Doubletap = double click

YES

External mouse - USB

YES

Additional Hardware

Card reader(s)

YES

Web camera

YES

Notes

So, finally all is perfect except front micro which is very handy for voice chats, sad.

Right after Ubuntu 9.10 installation

1. Wireless doesn't work

2. Generic VESA video resolution (acceleration doesn't work)

After update kernel from the official sources (as per 7.01.2010 right after installation - kernel 2.6.31-17-generic)

Same

Further updates for 9.10

1. Update from deb http://ppa.launchpad.net/markus-tisoft/rt3090/ubuntu karmic main deb-src http://ppa.launchpad.net/markus-tisoft/rt3090/ubuntu karmic main gives WiFi working properly (see https://launchpad.net/~markus-tisoft/+archive/rt3090) Or you can just download the package from this build page and have it for manual installation if something goes wrong. The card already supported in kernel 2.6.33 staging modules though, not in Ububtu supplied kernel.

2. After this https://wiki.ubuntu.com/HardwareSupportComponentsVideoCardsPoulsbo/ (i've done old style steps) graphics works exactly as it used to work and acceleration works properly - fullscreen glxgears 70 fps (thanks, guys).

3. Somehow sound has got disappeared at some point (after update or graphics module update - don't remember) - after some magic manipulations/packages re-installation (codecs/players) and selecting PulseAudio as default output in KDE i managed to get it working back.

Right after Ubuntu 10.04 installation

1. Wireless doesn't work 2. Generic VESA video resolution

Further updates for 10.04

1. sudo mkdir /etc/Wireless ; sudo mkdir /etc/Wireless/RT2860STA ; sudo touch /etc/Wireless/RT2860STA/RT2860STA.dat ; reboot - wireless works perfectly (rt3090sta module needed this file, well - its been given to it)

2. Update video driver (http://code.google.com/p/gma500/wiki/PPARepository) - video works perfectly


CategoryLaptop

LaptopTestingTeam/MSI X320 (last edited 2010-08-11 00:11:31 by xsnake)