LucidServerSeeds

Differences between revisions 8 and 9
Revision 8 as of 2009-11-24 16:55:33
Size: 25832
Editor: dsl-173-206-1-210
Comment:
Revision 9 as of 2009-11-24 16:58:17
Size: 25843
Editor: dsl-173-206-1-210
Comment:
Deletions are marked like this. Additions are marked like this.
Line 289: Line 289:
{{{
Line 948: Line 949:


Use this section to take notes during the BoF; if you keep it in the approved spec, use it for summarising what was discussed and note any options that were rejected.
}}}

## Use this section to take notes during the BoF; if you keep it in the approved spec, use it for summarising what was discussed and note any options that were rejected.

Summary

Perform a critical review of the current packages in main related to the Ubuntu Server product in view of Lucid being an LTS release. A complete list of packages to be added to main as well as removed from main can be found in the Design section.

Release Note

Provide an overview of some important packages that have been promoted to main for Lucid.

Rationale

Since Lucid is LTS, a critical review of the current contents of the server CD is necessary, both to free some space on the CD and to reduce the number of packages we'll be maintaining for 5 years. Some packages are not necessary and might be abandoned. Some packages are brought up in main by recommends while they should just be suggested. Some very useful packages are missing and should be added.

User stories

  • Albert deploys production services on Ubuntu and is confident that security updates will be issued by the Ubuntu Security team for packages running his services.
  • Britney doesn't spend entire days tracking down patches for security vulnerabilities in unmaintained software.

Design

Packages to be demoted to universe

Universe demotion proposals should be added to the Proposed universe demotions list and discussion should take place there.

List of package that should be demoted to universe for Lucid with an (optional) reason:

  • nis
  • elinks
  • lm-sensors
  • sensord
  • cricket
  • radvd
  • logwatch:
    • logcheck provides the same functionality
  • vlock
  • lilo
  • libxp6

Packages to be promoted to main

Main promotion proposals should be added to the Proposed main promotions list and discussion should take place there.

List of package that should be promoted to main for Lucid with an (optional) reason:

  • irqbalance:
    • add upstart job
    • install by default
  • python-tickcount:
    • required by LP
  • python-psycopg2:
    • required by LP
  • python-genshi
    • required by Landscape
  • oidentd
  • nagios-nrpe
  • nagios-nrpe-plugin
  • nagios-nrpe-server
  • tdb-tools:
    • samba cluster
  • ctdb:
    • samba cluster
  • acl
  • zip:
    • default (server) install
  • unzip:
    • default (server) install

Misc

  • supported-misc-servers needs reorg/comments/etc. for readability/documentation

Implementation

See the work items in the blueprint.

Unresolved issues

BoF agenda and discussion

Proposed universe demotions

  • redhat-cluster-suite:
    • not properly maintained
    • Recommend removal, modulo objections from enterprise customers:
      • enterprise customer objecting
    • See ClusterStack blueprint.

  • virt-manager:
    • I'd like to request that virt-manager be dropped from Main to Universe. It ships on the DVD, but not the other installable media. Most all virt-manager users have to apt-get install it post installation anyway. From a maintainability standpoint, no core-developer is really looking after the package. It falls outside of the scope of the Server team, since it's a GUI/desktop package, but no one from the Desktop team is looking after it either. The interface is years and years behind the interface of VirtualBox. And the bug backlog is huge. I suggest that virt-manager be dropped from the Main seeds, to Universe, for Lucid. -- DustinKirkland

  • backuppc:
    • jmdault says almost all his customers use backuppc at the moment
  • racoon:
    • Should we support an IPSEC based VPN solution in main?
    • isakmpd is the only(?) other ISPec daemon, and is in universe.
  • ipsec-tools:
    • the security team would not mind not needing to update ipsec-tools any more.
  • minicom:
    • cu is tiny and trivial to support, but doesn't support error correction
  • openssh-blacklist, openssl-blacklist:
    • needs further consideration by cjwatson

Rejected universe demotions

List of packages that have been considered to be demoted to universe. However after discussion it was decided to keep these in main. Include the reason why the package is kept in main when a package is added to this list:

  • quagga:
    • still maintained, needed for BGP
  • siege:
    • ivoks: i'd like to keep this one cause it's only usable http benchmarking tool

Proposed main promotions

  • drupal v6:
    • need to be repackaged to remove the dependency on wwwconfig-common.
  • asterisk:
  • python-svn (LP):
    • python-subversion already in main
    • check with Launchpad team on whether we need both.
  • python-pysqlite2 (Landscape):
    • sqlite3 is already part of python 2.6 - why is this needed?
  • apache-openid:
    • does this mean libapache2-mod-auth-openid? - ask IS.
  • Update autofs4 to autofs5:
    • autofs5 description says it is "experimental" - need to confirm this
  • pacemaker:
    • See ClusterStack blueprint:

    • Debian Maintainer wants to coordinate this cluster stack that they are shipping in squeeze with our LTS.

Rejected main promotions

List of packages that have been considered to be promoted to main. However after discussion it was decided to keep these in universe. Include the reason why the package is kept in universe when a package is added to this list:

  • wordpress:
    • security team is against it.
  • python-celementtree (LP):
    • only built for python2.4, not 2.5
    • requires small amount of porting, but there's no reason we should pull this back into main (or even have it in the archive)

UDS session agenda

  • Canonical application support (server-lucid-canonical-application-support) -mdz

  • Update autofs4 to autofs5? -mdz
  • Cluster stack (server-lucid-cluster-stack) -mdz

  • sysstat package be shipped with Ubuntu Server - jsalisbury
  • oprofile and systemtap package be shipped to provide deeper performance analysis. -jsalisbury
  • I'd like to request that virt-manager be dropped from Main to Universe. It ships on the DVD, but not the other installable media. Most all virt-manager users have to apt-get install it post installation anyway. From a maintainability standpoint, no core-developer is really looking after the package. It falls outside of the scope of the Server team, since it's a GUI/desktop package, but no one from the Desktop team is looking after it either. The interface is years and years behind the interface of VirtualBox. And the bug backlog is huge. I suggest that virt-manager be dropped from the Main seeds, to Universe, for Lucid. -- DustinKirkland

  • Look at the delta between hardy and karmic
  • General server seeds review / server package set
  • Look into dvd seed for server packages (time permitting)

UDS Lucid discussion notes

  • Canonical application support (server-lucid-canonical-application-support) -mdz

    • Xen: not feasible
    • drupal (v6)
      • security team says core is "quite good"
      • uses wwwconfig-common (universe) which we do not want
      • would need to be repackaged
    • asterisk
      • long-term release 1.8 is coming up (Q2 2010). Lucid will have 1.6.X most likely.
      • 1.8 is still vaporware, and will not likely be even beta for Lucid.
      • gives the security team "pause" (7 CVEs last year, 13 the year before)
      • could add an apparmor profile (jdstrand has one)
      • hard to fully test (potentially lots of hardware bits)
      • will have more information after asterisk session tomorrow
    • wordpress
      • kees says "no", jamie says "whoa"!
    • irqbalance
      • James T. says this is very important
      • should be upstartified
      • install by default on servers and desktops
    • python-* for Launchpad
      • python-celementtree
        • only built for python2.4, not 2.5; requires small amount of porting, but there's no reason we should pull this back into main (or even have it in the archive)
      • python-svn
        • python-subversion already in main; check with Launchpad team on whether we need both)
      • python-tickcount
      • python-simplejson
        • already in main
      • python-magic
        • already in main
      • python-psycopg2
      • python-pygments
        • already in main
    • python-* for Landscape
      • python-genshi
        • +1 from kees, good overall design
      • python-psycopg2
      • python-pysqlite2
      • python-simplejson
        • already in main
      • smartpm-core
        • already in main
      • python-smartpm
        • already in main
    • python-* for Ubuntu One
    • apache-openid
      • does this mean libapache2-mod-auth-openid?
    • oidentd
    • nagios-nrpe
      • nagios-nrpe-plugin, nagios-nrpe-server? both?
  • Update autofs4 to autofs5? -mdz
    • autofs5 description says it is "experimental" - need to confirm this
  • Cluster stack (server-lucid-cluster-stack) -mdz

    • removal of redhat-cluster-suite from main (because not properly maintained).
    • Push pacemaker instead (Debian Maintainer wants to coordinate this cluster stack that they are shipping in squeeze with our LTS).
    • recommend removal, modulo objections from enterprise customers? enterprise customer objecting
  • Build samba with clustering extensions, means including tdb-tools (source already in main) and ctdb in main. -- reduces debian delta
    • already included in the Debian package, so this is a revert of existing delta
    • Need to move "acl" package in main (was a hal dependency but not since karmic)
  • exim4 (in supported-misc-servers)
    • used by Canonical IS
    • keep
  • Review hardy/lucid diff
    • Mail filtering (Spec: server-lucid-more-mail-integration)
      • postgrey
      • Possibly a few small python-modules/app (all packages ScottK maintains in Debian)
      • amavisd-postfix package
  • sysstat package be shipped with Ubuntu Server - jsalisbury
    • already in main
  • oprofile and systemtap package be shipped to provide deeper performance analysis. -jsalisbury
    • NAK on systemtap -- it is young and actively generating CVEs --Kees
    • no reason for these to be in main
  • I'd like to request that virt-manager be dropped from Main to Universe. It ships on the DVD, but not the other installable media. Most all virt-manager users have to apt-get install it post installation anyway. From a maintainability standpoint, no core-developer is really looking after the package. It falls outside of the scope of the Server team, since it's a GUI/desktop package, but no one from the Desktop team is looking after it either. The interface is years and years behind the interface of VirtualBox. And the bug backlog is huge. I suggest that virt-manager be dropped from the Main seeds, to Universe, for Lucid. -- DustinKirkland

  • General server seeds review / server package set
  • Look into dvd seed for server packages (time permitting)
  • Look into NAS developemnt for SMB/Home Users. Would recommend making it a install option on list of installables (or separate lightweight flavor). - azteech
  • remove backuppc? (jmdault says almost all his customers use backuppc at the moment)
  • remove nis
  • no need to explicitly seed?
    • libaio1
    • libaio-dev
    • libpkcs11-helper1
    • cvs
    • dbconfig-common
    • pnm2ppa
  • remove gnbd-*
  • remove elinks
  • sensors
    • lm-sensors
      • sensord
    • still needed on modern hardware?
  • remove racoon? Should we support an IPSEC based VPN solution in main? isakmpd is the only(?) other ISPec daemon, and is in universe. That said, the security team would not mind not needing to update ipsec-tools any more.
    • ipsec-tools?
  • remove cricket
  • section for tomcat
  • remove analog
  • remove freenet6 (already gone from archive)
  • remove quagga? (NAK, still maintained, needed for BGP)
  • remove radvd
  • remove minicom? (cu is tiny and trivial to support, but doesn't support error correction)
  • remove siege (ivoks: i'd like to keep this one cause it's only usable http benchmarking tool)
  • further consideration (duplicate functionality?)
    • logwatch (has existed for a long time, cargo-culted by Kees)
    • logcheck (potentially better package integration, preferred by IS)
  • remove vlock
  • needs further consideration by cjwatson: openssh-blacklist, openssl-blacklist
  • remove system-cleaner (gone)
  • kvm -> qemu-kvm

  • remove lilo?
  • promote zip, unzip to server default install?
  • remove libxp6? - 29153
  • supported-misc-servers needs reorg/comments/etc. for readability/documentation

Hardy/Lucid diff

PLEASE DO NOT PANIC; THIS IS A ROUGH ANALYSIS AND DOES NOT ACTUALLY DIRECTLY CORRESPOND TO DROPPING STUFF FROM MAIN! IT NEEDS MANUAL REVIEW.

-aoetools (can we keep aoetools in main please?) Who's asking? Andrew Pollock jmdault as well it is not in main, but we will add it for eucalyptus anyway
+antlr
+antlr3
-apache2-mpm-perchild
-apache2-prefork-dev
-apache2-src
-apache2-threaded-dev
+apache2.2-bin
+aspell
+aspell-en
+augeas-lenses
-autoconf
-automake1.4
-autotools-dev
+avahi-daemon
+avahi-utils
+bacula-common-mysql
+bacula-common-sqlite3
+bacula-director-sqlite3
+bacula-sd-sqlite3
-bacula-traymonitor
+bind9utils
-bittornado
-bonnie++
+bogl-bterm
+bsd-mailx
-cdebconf-udeb
+bzrtools
+ca-certificates-java
+checkbox
+checkbox-cli
+clamav
+clamav-base
+clamav-daemon
+clamav-freshclam
-comerr-dev
-console-terminus
+corosync
-cracklib2
-crypto-modules-2.6.24-16-386-di
-crypto-modules-2.6.24-16-generic-di
-cryptsetup
-cups-pdf
-cupsddk
-cupsddk-drivers
-cupsys
-cupsys-bsd
-cupsys-client
-cupsys-common
-cupsys-driver-gutenprint
+cups
+cups-bsd
+cups-client
+cups-common
+cups-driver-gutenprint
-db4.6-util
+db4.7-util
+dbconfig-common
+dbus-x11
-debootstrap
+default-jre-headless
+devicekit-disks
-dmsetup
+diffstat
+dkms
-dovecot-dev
+dovecot-postfix
+dpatch
+dput
+drbd8-source
+erlang-base
+erlang-crypto
+erlang-mnesia
+erlang-os-mon
+erlang-public-key
+erlang-runtime-tools
+erlang-snmp
+erlang-ssl
+erlang-syntax-tools
+esound-clients
+ethtool
+euca2ools
+eucalyptus-cc
+eucalyptus-cloud
+eucalyptus-common
+eucalyptus-gl
+eucalyptus-java-common
+eucalyptus-nc
+eucalyptus-sc
+eucalyptus-udeb
+eucalyptus-walrus
-exim4-daemon-heavy-dbg
-exim4-daemon-light-dbg
-exim4-dbg
-exim4-dev
-eximon4
+facter
-foomatic-db-hpijs
-freeradius-dialupadmin
-freeradius-iodbc
-freeradius-krb5
-freeradius-ldap
-freeradius-mysql
-freeradius-postgresql
+freeradius-common
+freeradius-utils
+freetds-common
-g++-4.2
+g++-4.4
-gcc-4.2
-gcj-4.2-base
+gcc-4.4
-gij
-gij-4.2
-git-core
-gnbd-client
-gnbd-server
+ghostscript-cups
+gnome-keyring
+groovy
+gvfs
+gvfs-backends
+hal
+hal-info
+hicolor-icon-theme
+icedtea-6-jre-cacao
-jfsutils
+irb1.8
+ivy
+janino
+java-common
+john-data
+jsvc
+junit
+junit4
-kernel-image-2.6.24-16-386-di
-kernel-image-2.6.24-16-generic-di
+kernel-package
+kerneloops-daemon
+landscape-client
+language-selector-common
+libantlr-java
-libapache2-mod-auth-pam
-libapache2-mod-auth-sys-group
+libapache2-mod-axis2c
-libapache2-svn
+libapache2-reload-perl
-libapr1-dev
-libaprutil1-dev
-libarchive-tar-perl
+libaprutil1-dbd-sqlite3
+libaprutil1-ldap
+libapt-pkg-perl
+libarchive1
+libasm-java
+libasm2-java
-libasound2-plugins
+libatasmart4
+libatk1.0-data
+libaugeas-ruby1.8
+libaugeas0
+libauthen-sasl-perl
-libavahi-compat-libdnssd1
+libavahi-common3-udeb
+libavahi-core6
+libavahi-core6-udeb
-libbeecrypt6
+libaxiom-java
+libaxis2c0
+libbackport-util-concurrent-java
+libbcel-java
+libbcprov-java
+libbluetooth3
+libbsd-resource-perl
+libbsf-java
+libc-dev-bin
+libc3p0-java
-libc6-udeb
-libcap-bin
+libccs3
+libcdio-cdda0
+libcdio-paranoia0
+libcdio10
+libcdio7
+libcglib2.1-java
-libcman2
+libclamav6
+libcman3
+libcommons-beanutils-java
+libcommons-cli-java
+libcommons-codec-java
+libcommons-collections-java
+libcommons-collections3-java
+libcommons-daemon-java
+libcommons-dbcp-java
+libcommons-discovery-java
+libcommons-fileupload-java
+libcommons-httpclient-java
+libcommons-io-java
+libcommons-jxpath-java
+libcommons-lang-java
+libcommons-logging-java
+libcommons-pool-java
-libcompress-zlib-perl
+libcorosync4
+libcrack2
-libct3
+libcrypt-openssl-bignum-perl
+libcrypt-openssl-rsa-perl
+libcups2
+libcupscgi1
+libcupsdriver1
-libcupsys2
+libcupsmime1
+libcupsppdc1
-libdatrie0
-libdb4.2
-libdb4.6-dev
+libdaemon0
+libdate-manip-perl
+libdatrie1
+libdb4.6
-libdebian-installer4-udeb
+libdebconfclient0
+libdebian-installer4
+libdigest-hmac-perl
-libdirectfb-1.0-0
-libdlm2
-libdrm2
-libecpg-compat3
-libecpg-dev
-libecpg6
+libdirectfb-1.2-0
+libdjvulibre-text
+libdjvulibre21
+libdlm3
+libdlmcontrol3
+libdnsjava-java
+libdom4j-java
+libdrools-core-java
+libecj-java
+libeggdbus-1-0
-libevent1
+libeucalyptus-commons-ext-java
+libevent-1.4-2
+libexcalibur-logkit-java
-libexpat1-dev
-libffi4
+libezmorph-java
+libfence4
+libffi5
-libfile-temp-perl
+libflac8
+libfreeradius2
-libfs6
-libgcj-bc
-libgcj8-1
+libgcr0
-libgl1-mesa-glx
+libgdu0
+libgeronimo-ejb-3.0-spec-java
+libgeronimo-interceptor-3.0-spec-java
+libgeronimo-j2ee-connector-1.5-spec-java
+libgeronimo-jacc-1.1-spec-java
+libgeronimo-jms-1.1-spec-java
+libgeronimo-jpa-3.0-spec-java
+libgeronimo-jta-1.0.1b-spec-java
-libglib2.0-0
-libgmp3c2
+libgnuinet-java
+libgnujaf-java
+libgnumail-java
+libgoogle-collections-java
+libgp11-0
+libgpgme11
-libgsf-1-114
-libgsf-1-common
-libgtk-vnc-1.0-0
+libgssrpc4
+libgstreamer-plugins-base0.10-0
+libgstreamer0.10-0
+libgtk2.0-bin
+libgudev-1.0-0
+libgvfscommon0
+libgwt-user-java
+libhamcrest-java
+libhsqldb-java
-libhx10
+libhx18
+libicu40
-libio-compress-base-perl
-libio-compress-zlib-perl
+libijs-0.35
+libilmbase6
+libio-pty-perl
+libio-socket-inet6-perl
-libio-zlib-perl
-libiodbc2
+libipc-run-perl
+libjasper1
+libjavassist-java
+libjaxen-java
+libjaxme-java
+libjaxp1.3-java
+libjdom1-java
+libjetty6-java
+libjibx-java
+libjline-java
-libkadm55
-libkrb5-dev
-libldap2-dev
-liblockfile1
-libltdl3
+libjson-java
+libjug-java
+libkadm5clnt6
+liblcms1
+liblog4j1.2-java
+liblogthread3
+libltdl7
+liblua5.1-0
-libmailtools-perl
+liblzo2-2
+libmagickcore2
+libmagickwand2
+libmail-dkim-perl
+libmail-sendmail-perl
+libmail-spf-perl
-libmime-perl
-libmysqlclient15-dev
-libmysqlclient15off
-libneon27
-libneon27-dev
+libmockobjects-java
+libmvel-java
+libmx4j-java
+libmysqlclient16
+libnet-dns-perl
+libnet-ip-perl
+libnet-xwhois-perl
+libnetaddr-ip-perl
+libnetty-java
-libnss-files-udeb
+libnss-mdns
-libopenais2
+libntfs10
+libogg0
+libopenais3
+libopenexr6
+libopenobex1
+libopenssl-ruby
+libopenssl-ruby1.8
+liboro-java
+libpam-ck-connector
+libpam-gnome-keyring
-libpcre3
-libpcre3-dev
-libpcrecpp0
-libperl5.8
-libpgtypes3
+libparse-debcontrol-perl
+libpciaccess0
+libperl5.10
+libpkcs11-helper1
+libpod-coverage-perl
+libpolkit-agent-1-0
+libpolkit-backend-1-0
+libpolkit-gobject-1-0
-libpoppler2
-libpq-dev
+libpoppler5
+libproxy0
+libpth20
+libpython2.6
+libqdox-java
+librampart0
+libreadline-ruby1.8
+libregexp-java
-librpm4.4
-librrd2
+librpm0
+librpmbuild0
+librpmio0
+librrd4
-librsvg2-2
-librsvg2-common
+libruby
-libsamplerate0
+libsctp1
+libservlet2.4-java
+libservlet2.5-java
+libsgutils2-2
+libshadow-ruby1.8
+libslf4j-java
-libsmbclient-dev
+libsndfile1
+libsocket6-perl
+libsoup-gnome2.4-1
+libsoup2.4-1
-libsqlite3-dev
-libssl-dev
-libstdc++6-4.2-dev
-libsvn-dev
-libsvn-doc
-libsvn-java
-libsvn-javahl
-libsvn-perl
-libsvn-ruby
-libsvn-ruby1.8
-libsvn1
+libstdc++6-4.4-dev
+libstringtemplate-java
+libsys-hostname-long-perl
+libsysfs2
-libtextwrap1-udeb
+libtalloc1
+libterm-size-perl
+libtest-pod-perl
+libtie-ixhash-perl
-libtimedate-perl
-libtool
+libtomcat6-java
+libtommath0
+libts-0.0-0
+libupsclient1
+libv4l-0
-libvte-common
-libvte9
-libx11-6
-libx11-data
-libxau6
+libvorbis0a
+libvorbisenc2
+libwbclient0
+libwmf0.2-7
+libwrap0
+libwsdl4j-java
+libwss4j-java
+libx86-1
+libxalan2-java
-libxcb-xlib0
-libxcb1
+libxcb-render-util0
+libxcb-render0
-libxdmcp6
-libxext6
+libxerces2-java
+libxfont1
-libxkbfile1
-libxml-writer-perl
-libxml2
-libxml2-dev
+libxml-security-java
+libxmlrpc-ruby
-libxmuu1
+libxom-java
+libxpp2-java
+libxpp3-java
+libxstream-java
-libxtrap6
-libxv1
-libxxf86dga1
-libxxf86misc1
-libxxf86vm1
-linux-headers-2.6.24-16
-linux-headers-2.6.24-16-server
-linux-headers-server
-linux-image-2.6.24-16-server
-linux-image-server
+lintian
+linux-generic-pae
+linux-headers-2.6.32-4
+linux-headers-2.6.32-4-generic-pae
+linux-headers-generic-pae
+linux-headers-virtual
+linux-image-2.6.32-4-generic-pae
+linux-image-2.6.32-4-virtual
+linux-image-generic-pae
+linux-image-virtual
-linux-server
-linux-ubuntu-modules-2.6.24-16-server
+linux-virtual
+lksctp-tools
-lockfile-progs
-ltsp-server
-ltsp-server-standalone
-ltspfs
-make
-mdadm
+min12xxw
-moinmoin-common
+mtools
-mysql-client-5.0
+mysql-client-5.1
-mysql-server-5.0
+mysql-server-5.1
+mysql-server-core-5.1
+nagios-images
+nagios-plugins
+nagios3
+nagios3-cgi
+nagios3-common
+nagios3-core
+nagios3-doc
+ntfsprogs
+obex-data-server
+oem-config
+oem-config-debconf
+open-iscsi-utils
+openjdk-6-jre-headless
+openjdk-6-jre-lib
+openssh-blacklist
+openssh-blacklist-extra
-openssl
+openssl-blacklist
+openssl-blacklist-extra
+openvpn-blacklist
-patch
+partman-iscsi
+patchutils
-php5-dev
-pkg-config
+pm-utils
+policykit-1
+policykit-1-gnome
-postfix-dev
-postgresql-8.3
+postgresql-8.4
-postgresql-client-8.3
+postgresql-client-8.4
-postgresql-contrib-8.3
+postgresql-contrib-8.4
-postgresql-doc-8.3
-postgresql-plperl-8.3
-postgresql-plpython-8.3
-postgresql-pltcl-8.3
-postgresql-server-dev-8.3
+postgresql-doc-8.4
+powernap
+powerwake
+psfontmgr
+puppet
+puppetmaster
-python-cairo
-python-clientform
+python-boto
-python-dbg
-python-docutils
-python-gconf
-python-glade2
-python-gnome2
-python-gnomecanvas
+python-django
-python-gtk-vnc
-python-gtk2
+python-gst0.10
+python-image-store-proxy
-python-mechanize
+python-m2crypto
-python-numeric
-python-pyorbit
-python-roman
-python-subversion
-python-subversion-dbg
-python-twisted-bin
-python-twisted-conch
-python-twisted-core
-python-twisted-web2
-python-tz
+python-paramiko
+python-pyicu
+python-twisted-web
-python-virtinst
-python-vte
-python-zopeinterface
-python2.4
-python2.4-minimal
-python2.5-dbg
+python-xapian
+qemu-kvm
+rabbitmq-server
+radeontool
+rdate
+rdoc
+rdoc1.8
+re2c
+rhino
+ruby
-samba-dbg
+samba-common-bin
+sane-utils
-screen
-scsi-modules-2.6.24-16-386-di
-scsi-modules-2.6.24-16-generic-di
-shared-mime-info
-shorewall
-shorewall-common
-shorewall-shell
-shtool
+sg3-utils
+smartdimmer
-squashfs-tools
+spamassassin
+spamc
+sqlite3
+squid-langpack
-storage-core-modules-2.6.24-16-386-di
-storage-core-modules-2.6.24-16-generic-di
-subversion
-subversion-tools
-swat
-sysvinit
-tcl8.4
+tcpd
+tomcat6
+tomcat6-admin
+tomcat6-common
+tomcat6-docs
+tomcat6-examples
+tomcat6-user
+tsconf
-ubuntu-serverguide
-unifont
+ttf-freefont
+ttf-liberation
+tzdata-java
+ubiquity
+ubiquity-casper
+ubiquity-frontend-debconf
+ubiquity-ubuntu-artwork
+ubuntu-virt-server
+unattended-upgrades
-uuid-dev
+update-inetd
+update-motd
+vbetool
-vgabios
-virt-manager
+wakeonlan
+watershed
+wdiff
-x11-apps
-x11-common
-x11-session-utils
-x11-utils
-x11-xfs-utils
-x11-xkb-utils
-x11-xserver-utils
-xauth
-xbase-clients
-xfsprogs
+x-ttcidfont-conf
+xfonts-encodings
+xfonts-utils
-xinit
-zlib1g-dev
-zope-common
-zope3
-zope3-sandbox


CategorySpec

LucidServerSeeds (last edited 2010-02-17 18:59:09 by dsl-173-206-1-210)