DuplicatedPackages

Differences between revisions 17 and 18
Revision 17 as of 2010-03-09 10:36:03
Size: 5959
Editor: lns-bzn-48f-81-56-218-246
Comment:
Revision 18 as of 2010-03-15 13:09:34
Size: 6253
Editor: dslb-088-073-082-024
Comment: comments about progresses and won't fixes
Deletions are marked like this. Additions are marked like this.
Line 5: Line 5:

[doko] antlr3 depends on antlr (libantlr-java). How to drop it?
Line 31: Line 33:
[doko] will not fix, until gcc-4.4 is gets removed/demoted
Line 52: Line 56:
  * gcc-4.4   * gcc-4.4 [doko] will not fix, until gcc-4.4 is gets removed/demoted
Line 101: Line 105:
  * python2.6   * python2.6 [doko] in progress, will convert for lucid
Line 307: Line 311:
  * llvm
  * blt
  * llvm [doko] in progress
  * blt [doko] extension built for both 8.4 and 8.5

These packages have multiple versions in lucid main, and ought to be cleaned up for better supportability.

antlr

[doko] antlr3 depends on antlr (libantlr-java). How to drop it?

  • antlr
    • ant
    • antlr3
    • cdrdao
    • dom4j
    • groovy
    • jaxme
    • drools
    • eucalyptus
    • eucalyptus-commons-ext
    • gcj-4.4
    • stringtemplate
  • antlr3
    • drools
    • eucalyptus-java-common

autotools

  • autoconf (latest version; source: automake1.11)

  • autoconf2.59
    • gcc-4.4
    • gcj-4.4

[doko] will not fix, until gcc-4.4 is gets removed/demoted

  • automake (latest version)

  • automake1.4 (source: automake)
    • autoconf2.13
      • amavisd-new
      • firefox
      • thunderbird
      • xulrunner-1.9.1
  • DEMOTED: automake1.7

    • FIXED: id3lib3.8.3

    • FIXED: libmng

    • FIXED: libtextwrap

  • automake1.9
    • anthy
    • compiz-fusion-bcop
    • cryptsetup
    • curl
    • cyrus-sasl2
    • ethtool
    • gcc-4.4 [doko] will not fix, until gcc-4.4 is gets removed/demoted
    • gcj-4.4
    • gettext-kde
    • ghostscript
    • grub
    • hfsplus
    • hunspell
    • libatomic-ops
    • libiodbc2
    • libmodplug
    • libnss-db
    • libvigraimpex
    • libwpd
    • libwps
    • llvm
    • mtr
    • mysql-dfsg-5.1
    • net-snmp
    • network-manager
    • network-manager-applet
    • notification-daemon
    • shadow
    • smartmontools
    • sqlite
    • tidy
  • automake1.10
    • aalib
    • f-spot
    • gnome-user-docs
    • gupnp-igd
    • mdbtools

camlp

  • camlp4 (source: ocaml)
    • findlib
    • ocaml-nox
  • camlp5
    • ledit

libdb

  • db4.7
    • cyrus-sasl2
    • drac
    • libberkeleydb-perl
    • openldap
    • python2.6 [doko] in progress, will convert for lucid
    • sendmail
  • db (version 4.8, latest version)

gnupg

  • gnupg

  • gnupg2
    • kmail
    • kubuntu-desktop
    • kubuntu-netbook
    • gpgme1.0

junit

  • junit (version 3.8)

  • junit4
    • easymock
    • groovy
    • libezmorph-java
    • groovy

asm

  • asm (version 1.5)
    • eucalyptus-commons-ext
    • jmock
  • asm2
    • eucalyptus-commons-ext
    • groovy
    • ow-util-ant-tasks
  • asm3
    • cglib
    • jarjar

[ttx] Looked into that as part of another Java library cleanup spec, and it's not doable (at least not in lucid timeframe). ASM is traditionally embedded into other code, while we try to maintain it as separate libraries. Each version is quite incompatible, and upstream have no wish to switch to the "latest version" since they usually just embed ASM source code in their own code. It's not uncommon for some upstream stacks to use libraries that depend on different versions of ASM... (see eucalyptus-commons-ext which depends on asm and asm2).

Qt

  • qt-x11-free
    • avahi
    • cppunit
    • dbus-qt3
    • djvulibre
    • nvclock
    • pinentry
    • poppler
    • qscintilla (qt3 version of qscintilla2)
      • no rdepends, can be removed
    • qwt
    • scribus
    • unixodbc
    • wvstreams
  • qt4-x11 (primary package)

libcommons-collections-java

  • libcommons-collections-java (Version: 2.1)
    • ivy
    • libcommons-dbcp-java
    • libcommons-jxpath-java
  • libcommons-collections3-java
    • commons-beanutils
    • commons-vfs
    • eucalyptus-commons-ext
    • gwt
    • libjson-java

gmime

  • DEMOTED: gmime2.2

    • DEMOTED: pan

    • FIXED: tracker

  • gmime2.4

    • totem-pl-parser
    • tomboy

gtkhtml

  • DEMOTED: libgtkhtml2

    • DROPPED: python-gtkhtml2 (src: gnome-python-extras)

      • FIXED: apturl

  • gtkhtml3.14

    • evolution
    • evolution-indicator
    • gnome-desktop-sharp2

gtksourceview

  • DONE: gtksourceview

    • DROPPPED: python-gtksourceview (source: gnome-python-desktop)

      • (no rdepends)
  • gtksourceview2

readline

  • DEMOTED: readline5

    • FIXED: kalgebra (src: kdeedu)

    • FIXED: libreadline-ruby1.8 (src: ruby1.8)

    • FIXED: libreadline-java

    • FIXED: multipath-tools

    • FIXED: xfsprogs

  • readline6

libservlet-java

  • libservlet2.3-java (source: javax-servletapi2.3)
    • FIXED: liblogkit-java

  • libservlet2.4-java
    • FIXED: axis

    • FIXED: bsh

    • FIXED: excalibur-logkit

    • FIXED: groovy

    • FIXED: hsqldb

    • FIXED: jython

    • FIXED: libcommons-fileupload-java

    • FIXED: libmx4j-java

  • libservlet2.5-java (source: tomcat6)

sqlite

  • sqlite
    • bacula
    • cyrus-sasl2
    • php5
    • qt4-x11
    • binary only, no build dep: libmono-sqlite1.0-cil, libmono-sqlite2.0-cil
  • sqlite3

libusb

  • libusb (version: 0.1.12)
    • bluez
    • cups
    • gnome-pilot
    • gnupg
    • gnupg2
    • hal
    • hplip
    • indi
    • kdebase
    • kdebase-workspace
    • kdeedu
    • libftdi
    • libgphoto2
    • libifp
    • libindi
    • libmtp
    • libnjb
    • libopenobex
    • lirc
    • nut
    • pcsc-lite
    • pilot-link
    • sane-backends
    • system-config-printer
    • udev
    • upower
    • usbutils
  • libusb-1.0
    • libdc1394-22
    • libgpod
    • libimobiledevice
    • usbmuxd

libxpp-java

  • libxpp2-java
    • dom4j (depends on both versions!)
  • libxpp3-java
    • dom4j
    • drools
    • libjibx-java
    • libxstream-java

[ttx] dom4j upstream code explicitely build-depends on both xpp2 (providing org.gjt.xpp namespace, used in dom4j's XPPReader class) and xpp3 (providing org.xmlpull.v1 namespace, used in dom4j's XPP3Reader class). So it's not possible to remove one of the xpp libraries from main without crippling the dom4j we ship.

policykit

  • policykit-1

  • DONE: policykit

    • REMOVED: polkit-qt

      • no rdepends, can be removed/blacklisted

Tcl/Tk

  • tcl8.5, tk8.5

  • tcl8.4
    • llvm [doko] in progress
    • blt [doko] extension built for both 8.4 and 8.5
    • ecosconfig-imx
    • rrdtool-tcl
    • tcl
    • tk8.4
    • vim-gnome
    • xchat-gnome
    • hfsutils
    • ruby1.8
    • sqlite
    • swig1.3
  • tk8.4
    • blt
    • foo2zjs
    • hfsutils-tcltk
    • tk

Specs/Lucid/DuplicatedPackages (last edited 2010-03-31 07:13:56 by pD9EB6ACE)