Plymouth

Plymouth is a core component of our boot experience, but is very complex. We want to be sure that we know it's working properly, and under what circumstances it isn't, before Lucid Beta1 is released.

The variables known to affect plymouth's behavior are:

  • whether or not cryptsetup is installed
  • whether booting from a LiveCD or from an installed system
  • whether the system uses Intel KMS, ATI/nVidia KMS, or no KMS
    • with nVidia, the number of monitors connected at boot time
  • whether the 'splash' option is passed on the kernel commandline
  • whether the user has GDM (Ubuntu Desktop), KDM (Kubuntu), ubiquity-dm (the installer), or no display manager (Ubuntu Server) installed

To be sure that we've really worked all the plymouth bugs out of the system, we would like to test *all* of these combinations for regressions.

All testing must be done using the 20100318 candidate images. Tests of installed systems must use plymouth version 0.8.0~-17.

If testing a desktop system, press <enter> once X has loaded, then log in and type a few lines (on IRC, in a terminal, etc). Report any crashes.

To know whether you have KMS hardware, check the contents of the file /proc/fb. If the first line reads "0 inteldrmfb", you have Intel KMS. If it reads "0 radeonfb", you have ATI KMS, and if it reads "0 nouveaufb", you have nVidia KMS.

Where non-KMS testing is needed, users with cards supported by KMS can still help by booting with the nomodeset boot option, or by booting in a virtual machine (KVM or virtualbox).

Boot medium

cryptsetup installed

Boot option

splash

video hardware

Graphical splash screen?

Booted to login screen/desktop?

X crash after login?

Tested by

Notes

Ubuntu LiveCD

n/a

"try Ubuntu without installing"

Y

Intel KMS

yes

yes

no

RobertWall

Dell Mini 10v + LiveUSB; no problems

Ubuntu LiveCD

n/a

"try Ubuntu without installing"

Y

ATI or nVidia KMS w/ one monitor connected

yes

yes

no

vorlon

nVidia 8600M GT

Ubuntu LiveCD

n/a

"try Ubuntu without installing"

Y

nVidia KMS w/ more than one monitor connected

yes

no

no

gangely

nVidia 275GTX w/ two LCDs; no VT switch; no CTL-Alt-Del; ok with only one LCD connected

Ubuntu LiveCD

n/a

"try Ubuntu without installing"

Y

non-KMS

yes (see notes)

yes

no

sbeattie

virtualbox guest, okay w/no options (bug 535108), nomodeset+vesafb (vga=0x317) == garbled splash text

Ubuntu LiveCD

n/a

"try Ubuntu without installing"

N

any

no

yes

no

vorlon

nVidia 8600M GT - no video output at all before X?

Ubuntu LiveCD

n/a

"install Ubuntu"

Y

Intel KMS

yes

yes

no

JeffStone

Acer Aspire One + LiveUSB; no problems

Ubuntu LiveCD

n/a

"install Ubuntu"

Y

ATI or nVidia KMS w/ one monitor connected

yes

yes

no

vorlon

nVidia 8600M GT

Ubuntu LiveCD

n/a

"install Ubuntu"

Y

nVidia KMS w/ more than one monitor connected

yes

no

no

vorlon

nVidia 8600M GT; 533135

Ubuntu LiveCD

n/a

"install Ubuntu"

Y

non-KMS

yes

yes

no

RobertWall

Dell Mini 10v with nomodeset + LiveUSB; splash screen had "Ubuntu 10.04" text instead of ubuntu logo

Ubuntu LiveCD

n/a

"install Ubuntu"

N

any

no

yes

no

pitti

Dell Mini 10; get proper console error messages (b43 missing firmware, etc.)

Kubuntu LiveCD

n/a

"try Kubuntu without installing"

Y

Intel KMS

Kubuntu LiveCD

n/a

"try Kubuntu without installing"

Y

ATI or nVidia KMS w/ one monitor connected

yes

yes

no

sbeattie

nVidia NV11GL [Quadro2 MXR/EX/Go]

Kubuntu LiveCD

n/a

"try Kubuntu without installing"

Y

nVidia KMS w/ more than one monitor connected

yes

yes

no

vorlon

nVidia 8600M GT - dodges 533135 because of lack of kdm integration?

Kubuntu LiveCD

n/a

"try Kubuntu without installing"

Y

non-KMS

yes

yes

no

ev

Kubuntu LiveCD

n/a

"try Kubuntu without installing"

N

any

Kubuntu LiveCD

n/a

"install Kubuntu"

Y

Intel KMS

Kubuntu LiveCD

n/a

"install Kubuntu"

Y

ATI or nVidia KMS w/ one monitor connected

Kubuntu LiveCD

n/a

"install Kubuntu"

Y

nVidia KMS w/ more than one monitor connected

yes

yes

no

vorlon

nVidia 8600M GT

Kubuntu LiveCD

n/a

"install Kubuntu"

Y

non-KMS

yes

yes

no

ev

Kubuntu LiveCD

n/a

"install Kubuntu"

N

any

Ubuntu install

Y

Y

Intel KMS

yes

yes

no

vorlon

Ubuntu install

Y

Y

ATI KMS w/ one display connected

yes

yes

no

bk109

ATI RadeonHD3200 (AMD780M chipset).Consistently getting plymouthd apport warning after boot

Ubuntu install

Y

Y

nVidia KMS w/ more than one monitor connected

Ubuntu install

Y

Y

non-KMS

no

yes

no

vorlon

Intel+nomodeset

Ubuntu install

Y

N

any

no

yes

no

vorlon

Kubuntu install

Y

Y

Intel KMS

Kubuntu install

Y

Y

ATI or nVidia KMS w/ one monitor connected

Kubuntu install

Y

Y

nVidia KMS w/ more than one monitor connected

Kubuntu install

Y

Y

non-KMS

Kubuntu install

Y

N

any

Ubuntu install

N

Y

Intel KMS

yes

yes

no

scott

Ubuntu install

N

Y

ATI or nVidia KMS w/ one monitor connected

yes

yes

no

vorlon

nVidia 8600M GT

Ubuntu install

N

Y

nVidia KMS w/ more than one monitor connected

yes

no

no

vorlon

nVidia 8600M GT w/ external VGA; hangs at boot splash; no VT switch; Alt+SysRq+K starts X

Ubuntu install

N

Y

non-KMS

faked

yes

no

scott

Ubuntu install

N

N

any

no

yes

no

scott

no fsck messages Sad :-( 540645

Kubuntu install

N

Y

Intel KMS

Kubuntu install

N

Y

ATI or nVidia KMS w/ one monitor connected

Kubuntu install

N

Y

nVidia KMS w/ more than one monitor connected

yes

yes

no

vorlon

nVidia 8600M GT

Kubuntu install

N

Y

non-KMS

Kubuntu install

N

N

any

Ubuntu server

Y

Y

Intel KMS

Ubuntu server

Y

Y

ATI or nVidia KMS w/ one monitor connected

Ubuntu server

Y

Y

nVidia KMS w/ more than one monitor connected

Ubuntu server

Y

Y

non-KMS

faked

yes

N/A

sbeattie

VMWare SVGA II Adapter

Ubuntu server

Y

N

any

Ubuntu server

N

Y

Intel KMS

Ubuntu server

N

Y

ATI or nVidia KMS w/ one monitor connected

Ubuntu server

N

Y

nVidia KMS w/ more than one monitor connected

Ubuntu server

N

Y

non-KMS

Ubuntu server

N

N

any

Ubuntu install

N

Y

Intel KMS

NO

Yes

NO

DavidM

Ubuntu install

N

Y

nVidia KMS w/ more than one monitor connected

yes

no

no

lantash

nVidia 6900 GS; 533135

Boot medium

cryptsetup installed

Boot option

splash

video hardware

Graphical splash screen?

Booted to login screen/desktop?

X crash after login?

Tested by

Notes

Testing/Plymouth (last edited 2010-03-29 07:22:37 by vorlon)