Universe_Translations_in_LP

Universe translations in Launchpad

Universe, is one of the four repositories that make up Ubuntu (Main, Multiverse, Restricted and Universe). Until now only translations of packages in Main repository have been available under http://translations.launchpad.net/ubuntu/.

For Universe packages translations that are packaged for current Ubuntu version are used.

To give an example: If geany 0.18 is packaged in the universe for Ubuntu 11.10, translations in that package will be used even if better translations are available in the current version 0.20 (in this case the newest version is packaged for Ubuntu 11.10 but that is not always the case). Furthermore, for Universe packages translations are not taken into account until a new version of the program is packaged and released (translations are not a part of language packs). This has caused a significant delay in availability of newest translations in the past and also made translation more difficult as packages needed to be translated upstream, which caused:

a) lower visibility of translations (one needed to go to upstream project page to be available to translate) b) in many cases the translations workflow is significantly different and more technically challenging, which scares away less technical problems.

To alleviate this issue in the future selected Universe packages are going to be translatable under translations.launchpad.net/ubuntu. Not all universe packages are going to be available for translations since:

  • we don't want to get translations.launchpad.net/ubuntu overcrowded
  • packages need to be slightly changed in order to be translatable by maintainers

Before this feature is implemented it might be wise to get in contact with selected upstream projects about possibility of translations imports/exports.

Proposed Universe packages to be translated in Launchpad

The purpose of this page is to keep a list of packages, which are considered to be important (often used) and hence should be translatable in LP.

Package name

Reason

Developer

Person in contact

Status

Wine

Often used

Scot Ritchie

David

gnome-panel

Formerly on the CD, translations should already exist

Sebastien Bacher

Andrej

WAITING DEV. RESPONSE

synaptic

Miachel Vogt

David

epiphany-browser

The real GNOME browser, integrates with gnome-keyring and desktop much better

Jeremy Bircha

Andrej

WAITING DEV. RESPONSE

xfce4-power-manager

xfce4-power-manager is default in Xubuntu. Currently, for new upstream translations to land downstream, new upstream packaging is required. For this package that probably won't happen, as no new application code is underway. So it's up to downstream.

xubuntu-devel

Andrej

WAITING DEV. RESPONSE

xfce4-mixer

See above (xfce4-power-manager)

xubuntu-devel

Andrej

WAITING DEV. RESPONSE

xfce4-taskmanager

See above (xfce4-power-manager)

xubuntu-devel

Andrej

WAITING DEV. RESPONSE

xfburn

See above (xfce4-power-manager)

xubuntu-devel

Andrej

WAITING DEV. RESPONSE

xfce4-systemload-plugin

See above (xfce4-power-manager)

xubuntu-devel

Andrej

WAITING DEV. RESPONSE

xfce4-weather-plugin

See above (xfce4-power-manager)

xubuntu-devel

Andrej

WAITING DEV. RESPONSE

alacarte

Default menu editor for Xubuntu 12.04

xubuntu-devel

Andrej

WAITING DEV. RESPONSE

obconf

Default desktop configuration manager for Lubuntu

Julien Lavergne

Andrej

WAITING DEV. RESPONSE

abiword

Default word processor for Xubuntu and Lubuntu

xubuntu-devel

Andrej

WAITING DEV. RESPONSE

tomboy

gbrainy

Siegfried Gevatter

Andrej

WAITING DEV. RESPONSE

geany

?

Andrej

lxdm (and other Lubuntu packages)

Lubuntu users

Julien Lavergne

Andrej

WAITING DEV. RESPONSE

banshee

Chow Loong Jin

Andrej

DONE

gnome-applets

Robert Ancell

Andrej

DEV. NOT INETERESTED

gnome color manager

linked to from gnome control center

Michael Biebel

Andrej

DEVELOPER NOT INTERESTED - BLOCKED

hardinfo

Default System Profiler and Benchmark in Lubuntu. Nowhere translatable, not even upstream.

BLOCKED

Compizconfig-settings-manager

Required to change compiz (default package) options (this package is to be avoided for average users because it can cause breakage of unity)

BLOCKED

gdm

Ubuntu adds extra strings, see LP: 542068. Maybe we don't need it as Ubuntu now uses lightdm

BLOCKED

chromium-browser

Popular open source browser - already translatable at https://translations.launchpad.net/chromium-browser. Also appearently doesn't use gettext and cannot be shipped in language packs

BLOCKED

Template for bug reports

This is a template for bug reports to be sent to the maintainers.

Maintainer instructions for exposing universe package translations in Launchpad

  1. Add X-Ubuntu-Use-Langpack: yes to debian/control's source record

  2. Use dh_translations to generate a POT file during the build process.

Notes:

  • More precisely, there needs to be a (correctly named) PO template after build. Preferably it gets generated during build, but it will also work if the package ships a static one (in that case you'll need to ensure to update it each time you change strings, though).
  • dh_translations checks for some standard build systems (automake, cmake, Python distutils) to figure out how to build a POT. If the source does not have any build system at all, it will not be able to do this, so the debian/rules should take care of it, or upstream ship a correctly named one.

  • You'll find more background info on building POT templates during build here, but note that the page is not yet up to date in terms of recommending dh_translations as the preferred way for template generation.

Translations/Universe_Translations_in_LP (last edited 2012-06-30 12:00:25 by andrej.znidarsic)