20090205

Differences between revisions 1 and 33 (spanning 32 versions)
Revision 1 as of 2009-02-03 14:57:22
Size: 2707
Editor: mrkanister
Comment:
Revision 33 as of 2009-02-12 18:50:57
Size: 51286
Editor: a89-182-211-204
Comment: edited bugs #320685 with 'hugday close'
Deletions are marked like this. Additions are marked like this.
Line 8: Line 8:


== Tools ==

For doing your work easier during the hug days remember to use the [[https://wiki.ubuntu.com/UbuntuBugDay/Tools|hugday-tools]].
Line 21: Line 26:
{{{
Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you please add the log files from '/var/log/dist-upgrade/' to this bug report as separate attachments? Thanks in advance.
}}}
Line 22: Line 31:


== Tags ==

Tagging bugs are also a good way to isolate reports, the [[https://wiki.ubuntu.com/DebuggingUpdateManager|Update-Manager]] product currently use these following tags:

||<rowbgcolor="#FFEBBB"> '''Tag''' || '''Use case''' ||
|| [[https://launchpad.net/ubuntu/+bugs?field.tag=hardy2intrepid|`hardy2intrepid`]] || Bugs related to upgrades from Hardy Heron (8.04) to Intrepid Ibex (8.10) ||
|| [[https://launchpad.net/ubuntu/+bugs?field.tag=gutsy2hardy|`gutsy2hardy`]] || Bugs related to upgrading from Gutsy Gibbon (7.10) to Hardy Heron (8.04) ||
|| [[https://launchpad.net/ubuntu/+bugs?field.tag=feisty2gutsy|`feisty2gutsy`]] || Bugs related to upgrading from Feisty Fawn (7.04) to Gutsy Gibbon (7.10) ||
|| [[https://launchpad.net/ubuntu/+bugs?field.tag=edgy2feisty|`edgy2feisty`]] || Bugs related to upgrading from Edgy Eft (6.10) to Feisty Fawn (7.04) ||
|| [[https://launchpad.net/ubuntu/+bugs?field.tag=dapper2hardy|`dapper2hardy`]] || Bugs related to upgrades from Dapper Drake (6.06) to Hardy Heron (8.04) ||
|| [[https://launchpad.net/ubuntu/+bugs?field.tag=cdrom-upgrade|`cdrom-upgrade`]] || Bugs related to an upgrade from CD-ROM or DVD media ||

If you find a report which match any of those Use cases please add the tag to it.
Line 31: Line 55:



== 104 Incomplete Bugs ==
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/98496|98496 ]] || Firefox crashes during an update || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/115131|115131 ]] || When upgrade manager crashes, upgrade can't be resumed || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/163606|163606 ]] || distribution upgrade buggy(apparent hangs) || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/183750|183750 ]] || update-manager connects to obsolete proxy || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/195945|195945 ]] || "Updates Available" icon from Tango clashes with "Crash Report Detected" icon || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/207445|207445 ]] || Adept dist-update error window is too small || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/217936|217936 ]] || Allow delay of update-manager download start to use cheap bandwidth || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/225816|225816 ]] || cdrom upgrade crashes in DistUpgradeViewKDE || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/226217|226217 ]] || Dapper-to-Hardy upgrade fails on PowerPC (prerequisite dapper-backports missing) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/228415|228415 ]] || Update download speed is incredibly slow for connection || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/253747|253747 ]] || update manager does not allow resize of install window || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/254480|254480 ]] || Update-manager marks upgrades as completed even if they aren't || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/257639|257639 ]] || E: The package cache file is corrupted E: _cache->open() failed, please report. || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/271969|271969 ]] || Error during update-Power Pc (Hardy>Intrepid) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/273049|273049 ]] || update-manager should guest an estimative of upgrade size to prevent running out of free disk || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/280941|280941 ]] || update-manager "partial upgrade" should distinguish unmet dependencies from unused dependencies || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/283645|283645 ]] || On dist-upgrade, disable /etc/apt/preferences || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/290723|290723 ]] || intrepid RC failed to install || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/291241|291241 ]] || cpu wasted if download speed goes to 0 || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/291432|291432 ]] || update-manager via ssh: php.ini and sensors.conf dialogs not readable || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/294057|294057 ]] || 8.10 cdrom upgrade either doesn't upgrade or doesn't use the CD-ROM || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/295650|295650 ]] || High CPU load while updating package lists || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/295859|295859 ]] || Upgrade Manager crashes during upgrade from Kubuntu Hardy to Intrepid || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/297286|297286 ]] || dist-upgrade reinstalls previously removed packages || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/301970|301970 ]] || update.manager unresponsive after installing updates || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/307851|307851 ]] || Update manager shows invalid value in "last updated" field if failed to get package list || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/307890|307890 ]] || Update breaks sound, network, booting. Live CD works fine. || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/308325|308325 ]] || AMD64 update-manager dependency requirements || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/309912|309912 ]] || update-manager crashed with NameError in get_changelog() || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/311196|311196 ]] || [kde] upgrade tool crashed || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/311438|311438 ]] || package update-manager 1:0.93.34 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg exited unexpectedly || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/311441|311441 ]] || Initialization of update-manager fails || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/311555|311555 ]] || update-manager space saving suggestion || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/312515|312515 ]] || confusing behavior regarding preferred version || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/313538|313538 ]] || [kde] upgrader crashed with CacheExceptionDpkgInterrupted || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/314215|314215 ]] || update-manager crashed with SIGSEGV in PyErr_SetFromErrno() || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/315058|315058 ]] || upgrade to intrepid: KDE shows white screen || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/315663|315663 ]] || [apport] package update-manager-core failed to install/upgrade: || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/315694|315694 ]] || package update-manager 1:0.87.30 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /tmp/tmpExfjCH/backports/usr/bin/dpkg returned an error code (1) || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/317535|317535 ]] || [jaunty] update-manager doesn't honor "hold" flag for packages || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/318469|318469 ]] || Update manager cant handle proxy authentication with dots in login name [8.10] || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/319146|319146 ]] || When a release reaches End-of-Life, update manager should show EoL status and provide a link with working procedures and more information. || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/319372|319372 ]] || message about the unavailabillity of the changes list is worded wrongly || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/320222|320222 ]] || _cache->open() failed, please report. || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/320288|320288 ]] || package update-manager 1:0.93.35 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1), E:Sub-process /usr/bin/dpkg returned an error code (1), E:Sub-process /usr/bin/dpkg returned an error code (1) || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/320630|320630 ]] || upgrade from 7.1 to 8.04LTS || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/322076|322076 ]] || package update-manager 1:0.93.35 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1), E:Sub-process /usr/bin/dpkg returned an error code (1), E:Sub-process /usr/bin/dpkg returned an error code (1) || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/322152|322152 ]] || taskbar tab pulses unnecessarily || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/322389|322389 ]] || package linux-image-2.6.27-11-generic 2.6.27-11.25 failed to install/upgrade: underprocess post-installation script gav felkod 1 || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/322482|322482 ]] || distribution upgrade via update-manager fails over remote GDM || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/322742|322742 ]] || package update-manager 1:0.93.34 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): installArchives() failed || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/322821|322821 ]] || error "could not calculate the upgrade" || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/322871|322871 ]] || Download speed is not correctly displayed (wrong memory address for that variable ?) || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/323416|323416 ]] || url/ubuntu/dists/hardy-security/main/binary not found on this server || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/323472|323472 ]] || distribution upgrade failed to fetch ktimetracker_4.1.3-0ubuntu1~intrepid2_i386.deb || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/323493|323493 ]] || distribution uprade || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/323602|323602 ]] || package update-manager 1:0.97 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/323628|323628 ]] || Adept manager cann't update || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/323668|323668 ]] || Could not initialize the package information || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/324640|324640 ]] || update-manager "crash" while updating || mangilimic ||


== Incomplete Bugs ==
Line 40: Line 123:



== 77 Confirmed Bugs ==
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/46817|46817 ]] || ifrename package not purged || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/49851|49851 ]] || Update manager doesn't show packages availible for update. || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/77528|77528 ]] || "Size mismatch" error is unhelpful || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/89676|89676 ]] || After installing all possible updates update-manager still shows amount of available updates || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/99066|99066 ]] || There are a lot of updates, but "Download size" is 0 || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/107000|107000 ]] || update-manager should make sure that it is uptodate before a dist-upgrade even if edgy-updates is not available || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/108479|108479 ]] || Distribution Upgrade (to Feisty) fails: coreutils can not be installed if there is a different install-info in PATH || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/144427|144427 ]] || "Updates available" notification icon appears during OS upgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/147429|147429 ]] || Could not install 'debconf' during System upgrade 7.04 to 7.10 || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/150677|150677 ]] || Update Manager does not respect gtk-button-images setting || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/153880|153880 ]] || Update manager hangs during install from Feisty to Gutsy || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/154000|154000 ]] || kubuntu dist upgrade tool crashed || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/154590|154590 ]] || Change group right during updrage to Gutsy || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/185116|185116 ]] || kubuntu version upgrade failed "Can't install 'kubuntu-desktop'" || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/185122|185122 ]] || update manager cannot update while auto-update is occuring || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/191004|191004 ]] || Could not verify integreity of upgrader programme. This application will now exit. Feisty to Gutsy upgrade || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/205225|205225 ]] || Upgrade from gutsy to hardy hangs || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/207743|207743 ]] || Unicode character not correctly displayed || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/208545|208545 ]] || re:ubuntu-8.04-beta-alternate-amd64. No upgrade dialog just the file manager showing the disc contents. || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/218051|218051 ]] || Update Manager not updating last time checking repo || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/219531|219531 ]] || cannot calculate upgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/221388|221388 ]] || reboot dialog steals focus on upgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/221699|221699 ]] || package update-manager 1:0.81.3 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): installArchives() failed || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/222055|222055 ]] || [Hardy, Ubuntu-Studio] Upgrade crashes || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/225439|225439 ]] || Upgrade from Kubuntu 7.10 to 8.04 removes hostname from /etc/hosts || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/225978|225978 ]] || cannot upgrade to 8.04 from 7.1 || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/227282|227282 ]] || [hardy] Update Manager and Synaptic fail to install recommended updates without any explanation || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/227660|227660 ]] || Fail to update || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/227762|227762 ]] || do-release-upgrade logs a failed usermod near the end || mrkanister ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/233975|233975 ]] || 7.10 to 8.04 upgrade fails || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/239554|239554 ]] || cdromupgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/240724|240724 ]] || Could not calculate upgrade-Can't mark 'kubuntu-desktop' for upgrade || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/251783|251783 ]] || E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/257545|257545 ]] || Upgrade problem || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/259430|259430 ]] || /media/cdrom-1/cdromupgrade: line 32: 12909 Segmentation fault $TMPDIR/$COD ENAME --cdrom "$cddirname" || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/261471|261471 ]] || update-manager crashed with GError in restore_state() || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/262676|262676 ]] || package update-manager 1:0.87.30 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Couldn't configure pre-depend cups for cups-pdf, probably a dependency cycle. || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/267733|267733 ]] || update-manager layout does not leave adequate room for package short descriptions || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/271045|271045 ]] || update manager and synaptic crash || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/272472|272472 ]] || package update-manager 1:0.87.24 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): installArchives() failed || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/276982|276982 ]] || can't use update-manager || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/277700|277700 ]] || lack of meaningful dialogue box on a simple space problem when upgrading || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/277817|277817 ]] || Unable to install Intrepid beta (8.10) on a HP Pavillion Notebook || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/279884|279884 ]] || Intrepid Ibex fails via update-manager || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/280662|280662 ]] || Ubuntu 7.04 to 7.10 failed while installing packages || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/281142|281142 ]] || problems updating database if harddisk is suddenly full during installation || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/282270|282270 ]] || Upgrade Hash Sum mismatch || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/282748|282748 ]] || Could not initialize the package information || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/283014|283014 ]] || dpkg: warning unable to delete old directory `/usr/lib/python2.5/site-packages/DistUpgrade': Directory not empty || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/284178|284178 ]] || update-manager crashes during update || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/284462|284462 ]] || users should be added in the fuse group during a gutsy to hardy upgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/284541|284541 ]] || Update manager does not report the last update correctly || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/287105|287105 ]] || update manager error ubuntu 8.04 || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/287777|287777 ]] || Update manager does not install updates || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/288746|288746 ]] || update hoary to intrepid RC failed with dpkg locked || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/288885|288885 ]] || menu.lst not updated with update to intrepid || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/289611|289611 ]] || Hardy KDE 4 remix to Intrepid is incomplete || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/291563|291563 ]] || 8.10 update-manager error, ubuntu-minimal missing || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/292318|292318 ]] || adept dist-upgrade crashed upgrading from 8.04 to 8.10 || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/292352|292352 ]] || dist upgrade fails on xubuntu HH to II || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/292746|292746 ]] || update manager cannot find commercial/binary-amd64/Packages in Meta-index file || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/293342|293342 ]] || [Hardy] update-manager can't install 'ubuntu-desktop' || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/293666|293666 ]] || Update Manager crashes after selecting check for updates || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/295069|295069 ]] || update manager error on upgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/301318|301318 ]] || intrepid upgrade 8.04 to 8.10 on KDE fails with following error || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/301767|301767 ]] || Package always appears greyed out and partially cut off || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/301783|301783 ]] || 8.04 wouldn't let me upgrade through update-manager || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/303251|303251 ]] || applet || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/303827|303827 ]] || can't update from ubuntu 6.06 TLS to 8.04 TLS || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/306287|306287 ]] || Offline upgrade from 8.04 to 8.10 fails (using kubuntu 8.10 alternate iso) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/306902|306902 ]] || crash when updating from gutsy to hardy (ppc) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/309412|309412 ]] || Upgrade problem || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/310223|310223 ]] || upgrading feisty failed || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/310682|310682 ]] || [jaunty] update-manager crashes with segfault || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/311603|311603 ]] || Bad upgrade from 8.04 to 8.10 || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/311805|311805 ]] || can't upgrade from hardy to interpid with update-manager || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/312330|312330 ]] || upgrade from 8.04 to 8.10 crashes || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/312580|312580 ]] || update-manager crashed with ImportError in <module>() || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/312672|312672 ]] || 8.10 cdrom upgrade error-could not calc upgrade || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/313433|313433 ]] || Distribution update to 8.04 message: no package named `x11-xkb-utils' is installed, cannot configure || mangilimic ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/313517|313517 ]] || upgrade from kubuntu 8.04 to8.10 failed - network problem? || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/313531|313531 ]] || Problem with Update-Manager || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/313875|313875 ]] || 'update-manager' unresolvable problem occurred while initializing the package information || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/314495|314495 ]] || 'update manager' frozen || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/314584|314584 ]] || Could not download the upgrades || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/315085|315085 ]] || update manager || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/315327|315327 ]] || Update Failure || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/315712|315712 ]] || >8.10 U-M complained/exited low disk; have 8GB! || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/316939|316939 ]] || papercut fails on install of kubuntu 8.10 || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/317080|317080 ]] || subprocess post-removal script returned error exit status 2 || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/317467|317467 ]] || update manager doesn't download packages any more after upgrade to intrepid || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/317747|317747 ]] || update-manager crashed || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/318387|318387 ]] || java update cannot install (does it need acceptance of T&C?) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/318793|318793 ]] || Update manager crashes || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/319034|319034 ]] || E: the package lists or status file could not be parsed or opened || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/319473|319473 ]] || could not initialize the package information || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/319675|319675 ]] || Can't update or install software... apt-get update doesn't work either || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/319862|319862 ]] || E:The method driver /usr/lib/apt/methods/bzip2 could not be found. || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/320548|320548 ]] || the package "cups" failde to upgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/320851|320851 ]] || update manager crashes || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/321002|321002 ]] || error during upgrading || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/321251|321251 ]] || Update manager won't start. || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/321463|321463 ]] || update manager error processing dependencies || mangilimic ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/321792|321792 ]] || update-manager very slow on asus eee box 202 || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/324058|324058 ]] || update-manager upgrade from up-to-date 6.06.2 LTS to 8.04.1 LTS fails || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/324169|324169 ]] || update-manager || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/324629|324629 ]] || An unresolvable problem occurred while initalizing the package information. || ||


== Confirmed Bugs ==
Line 51: Line 240:
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/19421|19421 ]] || Humanized changelog and news after a dist-upgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/33605|33605 ]] || "Updates available" popup should hide when update-manager starts || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/33606|33606 ]] || Should autodetect CD insertion || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/35876|35876 ]] || 'Downloading package information' and 'building dependency tree' progress dialogs request focus too often || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/36929|36929 ]] || Add "IfInstalled: foo Install: bar" to DistUpgrade.cfg (was: Upgrade to dapper breaks mp3 playback) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/40792|40792 ]] || [Dist-upgrader] Window too big in 800x600 || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/42798|42798 ]] || update-manager improve: update repositories information || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/45129|45129 ]] || update-manager should have per-package changelog locations (was: uses changelogs.ubuntu.com for all packages) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/46758|46758 ]] || [dist-upgrader] User should be prompted to update *before* the upgrade process starts || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/47648|47648 ]] || could not calculate upgrade with old kernel package installed || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/49489|49489 ]] || Fatal error on upgrade - NoSectionError Distro || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/50791|50791 ]] || [dist-upgrader] When doing a dist-upgrade the upgrade tool should give the option to remove packages not being maintained in main any more || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/52158|52158 ]] || Shows pinned packages as available to update || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/56297|56297 ]] || Synaptic won't add Ubuntu CD to the repositories - freezes || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/61852|61852 ]] || Failing to fetch some packages should display a better/nicer error message || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/65570|65570 ]] || bogus pluralization of singular nouns || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/67090|67090 ]] || On upgrading to Edgy from Dapper, confusing kernel selection || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/67338|67338 ]] || Update waits indefinitely for user input (on terminal/debconf/conffile prompts) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/67382|67382 ]] || RFE: a bit more flexibility in handling modified files (conffile prompt) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/68453|68453 ]] || u-m GUI shows no feedback when mirrors are slow, timing out. || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/74899|74899 ]] || crashed in saveDistUpgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/77952|77952 ]] || cancelling software update install causes a rescan and forgets my selection || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/81464|81464 ]] || Update manager Instruction cannot be carried out || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/85644|85644 ]] || Clickable URLs need context menu || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/86028|86028 ]] || RFE: ask all config-file questions that the start or end of the upgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/107188|107188 ]] || [patch] Upgrade tool crashed with " Cannot allocate memory" || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/107766|107766 ]] || system-config-printer adds menu item the same as gnome-cups-manager's menu item || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/107779|107779 ]] || Upgrade Tool Crashed || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/108390|108390 ]] || better mirror support || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/108568|108568 ]] || CD-based upgrade from Edgy to Feisty fails on bad CD burns || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/108601|108601 ]] || Update-manager needs help info when terminating on wrong repositories and generally deal better with incorrect sources.list data || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/108910|108910 ]] || upgrade error from edgy server to feisty server becasue invoke-rc.d fails at "at" || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/109397|109397 ]] || update-manager becomes unresponsive because it cannot download ReleaseAnnouncement (needs sensible timeout) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/109765|109765 ]] || run apt-get autoclean after upgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/110388|110388 ]] || X fails after Fiesty install on AMD64 w/ATI binary drivers || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/112272|112272 ]] || ValueError: too many values to unpack (DistUpgradeControler.py stack trace) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/114587|114587 ]] || dapper to gutsy(+1): mozilla transition tweaks needed || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/116465|116465 ]] || Update to feisty failed on 3 different computers || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/122197|122197 ]] || Upgrade Manager failed from 6.10 to 7.04 || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/127243|127243 ]] || update-manager (and others) should lower their priority when working || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/128332|128332 ]] || update manager is showing "updates available" but no update is available (because prefer version from Feisty) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/133139|133139 ]] || update-manager bug when loading Changes is slow || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/133325|133325 ]] || Broken packages result in meaningless error message || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/137467|137467 ]] || crash in a update-manager edgy->feisty || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/144773|144773 ]] || update-manager crashed with AssertionError in saveDistUpgrade() || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/144920|144920 ]] || Prerequisites download fails if gpg authentication fails on over-aggressive caches || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/145764|145764 ]] || doesn't state why updates are necessary || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/146536|146536 ]] || Could not calculate the upgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/147742|147742 ]] || [kde] kde-tempdir removes all -x bits and that breaks the custom invoke-rc.d that is used during the upgrade (was: upgrade fails because invoke-rc.d fails) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/147758|147758 ]] || upgrade from feisty to gutsy beta errors || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/147928|147928 ]] || too many annoying interruptions during distribution upgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/149203|149203 ]] || If update-manager -d fails, you can't try again || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/150927|150927 ]] || kubuntu adept_manager --version-upgrade to 7.10 has some confusing dialog messages. || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/151098|151098 ]] || Cancelling download incorrectly results in error message || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/151242|151242 ]] || Prompt temporary move /var/cache/apt to other partition for distribution upgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/151943|151943 ]] || says no update available in the middle of the upgrade to gutsy RC when preferences define a low priority for new release || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/152412|152412 ]] || Download speed displayed as 'unknown' in update manager for the first seconds || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/152580|152580 ]] || Upgrade to gutsy beta crashes because of insufficient disc space || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/153228|153228 ]] || use monospace font in release notes window || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/153980|153980 ]] || 7.04->7.10 "Upgrade" fails: "Getting upgrade prerequisites failed" || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/153984|153984 ]] || dist upgrade tool 7.10 gutsy freezes || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/154094|154094 ]] || Transition from feisty-commercial to partner incorrect? (was: Error during update) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/154272|154272 ]] || Visual indication when final release comes out || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/156102|156102 ]] || [kde] RuntimeError: underlying C/C++ object has been deleted (was: Upgrade tool crashed Kubuntu Feisty to Gutsy) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/156320|156320 ]] || [kde] copy XAUTHORITY may fail and crashes the upgrader (was: Upgrade tool crashed when upgrading 7.04 -> 7.10) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/157907|157907 ]] || Dist upgrade failed while running update-initramfs || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/159458|159458 ]] || Error during update || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/160362|160362 ]] || "Ubuntu has some information for you." || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/160805|160805 ]] || pre-set PYTHONPATH breaks major upgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/160861|160861 ]] || DVD should be recognized as upgrade volume || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/162441|162441 ]] || improve download cancel handling || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/162845|162845 ]] || update-manager crashed with SIGSEGV in g_main_context_prepare() || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/164681|164681 ]] || [wishlist] Update-manager should allow to ignore misc updates || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/165235|165235 ]] || package libapache2-mod-php5 5.2.3-1ubuntu6 failed to install/upgrade: || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/172979|172979 ]] || Partial french translation of dist upgrade time estimate || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/173050|173050 ]] || update-manager does not correctly interpret gnome proxy configuration [gutsy] || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/173245|173245 ]] || update-manager prevents users from seeing&recording errors || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/173277|173277 ]] || Packages failed to install hardy || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/174024|174024 ]] || update-manager shows wrong changelog || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/178905|178905 ]] || update manager does not deal with packages in "reinstreq" state || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/180032|180032 ]] || Update removes vital media codex. || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/186465|186465 ]] || "distribution upgrade" hangs during update to hardy || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/187316|187316 ]] || Server upgrade from 7.04 to 7.10 fails || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/189620|189620 ]] || policykit integration missing || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/190782|190782 ]] || [Patch] RGBA support in update-manager || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/193558|193558 ]] || [Wishlist] Include limit-rate bandwidth option || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/195985|195985 ]] || update-manager could not upgrade...."release-upgrader-dpkg" untrusted || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/196699|196699 ]] || dist-upgrade crashes while upgrading from 7.04 to 7.10 || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/199986|199986 ]] || Shouldn't override the font in the terminal widget || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/200127|200127 ]] || ubuntu incorrectly believes I enjoy staring at progress bars || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/203659|203659 ]] || Pinned hardy repository causes update-manger to fail but shows no error message || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/209459|209459 ]] || The package information was last updated 1 days ago || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/209718|209718 ]] || bzr ppas block upgrade-manager partial upgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/213805|213805 ]] || BIOS beep occurs when clicking in lower half for the first time || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/215126|215126 ]] || update-manager shouldn't use modal dialogs || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/216368|216368 ]] || [kde] Distupgrade from Gutsy to Hardy (beta) fails || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/221285|221285 ]] || Gutsy->Hardy Upgrade: "unresolvable problem occurred" || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/222024|222024 ]] || Upgrade from 7.04 to 7.10 stops on 2nd step (Modifying the software channels) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/222096|222096 ]] || Many errors installing packages during upgrading to 8.04 || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/223011|223011 ]] || Partition not mounted after Gutsy to Hardy upgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/223542|223542 ]] || Release upgrade procedure "sucks" (from Gutsy to Hardy) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/223826|223826 ]] || [Dist Upgrade] Enhancement: user-friendly error reporting? || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/226254|226254 ]] || IOError: [Errno 32] Broken pipe || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/226574|226574 ]] || Failed to upgrade (7.10->8.04) || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/228247|228247 ]] || Update-manager requires connectivity to changelog.ubuntu.com - mirrors alone aren't sufficient || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/228510|228510 ]] || kubuntu - Upgrade Tool Crashed: CacheExceptionDpkgInterrupted || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/228928|228928 ]] || update-manager gives fixed-size window for customised configuration diff || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/230043|230043 ]] || Icons in Update Manager || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/231419|231419 ]] || update-manager starts gnome-power-manager when it's not wanted || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/249335|249335 ]] || update manager lines are unreadable || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/252068|252068 ]] || interrupted upgrade should automatically resume || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/255443|255443 ]] || update manager could warn of possible need to restart before installing || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/257114|257114 ]] || release upgrade from dapper to hardy possibly due to network error || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/272131|272131 ]] || Detect internet connection before trying to check for updates || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/272540|272540 ]] || Notify user if a program is in use that has been removed from the repositories || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/277985|277985 ]] || dapper to hardy: could not calculate the upgrade || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/278640|278640 ]] || Kubuntu 8.04 amd64 upgrade to 8.10 fails. Upgrade tool exits without messages. || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/282426|282426 ]] || update-manager crashed with SIGSEGV || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/283500|283500 ]] || Synaptic, update-manager, and apt-get should share proxy settings || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/289009|289009 ]] || Update manager says nothing about apt-listbugs prompt || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/289197|289197 ]] || [Intrepid, hardy] security updates aren't enabled by default when installing without internet connection || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/291342|291342 ]] || free disk space check could actually carry out suggested ways to clear space || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/312364|312364 ]] || update-manager crashed with SIGSEGV in PyErr_SetFromErrnoWithFilenameObject() || ||
||<rowstyle="background-color: ;"> [[https://bugs.launchpad.net/bugs/316911|316911 ]] || update-manager disables back button when managing conffiles || ||
||<rowstyle="background-color: lightgreen;"> [[https://bugs.launchpad.net/bugs/320685|320685 ]] || intrepid->jaunty, openssl-blacklist got removed || xxxxx ||
Line 59: Line 372:
{{http://people.ubuntu.com/~brian/complete-graphs/update-manager/plots/update-manager-week-triaging.png}} {{attachment:update-manager-week-triaging.png}}

This week's Hug Day will focus on update-manager!

After you have triaged or fixed a bug put your name in the last column and set the row's background to green by adding lightgreen in the first cell of the column after rowbgcolor=. This will let people know that the bug in that row has been hugged.

Tools

For doing your work easier during the hug days remember to use the hugday-tools.

5-a-day-ing

During hug days you can also do 5-A-Day for this one you can do the following in order to tag your work on the hug day:

  • 5-a-day --add-tag hugday-20090205
  • Add bugs to 5-a-day as usual
  • And when done with hug day run: 5-a-day --remove-tag hugday-20090205

Stock Responses

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you please add the log files from '/var/log/dist-upgrade/' to this bug report as separate attachments? Thanks in advance.

For problem specific Stock Responses see: Bugs/Responses

Tags

Tagging bugs are also a good way to isolate reports, the Update-Manager product currently use these following tags:

Tag

Use case

`hardy2intrepid`

Bugs related to upgrades from Hardy Heron (8.04) to Intrepid Ibex (8.10)

`gutsy2hardy`

Bugs related to upgrading from Gutsy Gibbon (7.10) to Hardy Heron (8.04)

`feisty2gutsy`

Bugs related to upgrading from Feisty Fawn (7.04) to Gutsy Gibbon (7.10)

`edgy2feisty`

Bugs related to upgrading from Edgy Eft (6.10) to Feisty Fawn (7.04)

`dapper2hardy`

Bugs related to upgrades from Dapper Drake (6.06) to Hardy Heron (8.04)

`cdrom-upgrade`

Bugs related to an upgrade from CD-ROM or DVD media

If you find a report which match any of those Use cases please add the tag to it.

New Bugs

To mark it off the list you should:

  • Verify the bug is still not fixed
  • Request any needed info, Subscribe, Status to incomplete or

  • Set status to Confirmed

Bug

Subject

Triager

98496

Firefox crashes during an update

115131

When upgrade manager crashes, upgrade can't be resumed

163606

distribution upgrade buggy(apparent hangs)

183750

update-manager connects to obsolete proxy

mangilimic

195945

"Updates Available" icon from Tango clashes with "Crash Report Detected" icon

207445

Adept dist-update error window is too small

217936

Allow delay of update-manager download start to use cheap bandwidth

225816

cdrom upgrade crashes in DistUpgradeViewKDE

226217

Dapper-to-Hardy upgrade fails on PowerPC (prerequisite dapper-backports missing)

228415

Update download speed is incredibly slow for connection

253747

update manager does not allow resize of install window

254480

Update-manager marks upgrades as completed even if they aren't

mangilimic

257639

E: The package cache file is corrupted E: _cache->open() failed, please report.

271969

Error during update-Power Pc (Hardy>Intrepid)

273049

update-manager should guest an estimative of upgrade size to prevent running out of free disk

280941

update-manager "partial upgrade" should distinguish unmet dependencies from unused dependencies

mangilimic

283645

On dist-upgrade, disable /etc/apt/preferences

290723

intrepid RC failed to install

mangilimic

291241

cpu wasted if download speed goes to 0

291432

update-manager via ssh: php.ini and sensors.conf dialogs not readable

mangilimic

294057

8.10 cdrom upgrade either doesn't upgrade or doesn't use the CD-ROM

mangilimic

295650

High CPU load while updating package lists

295859

Upgrade Manager crashes during upgrade from Kubuntu Hardy to Intrepid

297286

dist-upgrade reinstalls previously removed packages

mangilimic

301970

update.manager unresponsive after installing updates

307851

Update manager shows invalid value in "last updated" field if failed to get package list

307890

Update breaks sound, network, booting. Live CD works fine.

mangilimic

308325

AMD64 update-manager dependency requirements

309912

update-manager crashed with NameError in get_changelog()

311196

[kde] upgrade tool crashed

mangilimic

311438

package update-manager 1:0.93.34 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg exited unexpectedly

mangilimic

311441

Initialization of update-manager fails

mangilimic

311555

update-manager space saving suggestion

312515

confusing behavior regarding preferred version

mangilimic

313538

[kde] upgrader crashed with CacheExceptionDpkgInterrupted

mangilimic

314215

update-manager crashed with SIGSEGV in PyErr_SetFromErrno()

mangilimic

315058

upgrade to intrepid: KDE shows white screen

mangilimic

315663

[apport] package update-manager-core failed to install/upgrade:

mangilimic

315694

package update-manager 1:0.87.30 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /tmp/tmpExfjCH/backports/usr/bin/dpkg returned an error code (1)

mangilimic

317535

[jaunty] update-manager doesn't honor "hold" flag for packages

mangilimic

318469

Update manager cant handle proxy authentication with dots in login name [8.10]

mangilimic

319146

When a release reaches End-of-Life, update manager should show EoL status and provide a link with working procedures and more information.

319372

message about the unavailabillity of the changes list is worded wrongly

mangilimic

320222

_cache->open() failed, please report.

mangilimic

320288

package update-manager 1:0.93.35 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1), E:Sub-process /usr/bin/dpkg returned an error code (1), E:Sub-process /usr/bin/dpkg returned an error code (1)

mangilimic

320630

upgrade from 7.1 to 8.04LTS

mangilimic

322076

package update-manager 1:0.93.35 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1), E:Sub-process /usr/bin/dpkg returned an error code (1), E:Sub-process /usr/bin/dpkg returned an error code (1)

mangilimic

322152

taskbar tab pulses unnecessarily

mangilimic

322389

package linux-image-2.6.27-11-generic 2.6.27-11.25 failed to install/upgrade: underprocess post-installation script gav felkod 1

mangilimic

322482

distribution upgrade via update-manager fails over remote GDM

mangilimic

322742

package update-manager 1:0.93.34 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): installArchives() failed

mangilimic

322821

error "could not calculate the upgrade"

mangilimic

322871

Download speed is not correctly displayed (wrong memory address for that variable ?)

mangilimic

323416

url/ubuntu/dists/hardy-security/main/binary not found on this server

323472

distribution upgrade failed to fetch ktimetracker_4.1.3-0ubuntu1~intrepid2_i386.deb

323493

distribution uprade

mangilimic

323602

package update-manager 1:0.97 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1)

323628

Adept manager cann't update

323668

Could not initialize the package information

324640

update-manager "crash" while updating

mangilimic

Incomplete Bugs

To mark it off the list you should:

  • Change the bug's status to "Confirmed" or "Triaged" if the reporter replied with enough information or

  • Ask a secondary follow up question and subscribe to the bug report

Bug

Subject

Triager

46817

ifrename package not purged

49851

Update manager doesn't show packages availible for update.

77528

"Size mismatch" error is unhelpful

89676

After installing all possible updates update-manager still shows amount of available updates

99066

There are a lot of updates, but "Download size" is 0

107000

update-manager should make sure that it is uptodate before a dist-upgrade even if edgy-updates is not available

108479

Distribution Upgrade (to Feisty) fails: coreutils can not be installed if there is a different install-info in PATH

144427

"Updates available" notification icon appears during OS upgrade

147429

Could not install 'debconf' during System upgrade 7.04 to 7.10

150677

Update Manager does not respect gtk-button-images setting

153880

Update manager hangs during install from Feisty to Gutsy

154000

kubuntu dist upgrade tool crashed

154590

Change group right during updrage to Gutsy

185116

kubuntu version upgrade failed "Can't install 'kubuntu-desktop'"

mangilimic

185122

update manager cannot update while auto-update is occuring

191004

Could not verify integreity of upgrader programme. This application will now exit. Feisty to Gutsy upgrade

mangilimic

205225

Upgrade from gutsy to hardy hangs

mangilimic

207743

Unicode character not correctly displayed

208545

re:ubuntu-8.04-beta-alternate-amd64. No upgrade dialog just the file manager showing the disc contents.

218051

Update Manager not updating last time checking repo

219531

cannot calculate upgrade

221388

reboot dialog steals focus on upgrade

221699

package update-manager 1:0.81.3 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): installArchives() failed

222055

[Hardy, Ubuntu-Studio] Upgrade crashes

225439

Upgrade from Kubuntu 7.10 to 8.04 removes hostname from /etc/hosts

225978

cannot upgrade to 8.04 from 7.1

mangilimic

227282

[hardy] Update Manager and Synaptic fail to install recommended updates without any explanation

227660

Fail to update

227762

do-release-upgrade logs a failed usermod near the end

mrkanister

233975

7.10 to 8.04 upgrade fails

239554

cdromupgrade

240724

Could not calculate upgrade-Can't mark 'kubuntu-desktop' for upgrade

251783

E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

mangilimic

257545

Upgrade problem

259430

/media/cdrom-1/cdromupgrade: line 32: 12909 Segmentation fault $TMPDIR/$COD ENAME --cdrom "$cddirname"

261471

update-manager crashed with GError in restore_state()

262676

package update-manager 1:0.87.30 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Couldn't configure pre-depend cups for cups-pdf, probably a dependency cycle.

267733

update-manager layout does not leave adequate room for package short descriptions

271045

update manager and synaptic crash

272472

package update-manager 1:0.87.24 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): installArchives() failed

276982

can't use update-manager

277700

lack of meaningful dialogue box on a simple space problem when upgrading

mangilimic

277817

Unable to install Intrepid beta (8.10) on a HP Pavillion Notebook

279884

Intrepid Ibex fails via update-manager

280662

Ubuntu 7.04 to 7.10 failed while installing packages

mangilimic

281142

problems updating database if harddisk is suddenly full during installation

282270

Upgrade Hash Sum mismatch

mangilimic

282748

Could not initialize the package information

283014

dpkg: warning unable to delete old directory `/usr/lib/python2.5/site-packages/DistUpgrade': Directory not empty

284178

update-manager crashes during update

284462

users should be added in the fuse group during a gutsy to hardy upgrade

284541

Update manager does not report the last update correctly

287105

update manager error ubuntu 8.04

287777

Update manager does not install updates

mangilimic

288746

update hoary to intrepid RC failed with dpkg locked

288885

menu.lst not updated with update to intrepid

289611

Hardy KDE 4 remix to Intrepid is incomplete

291563

8.10 update-manager error, ubuntu-minimal missing

292318

adept dist-upgrade crashed upgrading from 8.04 to 8.10

292352

dist upgrade fails on xubuntu HH to II

mangilimic

292746

update manager cannot find commercial/binary-amd64/Packages in Meta-index file

293342

[Hardy] update-manager can't install 'ubuntu-desktop'

293666

Update Manager crashes after selecting check for updates

295069

update manager error on upgrade

301318

intrepid upgrade 8.04 to 8.10 on KDE fails with following error

301767

Package always appears greyed out and partially cut off

mangilimic

301783

8.04 wouldn't let me upgrade through update-manager

mangilimic

303251

applet

303827

can't update from ubuntu 6.06 TLS to 8.04 TLS

306287

Offline upgrade from 8.04 to 8.10 fails (using kubuntu 8.10 alternate iso)

306902

crash when updating from gutsy to hardy (ppc)

309412

Upgrade problem

310223

upgrading feisty failed

310682

[jaunty] update-manager crashes with segfault

311603

Bad upgrade from 8.04 to 8.10

311805

can't upgrade from hardy to interpid with update-manager

312330

upgrade from 8.04 to 8.10 crashes

312580

update-manager crashed with ImportError in <module>()

312672

8.10 cdrom upgrade error-could not calc upgrade

313433

Distribution update to 8.04 message: no package named `x11-xkb-utils' is installed, cannot configure

mangilimic

313517

upgrade from kubuntu 8.04 to8.10 failed - network problem?

mangilimic

313531

Problem with Update-Manager

313875

'update-manager' unresolvable problem occurred while initializing the package information

314495

'update manager' frozen

314584

Could not download the upgrades

315085

update manager

315327

Update Failure

315712

>8.10 U-M complained/exited low disk; have 8GB!

316939

papercut fails on install of kubuntu 8.10

317080

subprocess post-removal script returned error exit status 2

317467

update manager doesn't download packages any more after upgrade to intrepid

317747

update-manager crashed

318387

java update cannot install (does it need acceptance of T&C?)

318793

Update manager crashes

319034

E: the package lists or status file could not be parsed or opened

319473

could not initialize the package information

319675

Can't update or install software... apt-get update doesn't work either

319862

E:The method driver /usr/lib/apt/methods/bzip2 could not be found.

320548

the package "cups" failde to upgrade

320851

update manager crashes

321002

error during upgrading

321251

Update manager won't start.

321463

update manager error processing dependencies

mangilimic

321792

update-manager very slow on asus eee box 202

324058

update-manager upgrade from up-to-date 6.06.2 LTS to 8.04.1 LTS fails

324169

update-manager

324629

An unresolvable problem occurred while initalizing the package information.

Confirmed Bugs

To mark it off the list you should:

  • Verify the bug is still not fixed
  • Request any needed info, Subscribe, Status to incomplete or
  • Set status to triaged UbuntuBugControl

Bug

Subject

Triager

19421

Humanized changelog and news after a dist-upgrade

33605

"Updates available" popup should hide when update-manager starts

33606

Should autodetect CD insertion

35876

'Downloading package information' and 'building dependency tree' progress dialogs request focus too often

36929

Add "IfInstalled: foo Install: bar" to DistUpgrade.cfg (was: Upgrade to dapper breaks mp3 playback)

40792

[Dist-upgrader] Window too big in 800x600

42798

update-manager improve: update repositories information

45129

update-manager should have per-package changelog locations (was: uses changelogs.ubuntu.com for all packages)

46758

[dist-upgrader] User should be prompted to update *before* the upgrade process starts

47648

could not calculate upgrade with old kernel package installed

49489

Fatal error on upgrade - NoSectionError Distro

50791

[dist-upgrader] When doing a dist-upgrade the upgrade tool should give the option to remove packages not being maintained in main any more

52158

Shows pinned packages as available to update

56297

Synaptic won't add Ubuntu CD to the repositories - freezes

61852

Failing to fetch some packages should display a better/nicer error message

65570

bogus pluralization of singular nouns

67090

On upgrading to Edgy from Dapper, confusing kernel selection

67338

Update waits indefinitely for user input (on terminal/debconf/conffile prompts)

67382

RFE: a bit more flexibility in handling modified files (conffile prompt)

68453

u-m GUI shows no feedback when mirrors are slow, timing out.

74899

crashed in saveDistUpgrade

77952

cancelling software update install causes a rescan and forgets my selection

81464

Update manager Instruction cannot be carried out

85644

Clickable URLs need context menu

86028

RFE: ask all config-file questions that the start or end of the upgrade

107188

[patch] Upgrade tool crashed with " Cannot allocate memory"

107766

system-config-printer adds menu item the same as gnome-cups-manager's menu item

107779

Upgrade Tool Crashed

108390

better mirror support

108568

CD-based upgrade from Edgy to Feisty fails on bad CD burns

108601

Update-manager needs help info when terminating on wrong repositories and generally deal better with incorrect sources.list data

108910

upgrade error from edgy server to feisty server becasue invoke-rc.d fails at "at"

109397

update-manager becomes unresponsive because it cannot download ReleaseAnnouncement (needs sensible timeout)

109765

run apt-get autoclean after upgrade

110388

X fails after Fiesty install on AMD64 w/ATI binary drivers

112272

ValueError: too many values to unpack (DistUpgradeControler.py stack trace)

114587

dapper to gutsy(+1): mozilla transition tweaks needed

116465

Update to feisty failed on 3 different computers

122197

Upgrade Manager failed from 6.10 to 7.04

127243

update-manager (and others) should lower their priority when working

128332

update manager is showing "updates available" but no update is available (because prefer version from Feisty)

133139

update-manager bug when loading Changes is slow

133325

Broken packages result in meaningless error message

137467

crash in a update-manager edgy->feisty

144773

update-manager crashed with AssertionError in saveDistUpgrade()

144920

Prerequisites download fails if gpg authentication fails on over-aggressive caches

145764

doesn't state why updates are necessary

146536

Could not calculate the upgrade

147742

[kde] kde-tempdir removes all -x bits and that breaks the custom invoke-rc.d that is used during the upgrade (was: upgrade fails because invoke-rc.d fails)

147758

upgrade from feisty to gutsy beta errors

147928

too many annoying interruptions during distribution upgrade

149203

If update-manager -d fails, you can't try again

150927

kubuntu adept_manager --version-upgrade to 7.10 has some confusing dialog messages.

151098

Cancelling download incorrectly results in error message

151242

Prompt temporary move /var/cache/apt to other partition for distribution upgrade

151943

says no update available in the middle of the upgrade to gutsy RC when preferences define a low priority for new release

152412

Download speed displayed as 'unknown' in update manager for the first seconds

152580

Upgrade to gutsy beta crashes because of insufficient disc space

153228

use monospace font in release notes window

153980

7.04->7.10 "Upgrade" fails: "Getting upgrade prerequisites failed"

153984

dist upgrade tool 7.10 gutsy freezes

154094

Transition from feisty-commercial to partner incorrect? (was: Error during update)

154272

Visual indication when final release comes out

156102

[kde] RuntimeError: underlying C/C++ object has been deleted (was: Upgrade tool crashed Kubuntu Feisty to Gutsy)

156320

[kde] copy XAUTHORITY may fail and crashes the upgrader (was: Upgrade tool crashed when upgrading 7.04 -> 7.10)

157907

Dist upgrade failed while running update-initramfs

159458

Error during update

160362

"Ubuntu has some information for you."

160805

pre-set PYTHONPATH breaks major upgrade

160861

DVD should be recognized as upgrade volume

162441

improve download cancel handling

162845

update-manager crashed with SIGSEGV in g_main_context_prepare()

164681

[wishlist] Update-manager should allow to ignore misc updates

165235

package libapache2-mod-php5 5.2.3-1ubuntu6 failed to install/upgrade:

172979

Partial french translation of dist upgrade time estimate

173050

update-manager does not correctly interpret gnome proxy configuration [gutsy]

173245

update-manager prevents users from seeing&recording errors

173277

Packages failed to install hardy

174024

update-manager shows wrong changelog

178905

update manager does not deal with packages in "reinstreq" state

180032

Update removes vital media codex.

186465

"distribution upgrade" hangs during update to hardy

187316

Server upgrade from 7.04 to 7.10 fails

189620

policykit integration missing

190782

[Patch] RGBA support in update-manager

193558

[Wishlist] Include limit-rate bandwidth option

195985

update-manager could not upgrade...."release-upgrader-dpkg" untrusted

196699

dist-upgrade crashes while upgrading from 7.04 to 7.10

199986

Shouldn't override the font in the terminal widget

200127

ubuntu incorrectly believes I enjoy staring at progress bars

203659

Pinned hardy repository causes update-manger to fail but shows no error message

209459

The package information was last updated 1 days ago

209718

bzr ppas block upgrade-manager partial upgrade

213805

BIOS beep occurs when clicking in lower half for the first time

215126

update-manager shouldn't use modal dialogs

216368

[kde] Distupgrade from Gutsy to Hardy (beta) fails

221285

Gutsy->Hardy Upgrade: "unresolvable problem occurred"

222024

Upgrade from 7.04 to 7.10 stops on 2nd step (Modifying the software channels)

222096

Many errors installing packages during upgrading to 8.04

223011

Partition not mounted after Gutsy to Hardy upgrade

223542

Release upgrade procedure "sucks" (from Gutsy to Hardy)

223826

[Dist Upgrade] Enhancement: user-friendly error reporting?

226254

IOError: [Errno 32] Broken pipe

226574

Failed to upgrade (7.10->8.04)

228247

Update-manager requires connectivity to changelog.ubuntu.com - mirrors alone aren't sufficient

228510

kubuntu - Upgrade Tool Crashed: CacheExceptionDpkgInterrupted

228928

update-manager gives fixed-size window for customised configuration diff

230043

Icons in Update Manager

231419

update-manager starts gnome-power-manager when it's not wanted

249335

update manager lines are unreadable

252068

interrupted upgrade should automatically resume

255443

update manager could warn of possible need to restart before installing

257114

release upgrade from dapper to hardy possibly due to network error

272131

Detect internet connection before trying to check for updates

272540

Notify user if a program is in use that has been removed from the repositories

277985

dapper to hardy: could not calculate the upgrade

278640

Kubuntu 8.04 amd64 upgrade to 8.10 fails. Upgrade tool exits without messages.

282426

update-manager crashed with SIGSEGV

283500

Synaptic, update-manager, and apt-get should share proxy settings

289009

Update manager says nothing about apt-listbugs prompt

289197

[Intrepid, hardy] security updates aren't enabled by default when installing without internet connection

291342

free disk space check could actually carry out suggested ways to clear space

312364

update-manager crashed with SIGSEGV in PyErr_SetFromErrnoWithFilenameObject()

316911

update-manager disables back button when managing conffiles

320685

intrepid->jaunty, openssl-blacklist got removed

xxxxx

Progress

update-manager-week-triaging.png

More Bugs

This list is just a nibble of the bigger picture.


CategoryBugSquad

UbuntuBugDay/20090205 (last edited 2009-02-12 18:52:54 by a89-182-211-204)