Lubuntu

New Features in Lubuntu 16.10

  • The switch to LXQt has been postponed until 17.04.

  • We now ship with Linux Kernel 4.8.
  • General bug fix release as we prepare for LXQt.
  • LXDE components have been updated.
  • The artwork has received an update.

Lubuntu Applications

System Requirements

Lubuntu is a good operating system for many old computers, but not for all of them. Some computers have too little horsepower or memory. A rule of thumb is that the computer should not be more than 10 years old.

Memory (RAM)

For advanced internet services like Google+, YouTube, Google Drive, and Facebook, your computer needs at least 1 GB of RAM.

For local programs like LibreOffice and simple browsing habits, your computer needs at least 512 MB of RAM.

Processor (CPU)

The minimum specification for CPU is Pentium 4 or Pentium M or AMD K8. Older processors are too slow and the AMD K7 has problems with Flash video.

Upgrade

Ubuntu Release notes

Known Problems

Common Infrastructure

For bugs affecting all flavors, please refer to the Ubuntu release notes.

Lubuntu Applications

This is our list of known bugs affecting applications that Lubuntu uses but relies on others to maintain.

  • gnumeric menu ->help ->about gnumeric -> license button, does not work. (1516454).

  • Software properties gtk implies my cpu is unknown and not working. (1444682).

  • Desktop file does not open ImageMagick from the menu (1550210).

  • gparted does not recognize the iso9660 file system in cloned Ubuntu USB boot drives (1622313).

  • sh: 1: /lib/libc.so.6: not found (1473142). (fix pending)

Lubuntu-specific Bugs

These are maintained by the Lubuntu team.

LXDE

  • run dialog called from one desktop opens on the desktop with preferences dialog, regardless of which desktop is current (1445818).

  • changing multiple desktop names only results in the first being changed. (1522625).

Lubuntu Installer

  • All images require a DVD or USB. As a workaround, use the server or netboot images.

  • Lubuntu 16.10 slideshow still incorrectly showing Lubuntu Software Center (1633148).

  • GTK warning about "The :insensitive pseudo-class is deprecated. Use :disabled instead." in Lubuntu 16.10 installer output (1633135).

Get Lubuntu

Head over here to get it.

Support

  • This release is supported for 9 months.
  • Contact us.

YakketyYak/ReleaseNotes/Lubuntu (last edited 2016-10-13 23:16:56 by tsimonq2)