TouchBluez5Testing

We're currently (as of 2015-09-07 09:10:11) working on upgrading the Bluetooth stack on the Ubuntu Touch devices to BlueZ 5. This requires various changes across the whole system and involves extensive testing. This page describes which steps are needed to setup one of the current development devices to get BlueZ 5.x running.

Currently only Nexus 4 (mako) and Nexus 7 (flo) are supported.

Requirements

  • Device flashed with latest rc-proposed (>= 240)

    • This will include a new kernel which has an update Bluetooth stack (based on linux 4.2) which is required to run BlueZ 5.x

Installation

NOTE: Silo 52 includes an updated lxc-android-config package which can't be installed the normal way. Please follow the instructions here.

Known problems

  • When switching between A2DP and HFP volume level isn't correctly switched and takes a bit to get correct.
  • Bluetooth indicator gets out-of-sync with actual bluetooth power state at times

Bluetooth/TouchBluez5Testing (last edited 2015-10-07 07:30:55 by morphis)