UnityWithFglrxBeta

Quick instructions for trying Unity with the new beta fglrx driver.

fglrx beta driver

The latest beta version of the driver has been uploaded in the Ubuntu archive:

fglrx:
  Installed: (none)
  Candidate: 2:8.840-0ubuntu1
  Version table:
     2:8.840-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ natty/restricted i386 Packages

Take this version or a more recent one. It contains a very important bug fix to get Unity and Compiz running in fully accelerated mode. Note: this recent version of the fglrx driver is still not presented in jockey.

Compiz

You will also need a recent version of Unity, like this new one in the daily build archive:

unity:
  Installed: 3.6.8-0ubuntu3+r1039+201103291647
  Candidate: 3.6.8-0ubuntu3+r1039+201103291647
  Version table:
 *** 3.6.8-0ubuntu3+r1039+201103291647 0
        500 http://ppa.launchpad.net/unity/daily/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status
     3.6.8-0ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ natty/main i386 Packages

Take the +r1039 or later. This version contains a workaround to let the fglrx run at full speed with Unity & Compiz.

For informations on the ppa and how to add it as a package source on your system, see https://launchpad.net/~unity/+archive/daily

DesktopExperienceTeam/UnityWithFglrxBeta (last edited 2011-03-30 13:38:04 by dbarth)