FreeMind

Installation (Gutsy Gibbon 7.10 & Hardy Heron 8.04)

Hardy repository

In Hardy (8.04) freemind is included in the repository. Install it like any other ubuntu application. Though, as of this writing, the ubuntu repository has version 0.7.1 and the eric.lavar.de repository has version 0.8.1.

Guided installation

See the Freemind wiki's Ubuntu section.

Terminal commands

Release

# Add repositories if they don't exist
grep "deb http://eric.lavar.de/comp/linux/debian/ unstable/" /etc/apt/sources.list >> /dev/null || echo "deb http://eric.lavar.de/comp/linux/debian/ unstable/" | sudo tee -a /etc/apt/sources.list >> /dev/null
grep "deb http://eric.lavar.de/comp/linux/debian/ ubuntu/" /etc/apt/sources.list >> /dev/null || echo "deb http://eric.lavar.de/comp/linux/debian/ ubuntu/" | sudo tee -a /etc/apt/sources.list >> /dev/null
sudo apt-get update
# Install the packages
sudo apt-get install sun-java5-jre freemind

Beta

# Add repositories if they don't exist
grep "deb http://eric.lavar.de/comp/linux/debian/ experimental/" /etc/apt/sources.list >> /dev/null || echo "deb http://eric.lavar.de/comp/linux/debian/ experimental/" | sudo tee -a /etc/apt/sources.list >> /dev/null
grep "deb http://eric.lavar.de/comp/linux/debian/ ubuntu/" /etc/apt/sources.list >> /dev/null || echo "deb http://eric.lavar.de/comp/linux/debian/ ubuntu/" | sudo tee -a /etc/apt/sources.list >> /dev/null
sudo apt-get update
# Install the packages
sudo apt-get install freemind

You also need to force eric lavar's libjibx-java to 1.0. Otherwise it will give an error saying the pattern file format has changed. You can do this by adding the following 3 lines to /etc/apt/preferences:

Package: libjibx-java
Pin: version 1.0.*
Pin-Priority: 1001

Note

The installation will warn that the freemind package can't be authenticated. In order to remove the harmless warning (and ensure authentication of the package) we need the gpg key for the repository. There is also a discussion for this on the freemind wiki.

Installation (Dapper Drake 6.06)

The easiest way to install FreeMind on Dapper is to grab the .deb files from the freemind.sourceforge.net (listed under Debian Linux). I used the file freemind_0.8.0-1_all.deb, and you'll also need to get libforms-java_1.0.5-2_all.deb. Simply download thefiles to your desktop, double-click on them (start with the libforms file) and follow the instructions. Finally you need to use Synaptic package manager to install libgcj7-awt - for some reason this doesn't get automatically installed.

As with earlier versions of Ubuntu, it's very important to use Sun's Java. See the RestrictedFormats wiki page for instructions on obtaining this.

FreeMind (last edited 2009-07-23 14:40:29 by johndoesacc)