HardwareSupportComponentsPrintersCanon

Tested

There is a PPA with Canon drivers: https://launchpad.net/~michael-gruz/+archive/canon
Read here how to use it:

Printers have been tested on a currently supported version of Ubuntu.

Make

Model

PPD/Driver

Supported

Works?

Ubuntu Version

Comments

Last Updated

Canon

i-SENSYS FAX-L120

-

No

No

9.10

Product Page

2010-Jan-13

Canon

i-Sensys LBP3010

CNCUPSLBP3050CAPTK.ppd

Yes

Yes

9.04 (Jaunty) , 9.10 (Karmic), 10.04 (Lucid), 10.10 (Maverick)

Using version 2.00 Drivers from Canon, Auto deteced but will not work without Canons drivers, Status monitor / cleaning working OK. https://help.ubuntu.com/community/HardwareSupportComponentsPrinters/CanonPrinters#preview

2010-Oct-11

Canon

LBP3100B

CNCUPSLBP3150CAPTK.ppd

Yes

Yes

10.04 (Lucid 32bit ONLY)

Using version 2.00 Drivers from Canon, Auto detected model will not work. Set-up following Canon Installation instructions works OK. Couldn't get it working at all for 64bit

2010-Dec-28

Canon

PIXMA iP1700

iP1900

No

Yes

v13.04 (Raring)

Works using the iP1900 drivers following this how-to: CanonPixmaIP1700

2013-Jul-06

Canon

imageCLASS MF4350d

No

No

v8.10 (Intrepid)

Printer wasn't recognized at all - didn't show up in Add Printer tool

2008-Nov-30

Canon

imageCLASS MF4370dn

Linux Printer Driver (UFR II) Ver.2.00E

Yes

Yes

v8.04 (Intrepid)

The current driver doesn't support all features. But you will be able to print via USB. How to install

2009-Jan-29

Canon

imageCLASS MF8050Cn

Linux Printer Driver (UFR II) Ver.2.00

Yes

Yes

v9.10 (Karmic)

The current driver doesn't support all features. But you will be able to print via the network. How to install

2010-Apr-07

Canon

imageRunner iR2xxx

Canon imageRunner_330s Foomatic/hpijs

No

Yes

v8.04.3 (Hardy)

2008-Apr-08

Canon

imageRunner iRC2620

Canon imageRunner_330s Foomatic/hpijs

No

Yes

v8.04.3 (Hardy)

Only prints in black and white so far...

2008-Jun-06

Canon

imageRunner iRC3380

Canon UFR II/UFR II LT

No

Yes

v8.04.3 (Hardy)

Install the official Canon DEBs (they contain source code too) http://files.canon-europe.com/files/soft31040/software/g8b5enx.zip , install the printer, use "sudo cngplp" to configure default properties, and then set Job Accounting ID/Password for current user "cnjatool -p [Printer Name]"

2009-Jun-30

Canon

imageRunner iRC3580i

CNCUPSIRC3580SK.ppd

No

Yes

v8.04.3 (Hardy)

Default (foomatic) driver does not work. Get (free) drivers from www.canon.com.au, install the .deb packages, and select "Canon iR C3080/3480/3580 PS3 ver.1.8" as the "Make and Model". I used lpd://(printer's IP) in the URI field

2009-Jan-21

Canon

LBP-1120

CNCUPSLBP1120CAPTK.ppd

No

Yes

v9.10 (Karmic)

Works with v1.90 drivers from Canon. The instructions are the same as those for Canon CAPT printer driver v. 1.90

2010-Mar-21

Canon

LBP-6200d

CNCUPSLBP6200CAPTK.ppd

Yes

Yes

13.04 (32&64bit)

Works with v2.60 drivers from Canon. Do not turn on the printer until after installation. 32bit: Follow the readme of the printer driver. Change localhost to 59787. 64bit: Follow readme of the canon printer driver. Change localhost to 59787. Install libglade2-0 ia32-libs libpopt0:i386 from repository. (Standard Raring ia32-libs works.) (32&64bit) Add sudo /etc/init.d/ccpd start and if you want the capt Statusmonitor started sh -c "sleep 30; /usr/bin/captstatusui -P LBP6200 -e" for each user to gnome-session-properties. Allow each user to start ccpd as root. Therefore add to /etc/sudoers following line for each user: (username) ALL=NOPASSWD: /etc/init.d/ccpd start

2013-Oct-26

Canon

LBP-2900

CNCUPSLBP2900CAPTK.ppd

No

Yes

v9.10 (Dapper)

Works with v1.90 drivers from Canon. The instructions are the same as those for Canon CAPT printer driver v. 1.90

2010-Mar-21

Canon

MP210

Official driver in any version prior to Karmic. In v9.10 (Karmic) MP160 driver.

No

Yes

v8.04.3 (Hardy) / v10.04 (Lucid)

Krmic works properly with official drivers: http://software.canon-europe.com/products/0010485.asp Version 9.10 "Karmic" and later work perfectly with MP160 driver.

2010-May-17

Canon

PIXMA iP3500

canonip3500.ppd

Yes

Yes

v8.04.3 (Hardy)

Works with Canon supplied drivers available at http://support-au.canon.com.au/EN/search?v%3Aproject=ABS-EN&binning-state=model%3D%3DPIXMA%20iP3500%0Amenu%3D%3DDownload%0Aos%3D%3DLinux&

2009-Jan-27

Canon

PIXMA iP2600

ip2600

No

Yes

v9.10

Works with Canon supplied drivers available at http://www.canon.com/

2009-Feb-22

Canon

PIXMA iP5200R

gutenprint

No

Yes

v9.04 (Jaunty) 64-bit

Works over local network using LDP/LPR or AppSocket, with correct ip and selecting the PIXMA ip5200 driver, make sure the cups-driver-gutenprint package is installed first. Dual-sided printing works. No ink level info.

2009-Aug-12

Canon

PIXMA MP190

Canon MP190

Yes

Yes

v9.10

Detected and downloaded MP180 drivers. Print and scan work well.

2010-Mar-05

Canon

PIXMA MP960

Canon PIXMA iP6700

Yes

Yes

v8.10 (Intrepid)

Detected correctly as Canon MP960. You have to fool the computer into thinking it is a PIXMA iP6700. The iP6700 and the MP960 use the same kind of ink cartridges, but the MP960 has a seventh one (PGI-5BK Pigment Black) used for text purpose only. I believe this last cartridge is not used by the driver at all. Printing quality is very good for text. Pictures look a little bit washed out, but you can improve this if you change the default settings offered (brightness, contrast, saturation). Resolution locked to 600x600 DPI (this is a printer with a resolution of 9600 x 2400 DPI).

2008-Nov-09

Canon

PIXMA MP160

Canon PIXMA MP160 - CUPS+Gutenprint v5.2.3

Yes

Yes

v9.04 (Jaunty)

Canon USB all-in-one printer/scanner. Printer recognized and proper driver loaded on Ubuntu install. XSane scanning also fully functional.

2009-Jul-26

Canon

PIXMA MP250

Canon MP250 series Ver.3.40[en]

Yes

Yes

v10.10 (Maverick)

Canon USB all-in-one printer/scanner. Printer not recognized on Ubuntu install. Guide to install Canon driver here: http://ubuntica.com/pixma-mp250-on-ubuntu.html. Link to driver in guide is dead; new link: http://support-sg.canon-asia.com/contents/SG/EN/0100236101.html Scanner is also working with Simple Scanning without any work.

2011-May-19

Canon

MP530

BJC-7000

No

Yes

v9.10 (Karmic)

Printer works if you assign the BJC-7000 Gimp driver to it using the add printer wizard. Scanning works fine as well. I have had issues with paper drawing from the lower cassette. This is true of the MP500 driver as well. Sometimes it works and others it doesn't. Using the manual feed door, it seems to do everything fine.

2010-Jan-24

Canon

MP630

cnijfilter?

No

Yes

v9.10 (Karmic) & v10.04 (Lucid)

Printing and scanning works with the following: You need to install the dummy package libcupsys2 for new version support and download the drivers from Canon. Further instructions at Linux Foundation Forums.

2010-May-08

Canon

MP640

cnijfilter?

No

Yes

v9.10 (Karmic)

Wireless printing works with the MP640 debian driver supplied by Canon. XSANE does not recognize the scanner until the Canon MP640 scanner driver was installed. Afterwards I found this sane-backend installation tutorial and the good news is this model is fully supported.

2010-July-21

Canon

i560

CUPS+Gutenprint v5.2.5

?

Yes

v10.4 (Lucid)

auto detected, 300px and 600px, many printer adjustments available, but no ink level or head cleaning. Proprietary driver at mambo kyoto apparently no longer available. Tested only on USB.

2010-Nov-26

Canon

PIXMA iP3600

canonip3600.ppd

No

Yes

v10.4 (Lucid)

Works with Canon supplied drivers following http://ubuntuforums.org/showthread.php?t=1427098

2010-Dec-14

Canon

PIXMA iP4600

canonip4600.ppd

No

Yes

v10.4 (Lucid)

Works ok

2010-Dec-27

Canon

SELPHY CP800

Canon SELPHY CP525

Yes

Yes

v11.10 (Oneiric)

Detected correctly as CP800. Drivers exist in the DB but don't work (paper prepares for print, but then printer hangs). Use CP525 drivers instead and then it'll be fine and works 100%.

2012-Jan-21

Needs Retesting

The following printers were tested on Ubuntu versions that have since reached EOL*. They need tested on a currently supported version of Ubuntu. Please test and move the results to the table above.

Make

Model

PPD/Driver

Supported

Works?

Ubuntu Version

Comments

Last Updated

Canon

i450

i560

No

Yes

v7.04 (Feisty)

Detect as i450 but no driver. Work if select i560.

?

Canon

BJC-2000

bjc600

Yes

Yes

v4.10 (Warty)

Detected during installation

2004-Dec-14

Canon

BJC-2100

bjc600

No

Yes

?

Detected during installation, both LP and USB work

?

Canon

i455 USB

gimp-print

No

Yes

v5.10 (Breezy)

Not detected, but works when you select BJC 7000 printer and gimp-print driver

2005-Oct-30

Canon

i550 USB

s800

No

Yes

v7.10 (Gutsy)

Properly detected as i550, works after manually selecting printer model s800 in driver tab of printer properties window.

2007-Oct-21

Canon

i850 USB

bjc-7004

No

Yes

v5.10 (Breezy)

Not detected during installation, no borderless and low photo quality with open driver - works flawlessly with www.turboprint.de non-free

2006-Mar-05

Canon

i860 USB

N/A

No

Yes

v4.10 (Warty)

Can't find open driver that will work correctly with this printer. Even tried this: http://www.teaser.fr/~amajorel/howto/CANON-I850-CUPS - works flawlessly with www.turboprint.de non-free

2005-Feb-20

Canon

LBP-460

?

?

?

?

Unknown, but have a look at http://www.boichat.ch/nicolas/lbp660/ for "Linux Driver" for LBP 460 - please let me know if it works! contact richard@LPAgroup.biz

?

Canon

LBP-1210

CNCUPSLBP1210CAPTK.ppd

No

USB Only

v6.06 (Dapper)

No drivers for the LBP-1210 seem to support the parallel port interface. Printer works via USB with manual installation (see Canon_LBP_2900_HowTo). I have not tested the Open Source driver for 1120, but author claims it also only works with USB

2006-Dec-18

Canon

LBP5200

-

No

No

v7.04 (Feisty)

Not detected and not working

2007-Apr-26

Canon

LBP5200

-

No

No

v6.06 (Dapper)

Detectet but not working

2007-Oct-15

Canon

MP360

MultiPASS C5500 bjc600 Driver

No

Yes

v5.10 (Breezy)

Printer works using the MultiPASS C5500 bjc600 driver, not tested scanning as yet

2006-Apr-17

Canon

MP390

MultiPASS MP150 Gutenprint CUPS driver

No

Yes

v7.04 (Feisty)

Printer works perfectly if you assign the Gutenprint CUPS driver to it using the add printer wizard (Choose model MultiPASS MP150). Scanning doesn't work.

2007-Jun-23

Canon

PIXMA iP1000

CUPS Driver

No

Yes

v7.10 (Gutsy)

You'll find detailed instructions in this site http://mambo.kuhp.kyoto-u.ac.jp/~takushi/#canon Thanks to Takushi Miyoshi for building this and other drivers for Canon printers. UPDATE: Unfortunately, these drivers no longer work in Ubuntu 9.10 (Karmic). They are broken.

2008-Apr-05

Canon

PIXMA ip1500

-

No

Yes

v7.04 (Feisty)

Following this howto CanonPixmaIP1500

2007-May-12

Canon

PIXMA iP1600

Pixma iP2200

No

Yes

v7.04 (Feisty)

Works with Canon supplied drivers following this howto: CanonPixmaIP2200. HowTo in French

2006-Nov-21

Canon

PIXMA iP2000

bjc800

No

Yes

v5.10 (Breezy)

Just select "BJC 7100" (driver bjc800) at the installation.

2006-May-09

Canon

PIXMA iP2000

PIXMA iP2000

Yes

Yes

v7.04 (Feisty)

The dialog box suggests model i560, choose the working PIXMA iP2000 model instead.

2006-May-09

Canon

PIXMA iP2200

Pixma iP2200

No

Yes

v7.04 (Feisty)

Works with Canon supplied drivers following this howto: CanonPixmaIP2200

2006-Nov-21

Canon

PIXMA iP3000

Pixma iP3000

No

Yes

v5.10 (Breezy)

32bits drivers for this printer available at ftp://download.canon.jp/pub/driver/bj/linux/. No drivers for AMD64 architecture.

2006-Apr-12

Canon

PIXMA iP4000

Pixma iP4000

No

Yes

v5.10 (Breezy)

32 bits drivers for this printer available at ftp://download.canon.jp/pub/driver/bj/linux/. Gimp-Print Canon BJC 8200 drivers also work but only at low resolution. These drivers also work for sharing with Mac OS X over IPP. Same low-resolution limitation exists.

2006-Apr-12

Canon

PIXMA iP4200

Pixma iP4200

No

Mostly

v6.10 (Edgy)

Works with Canon supplied drivers following this howto: CanonPixmaIP4200

2006-Jun-27

Canon

PIXMA iP4300

Pixma iP4200

No

Mostly

v6.10 (Edgy)

Works with Canon supplied drivers following this howto: CanonPixmaIP4200

2007-Jan-28

Canon

PIXMA iP5200

Pixma iP5200

No

Mostly

v6.10 (Edgy)

Works with Canon supplied drivers for the IP4200 following this howto: CanonPixmaIP4200

2007-Jan-4

Canon

PIXMA MP170

MP150

No

Yes

v7.04 (Fiesty)

Properly detected on scan. Suggested BJC600 tried Pixma MP150 and selected HQI (Gutenprint). Works well. Scanner works also.

2007-Nov-11

Canon

S200

bjc-s200

No

Yes

v4.10 (Warty)

Needs cupsys-driver-gimpprint from universe repository

2004-Oct-21

Canon

S300

S800.ppd

No

Yes

v5.10 (Breezy)

Use the driver for the S800 model and be sure to change the res to 600x600.

2005-Nov-04

Canon

S400

bjc6000a1?

Yes

Yes

v6.06 (Dapper)

works flawlessly, auto detected

2006-Oct-16

Canon

S450

bjc6000a1

Yes

Yes

v5.10 (Breezy)

works flawlessly, auto detected

2005-Dec-10

Canon

S500

-

No

Yes

v5.10 (Breezy)

works flawlessly with www.turboprint.de non-free drivers

2005-Nov-24

Canon

S520

-

No

Yes

v5.04 (Hoary)

works flawlessly with www.turboprint.de non-free drivers

2005-Sep-21

Canon

PIXMA MP600

High Quality Image (Gutenprint CUPS)

No

Somewhat

v7.04 (Feisty)

Detected correctly as Canon MP600. Will get stuck on "Printing..." if you don't fool the computer into thinking it's a PIXMA iP4200. Pictures are washed out.

2007-Aug-20

Canon

PIXMA MP960

High Quality Image (Gutenprint CUPS)

Yes

Partial

v7.04 Feisty

Detected correctly as Canon MP960. Printing quality is unacceptable and sometimes a real mess. Under "Printer Properties" to choose "PIXMA IP6700" and the "Gutenberg CUPS" driver. More info at the OpenPrinting's Forums ---> http://forums.openprinting.org/

2007-Jul-17

Canon

PIXMA MP960

Canon PIXMA iP6700

Yes

Yes

v7.10 (Gutsy)

Detected correctly as Canon MP960. You have to fool the computer into thinking it's a PIXMA iP6700. Printing quality is OK for text. Pictures look a little bit washed out, but you can improve this if you change the default settings offered (brightness, contrast, saturation). Resolution locked to 600x600 DPI

2007-Oct-21

Canon

PIXMA iP8500

canonpixusip8600.ppd

Yes

Mostly

v6.06 (Dapper)

Works with Canon supplied drivers following http://www.ubuntuforums.org/showthread.php?t=38995

2006-Dec-11

* v6.06 LTS Desktop has reached EOL, v6.06 LTS Server has not as of this writing.


Note Most recent Linux drivers can be found here: http://support-asia.canon-asia.com/


CategoryHardware CategoryHardware

HardwareSupportComponentsPrintersCanon (last edited 2013-10-26 16:10:40 by bj7u6139zdyf2a6nz2ly74oec10f2lnela24rsgd389d0elot5a7jz6hawymvsdk-info-jjcftv6wldnzq84cskygyvhqqb9qwjfcq0yfnwzcca0ux8ircw2a3om624q2ycdp)