HardwareSupportComponentsVideoCardsNvidia

Summary

Make

Model

Chipset/Driver

Auto-detected?

2D

3D

Ubuntu Version

Comments

Last Updated

nVidia

EN8400 series

Yes

Yes

Yes

nVidia

EN8400GS Silent 512MB PCIe

nVidia

Yes

Yes

Yes

8.04.2 32bits (Hardy)

Enable the restricted driver and reboot.

2009-May-22

nVidia

GeForce1 series

Yes

Yes

Yes

3D requires nvidia-glx-legacy, see BinaryDriverHowto.

nVidia

GeForce2 series

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce2 4200

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce3 series

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce4 series

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce4 440 Go MX 440 8x AGP

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce4 440 Go Ti 4200

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce4 440 Go Ti 4600

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce4 NV25 AGP4x Ti4200

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce4 Ti 4200 Go

Yes

Yes

Yes

v5.10 (Breezy)

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce 4 Ti 4800 SE

Yes

Yes

Yes

8.04 (Hardy)

3D requires nvidia-glx, see BinaryDriverHowto.

2008-04-17

nVidia

GeForce FX series

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce FX 5200

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce FX 5200 Go

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce FX 5500

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce FX 5600

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce FX 5700

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce FX 5700 PRO

Yes

Yes

?

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce FX 5900

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce 6 Series

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce 6150 128Mb

Yes

Yes

Yes

7.10 (Gutsy)

3D requires nvidia-glx, see BinaryDriverHowto.

2008-02-03

nVidia

GeForce 6200 256Mb

Yes

Yes

Yes

v8.10 (Intrepid) v9.04 (Jaunty) v9.10 (Karmic)

3D requires nvidia-glx, see BinaryDriverHowto.

2010-Feb-24

nVidia

GeForce 6200 TurboCache(TM)

Yes

Yes

Yes

8.04 & 8.10 & 9.04

3D requires nvidia-glx, see BinaryDriverHowto.

16.06.2009

nVidia

GeForce 6600GT 128Mb PCIe

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce 6600TD 256MB PCIe

nv & nvidia

Yes

Yes

Yes

6.06, 6.10

3D requires nvidia-glx, see BinaryDriverHowto.

2007-01-08

nVidia

GeForce A6600GT 128Mb AGP

nv & nvidia

Yes

Yes

Yes

6.06 - 8.04

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce 6800LE 128Mb

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce 6 Integrated Series

Yes

yes

Yes

v6.06 (Dapper)

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce 7200GS

Yes

Yes

Yes

v7.04 (Feisty Fawn)

3D requires nvidia-glx, use restricted-manager.

2007-08-11

nVidia

GeForce 7300GS

Yes

Yes

No

v6.06 (Dapper)

The Xorg nv driver makes the screen looks weird. Need nvidia-glx to correct this and enables 3D. See BinaryDriverHowto.

nVidia

GeForce 7300GT

Yes

Yes

Yes

v6.10 (Edgy)

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce 7300SE

Yes

Yes

Yes

v8.04 (Hardy)

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce 7600GS

Yes

Yes

Yes

v6.06 (Dapper) or higher

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce 7800GT

Yes

Yes

Yes

v6.06 (Dapper)

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce 7900GTX

Yes

Yes

Yes

v6.06 (Dapper) v6.10 (Edgy) v7.04 (Feisty Fawn) 8.04 (Hardy)

3D requires nvidia-glx new, see BinaryDriverHowto.

nVidia

GeForce 7950GX2

Yes

Yes

Yes

v6.10 (Edgy)

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

GeForce 8600GT 512MB 128-bit GDDR3 PCI Express x16 HDCP Ready SLI Supported

nVidia

Yes

Yes

Yes

v7.10 (Gutsy)

3D requires nVidia driver, see BinaryDriverHowto or follow these instructions.

2008-01-22

nVidia

NV5 RIVA TNT2/TNT2 PRO

Yes

Yes

Yes

v5.10 (Breezy)

3D requires nvidia-glx-legacy + kernel-module, see BinaryDriverHowto.

nVidia

Quadro FX 560

nv & nvidia

Yes

Yes

Yes

6.10 (Edgy)

3D requires nvidia-glx and binary drivers

nVidia

Quadro 140 M

Yes

Yes

Yes

8.04 (Hardy)

You need the restricted driver manager to enable 3d

2008-04-27

nVidia

Geforce 8400 GS

nvidia

Yes

Yes

Yes

9.04 (Jaunty)

3D requires nvidia-glx, see BinaryDriverHowto.

08-02-10

nVidia

Geforce 8400 GT

nvidia

Yes

Yes

Yes

10.10 (Maverick)

3D requires nvidia-glx, see BinaryDriverHowto.

10-10-10

nVidia

Geforce 8800 GT

yes

Yes

Yes

8.04, 8.10

out-of-the-box. 8.10 live cd and dvd x32 and x64 starts with compiz enabled

2008-apr-25, 2008-nov-30

nVidia

Geforce 9600 GSO

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

Geforce 9600 GT

Yes

Yes

Yes

3D requires nvidia-glx, see BinaryDriverHowto.

nVidia

Geforce 9800 GX2

nvidia

Yes

Yes

Yes

8.04 (Hardy)

3D requires nvidia-glx, see BinaryDriverHowto.

08-09-23

nVidia

Geforce 9800 GT

nvidia

Yes

Yes

Yes

8.10

Will hang loading "nvdia" using 177.82 drivers as Jan-2-2009,Worked for 177.82 drivers as Mar-07-2009

2009-Mar-07

nVidia

Geforce 9800 GT

nvidia

Yes

Yes

Yes

9.04

3D requires nvidia-glx, see BinaryDriverHowto. (Works with version 180.44)

2009-Aug-28

nVidia

GeForce GTS 250

nvidia

N/A

Yes

No

9.10

Newly supported, no additional information.

2009-Dec-16

nVidia

GeForce GTS 250

nv

No

No

No

8.04.2

The nv driver is never loaded

2009-Mar-26

nVidia

GeForce GTS 250

nv, nvidia

Yes

Yes

Yes

8.10

3D requires nvidia-glx, see BinaryDriverHowto.

2009-Mar-21

nVidia

GeForce GTS 250

nv, nvidia

Yes

Yes

Yes

9.04

3D requires nvidia-glx, see BinaryDriverHowto.

2009-May-03

nVidia

GeForce Go 6600

-

Yes

Yes

Yes

9.04

3D requires nvidia-glx, see BinaryDriverHowto.

2009-Sept-26

HardwareSupportComponentsVideoCardsNvidia (last edited 2010-10-09 14:44:08 by thorsten-full)