es


Contents

  1. Requisitos del sistema
  2. Instalación
    1. Posibilidad de que el disco duro no se muestre cuando se instala el sistema en modo Live CD
    2. La opción «Sólo software libre» instala software restringido
    3. Comienzo lento del paso «Seleccionar e instalar software» del instalador en modo texto
    4. oem-config falla con algunos idiomas
    5. Las imágenes MID necesitan una conexión a la red para instalarse correctamente
    6. Los paquetes recomendados se instalan de forma predeterminada
    7. Limitación de contraseñas con ecryptfs
  3. Actualización
    1. Soporte de antiguas («legacy») tarjetas nVidia
    2. Soporte de vídeo «fglrx» de ATI
    3. Dispositivos de entrada X.Org
    4. Incompatibilidad entre evdev y xmodmap en X.Org
    5. Soporte para núcleo de tiempo real en UbuntuStudio
    6. Soporte para teclas rápidas en portátiles Toshiba
    7. Fallos de arranque en sistemas con placas base Intel D945
    8. Kubuntu KDE4 remix
    9. No se puede iniciar sesión tras la actualización desde Kubuntu 8.04 KDE 4 Remix
    10. encfs ya no soporta el cifrado ssl/blowfish-v0.2 versión 2:0:1
    11. Problemas de actualización en PlayStation 3
  4. Otros problemas conocidos
    1. Bloqueos del sistema con chipsets inalámbricos Intel 4965
    2. No se puede reactivar el dispositivo inalámbrico Intel 3945/4965 si se arranca con el interruptor apagado
    3. El controlador inalámbrico ath5k de Atheros no está habilitado de forma predeterminada
    4. Orden de arranque en iSCSI
    5. No se pueden montar varios targets iSCSI al mismo tiempo
    6. El adaptador inalámbrico no funciona con el controlador ath_pci tras una suspensión
    7. Los sistemas instalados desde imágenes diarias no publicadas pueden causar pérdidas de archivos
    8. Soporte de Bluetooth en Kubuntu
    9. KNetworkManager no soporta conexiones con IPs estáticas
    10. Usar usb-creator con imágenes 8.04.1 (Hardy)
    11. En los adaptadores Intel 3945 sólo están habilitados los canales inalámbricos estadounidenses de forma predeterminada
    12. Base de datos Cyrus SASL creada con permisos incorrectos
    13. Acceso al entorno de ejecución de Java
    14. Problemas con la expulsión de CDs
    15. Salvar y restaurar la sesión no funciona, y las aplicaciones no pueden guardarse automáticamente al finalizar la sesión
    16. Bloqueo del sistema con efectos de escritorio en tarjetas gráficas Intel 830MG y 845G

Estas notas de publicación documentan problemas ya conocidos de Ubuntu 8.10 y sus variantes.

Requisitos del sistema

La cantidad mínima de memoria necesaria para Ubuntu 8.10 es 256 MiB de RAM. (Tenga en cuenta que su tarjeta gráfica puede usar parte de la memoria de su sistema, y que por tanto no toda estaría disponible.)

Cuando sólo se dispone de la cantidad mínima de memoria, el proceso de instalación tarda más de lo normal, pero se completa satisfactoriamente y el sistema funciona de forma adecuada una vez instalado. Los sistemas con poca memoria podrán usar el desktop CD para instalar Ubuntu 8.10 seleccionando «Instalar Ubuntu» en el menú de arranque para ejecutar únicamente el instalador, en lugar de iniciar el escritorio completo seleccionando «Probar Ubuntu sin alterar su equipo».

Instalación

Posibilidad de que el disco duro no se muestre cuando se instala el sistema en modo Live CD

Si un usuario explora un disco duro en modo Live CD antes de llevar a cabo la instalación, Ubiquity no podrá instalar el sistema en ese disco porque un disco no se puede particionar si tiene particiones montadas (ocupadas). Para instalar el sistema sobre un disco montado, primero deberá desmontar la unidad antes de proceder a la instalación.

La opción «Sólo software libre» instala software restringido

La opción «Sólo software libre», disponible al pulsar F6 dos veces en la primera pantalla del desktop CD/DVD, instalará el paquete restringido linux-restricted-modules-2.6.27-7-generic. Esto se puede corregir temporalmente desinstalando el paquete linux-restricted-modules-2.6.27-7-generic cuando finalice la instalación.

Observe que la opción «Sólo software libre» no instala ningún otro software restringido.

Para más información, consulte el bug 290925.

Comienzo lento del paso «Seleccionar e instalar software» del instalador en modo texto

El paso «Seleccionar e instalar software» del CD de instalación en modo texto puede parecer que se queda bloqueado cuando ha alcanzado menos del 10% del progreso. Esto se da particularmente en el caso de instalaciones en red, donde la barra de progreso no se actualiza en absoluto mientras se están descargando paquetes. Esto se debe a un fallo de interacción entre el instalador y apt-get que fue diagnosticado demasiado tarde para ser corregido antes de la salida de Ubuntu 8.10: bug 290234.

Puede comprobar si el instalador continúa su progreso pulsando Alt-F4 para pasar a la consola de registro; Alt-F1 le devuelve de vuelta al instalador principal. (Si está instalando en QEMU o KVM, asegúrese de pulsar Ctrl+Alt o pulsar con el ratón en la ventana para que el emulador capture el foco antes de pulsar Alt-F4; si no lo hace, provocará que el emulador se cierre.)

oem-config falla con algunos idiomas

La herramienta de configuración OEM para el usuario final no funciona correctamente si se selecciona un idioma que no use los conjuntos de caracteres ASCII o ISO-8859-1, por lo que el usuario final acabará teniendo una localización incorrecta al seleccionar uno de esos idiomas (bug 290580). La lista de idiomas bien conocidos es la siguiente: vasco, catalán, danés, holandés, inglés, finlandés, francés, gallego, alemán, indonesio, italiano, sami del norte, bokmål noruego, nynorsk noruego, portugués, portugués de Brasil, español, sueco y tagalog.

Mientras tanto, los OEMs afectados por este problema pueden aplicar este parche (la parte de scripts/tzsetup) al archivo /usr/lib/oem-config/timezone/tzsetup antes de ejecutar el paso de «Preparar para entregar al usuario final». Esperamos publicar una actualización en el momento oportuno, que se podrá instalar mediante el sistema de paquetes normal en ese mismo paso.

Las imágenes MID necesitan una conexión a la red para instalarse correctamente

Cuando se intenta instalar una imagen de Ubuntu MID (Mobile Internet Device) sin conexión a la red, el instalador muestra una ventana en un bucle infinito cerca del final de la instalación, mientras se busca el repositorio. La única forma de romper este bucle es conectarse a la red (bug 288320).

Los paquetes recomendados se instalan de forma predeterminada

En concordancia con el Manual de directivas de Debian (que dice «El campo 'Recommends' debe enumerar los paquetes que deberían ir junto con este en todas las instalaciones menos en las poco usuales»), el sistema de gestión de paquetes ahora instala de forma predeterminada los paquetes que se enumeran en el campo Recommends: de otros paquetes instalados, además de los indicados en Depends:. Si desea evitar este comportamiento con paquetes específicos, use apt-get --no-install-recommends; si desea hacerlo permanente, establezca APT::Install-Recommends "false"; en /etc/apt/apt.conf. Tenga en cuenta que esto puede provocar pérdida de características en algunos programas.

Limitación de contraseñas con ecryptfs

Los usuarios que instalen la versión Alternate o Server y que seleccionen una contraseña que contenga un «%» o un «-» obtendrán un directorio cifrado ~/Private que no se montará durante el arranque ni en posteriores inicios de sesión. Para corregir esto, los usuarios afectados necesitarán hacer lo siguiente en el sistema recién instalado:

  1. Actualice el paquete ecryptfs-utils a una versión igual o posterior a la 53-1ubuntu12 (tan pronto como esté disponible como actualización)
  2. Ejecute: $ ecryptfs-setup-private --force

Para más información sobre el fallo y una aproximación a la solución, consulte el bug #290445.

Actualización

Los usuarios de Ubuntu 8.04 LTS pueden actualizarse a Ubuntu 8.10 mediante un proceso automático adecuado. Los usuarios de otras versiones de Ubuntu deberán actualizarse primero a Ubuntu 8.04 LTS y después a la 8.10. Podrá encontrar las instrucciones completas en http://www.ubuntu.com/getubuntu/upgrading.

Soporte de antiguas («legacy») tarjetas nVidia

Las series 71 y 96 de los controladores privativos de nVidia, proporcionadas por los paquetes nvidia-glx-legacy y nvidia-glx en Ubuntu 8.04 LTS, no son compatibles con el X.Org incluido en Ubuntu 8.10. Los usuarios afectados son los poseedores de chipsets gráficos nVidia TNT, TNT2, TNT Ultra, GeForce, GeForce2, GeForce3 y GeForce4, y para ellos se migrará al controlador libre nv al actualizarse. Este controlador no permite aceleración 3D.

Los usuarios de otros chipsets de nVidia soportados por las series 173 o 177 del controlador se migrarán a los paquetes nvidia-glx-173 o nvidia-glx-177. Sin embargo, al contrario de lo que ocurre con los controladores 96 y 71, los controladores 173 y 177 sólo son compatibles con CPUs que soporten SSE (p.ej. Intel Pentium III, AMD Athlon XP o superiores). Los sistemas que dispongan de CPUs más antiguas también se migrarán al controlador nv durante la actualización.

Soporte de vídeo «fglrx» de ATI

El controlador de vídeo ATI en 8.10 no dispone de soporte para las tarjetas gráficas con chips basados en r300 (las tarjetas de las series Radeon 9500 - X600). Si tiene una de esas tarjetas, por favor, use «Controladores de hardware» en Sistema->Administración para deshabilitarlo antes de la actualización.

Consulte el bug 284408 para más información.

Dispositivos de entrada X.Org

El archivo de configuración de X.Org (/etc/X11/xorg.conf) aún contiene entradas InputDevice para el ratón y el teclado, pero a partir de ahora se ignoran debido a que ahora se usa input-hotplug. Las opciones del teclado ahora provienen de /etc/default/console-setup; para cambiarlas, por favor, use sudo dpkg-reconfigure console-setup. A continuación, reinicie HAL y X (p.ej. reiniciando su sistema).

Incompatibilidad entre evdev y xmodmap en X.Org

Los códigos de teclas para X generados con el nuevo controlador de entrada evdev en X.Org 1.5 no son compatibles con los generados en Ubuntu 8.04 LTS y anteriores. Si ha configurado combinaciones de teclas para su usuario en un archivo ~/.Xmodmap, necesitará convertirlas o desactivarlas a mano en la actualización.

Soporte para núcleo de tiempo real en UbuntuStudio

La variante de tiempo real para el núcleo incluido en Ubuntu 8.10 no incluye soporte SMP. A los usuarios de UbuntuStudio 8.04 que necesiten soporte de tiempo real con procesadores de doble núcleo, o con doble procesador u otras configuraciones SMP más complejas, se les recomienda no actualizarse a UbuntuStudio 8.10 en este momento.

Soporte para teclas rápidas en portátiles Toshiba

El controlador tlsup del núcleo incluido en Linux 2.6.27 para el soporte de portátiles Toshiba no es compatible con el modelo de eventos de X.Org 1.5, lo que provoca que las teclas rápidas de esos portátiles no funcionen con Ubuntu 8.10. Esto se arreglará en una actualización del núcleo posterior a la publicación de la versión final para volver a introducir el controlador toshiba_acpi.

Fallos de arranque en sistemas con placas base Intel D945

Algunos usuarios han informado que la detección de los discos duros SATA es más lenta de lo normal con placas base Itenl D945 en Ubuntu 8.10. Esto puede provocar que el sistema caiga en un intérprete de comandos «busybox» en initramfs con un mensaje de error del tipo «Gave up waiting for root device». Espere uno o dos minutos y a continuación salga del intérprete de comandos de initramfs tecleando 'exit'. El arranque debería continuar normalmente. En caso contrario, espere un poco más y vuelva a intentarlo. Cuando el sistema haya arrancado, edite el archivo /boot/grub/menu.lst y añada rootdelay=90 en la sección «kernel» de su núcleo actual.(bug 290153).

Kubuntu KDE4 remix

En algunos casos, no todas las aplicaciones se actualizan correctamente al pasar de Kubuntu 8.04 KDE 4 Remix a Kubuntu 8.10. Esto ocurre si se desinstala el paquete kubuntu-desktop. Recomendamos encarecidamente que compruebe que tiene instalado el paquete kubuntu-desktop (y kubuntu-kde4-desktop también, si tiene KDE4 instalado) antes de proceder con la actualización. Si se usa el actualizador de distribuciones, este lo llevará a cabo automáticamente.

No se puede iniciar sesión tras la actualización desde Kubuntu 8.04 KDE 4 Remix

Después de una actualización desde Kubuntu 8.04 KDE 4 Remix, al iniciar una sesión se volverá de nuevo directamente a la pantalla de entrada. El enlace alternativo de x-session-manager no está actualizado correctamente. Seleccione «KDE» en el menú de sesión antes de iniciar una sesión y corrija el problema con update-alternatives --set x-session-manager /usr/bin/startkde. (bug 287488).

encfs ya no soporta el cifrado ssl/blowfish-v0.2 versión 2:0:1

En la versión 1.4.x de encfs (la incluida en Ubuntu 8.10) se ha eliminado la compatibilidad con este antiguo algoritmo. Antes de actualizar, los usuarios de este algoritmo tendrán que migrar manualmente sus volúmenes encfs a uno nuevo creado con la nueva versión. Como alternativa, puede seguir usando una versión antigua de encfs para poder seguir leyendo los volúmenes.

Problemas de actualización en PlayStation 3

Se debe desactivar la pantalla gráfica de arranque cuando se actualicen sistemas PlayStation 3 desde Ubuntu 8.04 (bug 285218). Consulte las notas de publicación de PS3 para más información.

Otros problemas conocidos

Bloqueos del sistema con chipsets inalámbricos Intel 4965

La versión del controlador inalámbrico iwlagn para los chipsets inalámbricos Intel 4965 incluido en el núcleo Linux versión 2.6.27 causa cuelgues del núcleo cuando se usa en redes 802.11n o 802.11g. Los usuarios afectados por este problema pueden instalar el paquete linux-backports-modules-intrepid para tener así instalada una nueva versión de este controlador que corrige el fallo. (Como la única corrección conocida al problema necesita una nueva versión del controlador, no se espera que sea posible incluir este fallo en el paquete principal del núcleo.)

No se puede reactivar el dispositivo inalámbrico Intel 3945/4965 si se arranca con el interruptor apagado

En portátiles que dispongan de chipsets inalámbricos Intel 3945 ó 4965 y un interruptor para activar o desactivar la antena inalámbrica, iniciar el sistema con el interruptor apagado (es decir, con la radio inalámbrica deshabilitada) impedirá volver a habilitar la interfaz inalámbrica encendiendo el interruptor. Como solución temporal, los usuarios deben arrancar el sistema con el interruptor encendido. Para más información, consulte el [[https://bugs.launchpad.net/bugs/193970|bug 193970]. Se espera que aparezca una futura actualización del núcleo que corrija este problema.

El controlador inalámbrico ath5k de Atheros no está habilitado de forma predeterminada

La versión del controlador ath5k para los dispositivos inalámbricos Atheros incluida en Linux 2.6.27 interfiere con el uso del controlador madwifi usado en algunos dispositivos inalámbricos, y en consecuencia se ha deshabilitado de forma predeterminada. Muchos chipsets Atheros funcionarán correctamente con el controlador madwifi, pero algunos chipsets más modernos no, además de que el controlador madwifi puede no funcionar con la autenticación WPA. Si dispone de un dispositivo Atheros que no funciona con madwifi, tendrá que instalar el paquete linux-backports-modules-intrepid-generic, que incluye una versión actualizada del controlador ath5k. Aunque no se instala de forma predeterminada, este paquete linux-backports-modules-intrepid-generic está incluido en las imágenes de CD y DVD de Ubuntu 8.10 para facilitar su instalación.

Orden de arranque en iSCSI

Puede que los sistemas de archivos alojados en objetivos iSCSI no se monten automáticamente durante el arranque del sistema (incluso aunque tengan una entrada en /etc/fstab) si se necesita tener una interfaz Ethernet en puente («bridged») o vinculada («bonded») para alcanzar el objetivo iSCSI. Como solución temporal, tendrá que reiniciar el servicio open-iscsi y montar manualmente el sistema de archivos en cuestión después del arranque del sistema, una vez que la interfaz de red necesaria esté ya operativa. Los sistemas equipados con una interfaz Ethernet sencilla no están afectados.

Consulte el bug #227848.

No se pueden montar varios targets iSCSI al mismo tiempo

Actualmente no se soporta el montaje de varios targets iSCSI al mismo tiempo. Los sistemas configurados para usar más de un target iSCSI no deberían actualizarse a Ubuntu 8.10.

Para más información sobre el fallo y una aproximación a su solución, consulte el bug #289470.

El adaptador inalámbrico no funciona con el controlador ath_pci tras una suspensión

Los adaptadores inalámbricos que usen el controlador ath_pci del núcleo, como la tarjeta inalámbrica Atheros AR5212, no podrán conectarse a la red después de suspender y reanudar el sistema. Para solucionar temporalmente este problema, los usuarios pueden crear un archivo /etc/pm/config.d/madwifi que contenga la siguiente línea:

   SUSPEND_MODULES=ath_pci

Esto hará que el módulo se descargue antes de suspender y se cargue después de reanudar.

Los sistemas instalados desde imágenes diarias no publicadas pueden causar pérdidas de archivos

Un fallo presente en las imágenes diarias de escritorio no publicadas pueden causar la pérdida de algunos archivos relacionados con el soporte de idiomas en los sistemas instalados. Para corregir este problema, debería bastar con desinstalar y volver a instalar los paquetes de soporte de idiomas.

Este fallo no afecta a los usuarios que hayan instalado sus sistemas usando las versiones Beta o Release Candidate de Ubuntu 8.10.

Soporte de Bluetooth en Kubuntu

Kubuntu 8.10 no soporta Bluetooth debido a que KDE no soporta aún la pila bluez 4.x necesaria por compatibilidad con el núcleo usado en la versión 8.10.

Se está evaluando una solución a este problema en forma de actualización tras la publicación de la versión final.

KNetworkManager no soporta conexiones con IPs estáticas

KNetworkManager en Kubuntu 8.10 a veces da problemas con las conexiones de red que usan una configuración de dirección IP estática (bug 280762). Las conexiones que usan DHCP para la configuración de la dirección IP no están afectadas por este problema.

Usar usb-creator con imágenes 8.04.1 (Hardy)

El soporte para persistencia en las imágenes 8.04.1 no funciona. Crear una imagen USB con usb-creator y una imagen 8.04.1 provocará la aparición de un intérprete «busybox» si se marca la opción de persistencia.

En los adaptadores Intel 3945 sólo están habilitados los canales inalámbricos estadounidenses de forma predeterminada

El controlador inalámbrico iwl3945 está configurado de forma predeterminada para funcionar según el dominio regulatorio americano para redes inalámbricas, por lo que no funcionarán las redes inalámbricas en canales prohibidos por las regulaciones estadounidenses pero permitidos por las regulaciones europeas o japonesas. Esto afecta a los canales IEEE 802.11b/g 12 (Europa y Japón), 13 (Europa y Japón) y 14 (sólo Japón), así como a todos los canales 802.11a. (Pueden haber algunos otros controladores inalámbricos afectados; este es el único que sepamos que está afectado.)

Para corregir temporalmente el problema, añada la línea siguiente en el archivo /etc/modprobe.d/options si usa este controlador y necesita usar los canales inalámbricos europeos:

options cfg80211 ieee80211_regdom=EU

O bien, añada la siguiente línea si usa este controlador y necesita usar los canales inalámbricos japoneses:

options cfg80211 ieee80211_regdom=JP

Base de datos Cyrus SASL creada con permisos incorrectos

Cyrus SASL crea la base de datos para su complemento sasldb2 con permisos incorrectos. Como resultado, otros usuarios de essta base de datos (como cyrus-imap) no podrán acceder a ella y fallarán. Esto no afecta a las actualizaciones de bases de datos ya existentes desde una versión anterior. La solución temporal consiste en cambiar manualmente el grupo de /etc/sasldb2 a sasl:

$ sudo chgrp sasl /etc/sasldb2

Consulte el bug 288478 para más información.

Acceso al entorno de ejecución de Java

Para usar programas Java necesita instalar el paquete openjdk-6-jre, que contiene el entorno de ejecución de Java (Java Runtime Environment). Si quiere desarrollar programas Java, instale el paquete openjdk-6-jdk. Para trabajar con applets de Java en el navegador Firefox (y compatibles) sobre una arquitectura x86, necesitará instalar el paquete icedtea6-plugin a mano.

El JRE y el complemento para applets de Java ya están instalados de forma predeterminada en la sesión Live del DVD de Ubuntu, pero actualmente no están instalados en ningún otro sitio por problemas de espacio. Sin embargo, el instalador carece de una característica que le impide instalar esos paquetes cuando se está usando el instalador gráfico del DVD, por lo que tendrá que instalarlos usted luego.

Problemas con la expulsión de CDs

Cuando se abre la bandeja de una unidad de CD-ROM que contiene un CD, la bandeja se vuelve a cerrar inmediatamente, dificultando la extracción del disco (bug 283316). Como solución temporal, se puede pulsar el botón de expulsión una vez más antes de que el disco se monte completamente, tras lo cual la unidad permanecerá abierta. Esperamos corregir este problema en una actualización posterior a la publicación de la versión final.

Salvar y restaurar la sesión no funciona, y las aplicaciones no pueden guardarse automáticamente al finalizar la sesión

La opción «Recordar automáticamente las aplicaciones en ejecución al salir de la sesión» que se encuentra en «Preferencias de la sesión» no funciona en esta versión (bug 249373).

Hay muchas aplicaciones que pueden hacer un guardado automático de (o que ofrecen guardar) cualquier documento abierto cuando se cierra una sesión. El gestor de sesiones de GNOME en esta versión no les notifica que se va a cerrar la sesión, por lo que no tienen oportunidad de guardar su estado. Como resultado, si se sale de la sesión teniendo documentos modificados abiertos se puede perder información.

Bloqueo del sistema con efectos de escritorio en tarjetas gráficas Intel 830MG y 845G

Hay un fallo en el controlador gráfico Intel para las viejas tarjetas gráficas integradas Intel 830 y 845 usadas en portátiles como el IBM R30. Los efectos de escritorio con Compiz no funcionan con esos chips y provocarán el bloqueo del sistema. Para llevar a cabo instalaciones nuevas, use el modo gráfico seguro (pulse F4 en la pantalla de arranque) y deshabilite los efectos de escritorio en Sistema -> Preferencias -> Apariencia, pulsando en «Efectos visuales» y seleccionando «Ninguno».

IntrepidReleaseNotes/es (last edited 2008-11-09 20:02:57 by ricardo)