ru


Contents

  1. Системные требования
  2. Установка
    1. Рекомендованные пакеты, устанавливаемые по умолчанию
    2. Медленно работает шаг "Выбор и установка программ" при установке в текстовом режиме
    3. Жёсткий диск (диски) не доступны при установке в режиме Live CD
    4. Ограничение в паролях с ecryptfs
  3. Обновление
    1. Поддержка видеокарт nVidia прошлых поколений
    2. Поддержка видеокарт ATI "fglrx"
    3. Устройства ввода в X.Org
    4. Несовместимость evdev xmodmap в X.Org
    5. Апплет «Выход...» в GNOME
    6. Поддержка ядра реального времени в UbuntuStudio
    7. encfs больше не поддерживает шифр ssl/blowfish-v0.2, версии 2:0:1
  4. Прочие известные проблемы
    1. Зависание систем с беспроводными адаптерами Intel 4965
    2. Не удаётся включить беспроводные сетевые карты Intel 3945/4965 если система загружена с выключенным радиомодулем
    3. Драйвер для адаптеров беспроводных сетей Atheros ath5k не включен по умолчанию
    4. Монтирование iSCSI при загрузке
    5. Не поддерживается подключение нескольких iSCSI устройств одновременно
    6. Беспроводная сеть не работает после выхода из спящего режима
    7. В системах, установленных из образов пре-релиза, может не хватать файлов
    8. Поддержка Bluetooth в Kubuntu
    9. KNetworkManager не может работать с соединениями со статичным IP-адресом
    10. Невозможно войти в сеанс при обновлении с Kubuntu 8.04 KDE 4 Remix
    11. Использование usb-creator совместно с образами 8.04.1 (Hardy)
    12. В Intel 3945 по умолчанию включены только каналы США
    13. База данных Cyrus SASL создается с неправильными правами

Этот документ описывает известные проблемы Ubuntu версии 8.10 и других версий операционной системы.

Системные требования

Минимальные требования Ubuntu 8.10 к памяти — 256 Мб. (Отметим, что часть памяти вашей системы может быть недоступна, поскольку будет использоваться видеокартой.)

С минимальным объемом памяти процесс установки будет длиться дольше обычного, но будет завершен успешно. Установленная система будет работать должным образом. Возможно использование Desktop CD на системах с малым количеством памяти с помощью выбора в загрузочном меню пункта «Установить Ubuntu» вместо запуска всей системы, когда выбирается пункт «Попробовать Ubuntu без установки на компьютер».

Установка

Рекомендованные пакеты, устанавливаемые по умолчанию

В соответствии с Debian Policy Manual (в котором списком 'Recommends' указан перечень пакетов, обычно используемых совместно с данным пакетом во всех случаях, кроме нетипичных) система управления пакетами теперь устанавливает пакеты, указанные в списке рекомендованных так же, как и пакеты из списка зависимых ('Depends'), т.е. по умолчанию. Если данное поведение нежелательно для отдельного пакета, используйте apt-get --no-install-recommends. Для активации этого режима по умолчанию, установите APT::Install-Recommends "false"; в файле /etc/apt/apt.conf. Обратите внимание на то, что это может привести к потере ряда функций в некоторых приложениях.

Медленно работает шаг "Выбор и установка программ" при установке в текстовом режиме

Шаг "Выбор и установка программ": при установке в текстовом режиме полоса прогресса замирает на малых значениях прогресса. Это, в основном, относится к вариантам сетевой установки (netboot installations) и связано с тем, что при закачке пакета из сети Интернет не происходит обновления состояния закачки между установщиком пакетов и apt-get. Данная проблема была слишком поздно выявлена, поэтому исправление не вошло в релиз Ubuntu 8.10: ошибка №290234.

Состояние закачки можно посмотреть переключившись на диагностический экран нажатием Alt-F4; Alt-F1 вернет вас в основное окно установщика. (Если установка производится в эмуляторе QEMU или KVM, то нужно проявить осторожность и нажимать Ctrl+Alt или сперва кликнуть мышкой в окно эмулятора, для захвата фокуса клавиатуры, а только потом нажимать Alt-F4, иначе рискуете случайно закрыть эмулятор!)

Жёсткий диск (диски) не доступны при установке в режиме Live CD

Если пользователь просматривал информацию на жёстком диске (дисках) в режиме Live CD перед выполнением установки, то установщик не разрешит использование этих дисков. Это связано с тем, что при просмотре разделов происходит их подключение (монтирование), а диски с подключёнными разделами невозможно изменить. Решение этой проблемы состоит в том, чтобы отключить (отмонтировать) все подключённые разделы перед запуском установки.

Ограничение в паролях с ecryptfs

Пользователи инсталяций alternate/server, у которых в пароле содержится знак "%" или "-" не смогут получить доступ к своей папке ~/Private directory, т.к. она не будет подключена при перезагрузке и последующих входах. Чтобы исправить данную проблему нужно выполнить следующие действия:

  1. Обновить ecryptfs-utils до самой новой версии

  2. Затем выполнить: $ ecryptfs-setup-private --force

Более подробно о проблеме и способах её решения смотрите ошибка №290445.

Обновление

Пользователи Ubuntu 8.04 LTS могут обновиться до Ubuntu 8.10 в автоматическом режиме. Пользователи более старых релизов Ubuntu должны обновить систему до Ubuntu 8.04 LTS, а затем до Ubuntu 8.10. Подробные инструкции можно найти по адресу http://www.ubuntu.com/getubuntu/upgrading.

Поддержка видеокарт nVidia прошлых поколений

71 и 96 серии несвободных драйверов nVidia, которые входили в состав Ubuntu 8.04 LTS как пакеты nvidia-glx-legacy и nvidia-glx, не совместимы с версией X.Org, которая входит в Ubuntu 8.10. Проблема касается пользователей видеокарт на чипах nVidia TNT, TNT2, TNT Ultra, GeForce, GeForce2, GeForce3, и GeForce4, при обновлении будет произведен переход на использование свободного драйвера nv. Этот драйвер не поддерживает 3D-ускорение.

Пользователи прочих чипов,поддерживаемых драйверами серии 173 или 177, будут переведены на использование пакетов nvidia-glx-173 или nvidia-glx-177. Однако, в отличие от драйверов серий 96 и 71, драйвера серий 173 и 177 совместимы только с центральными процессорами, которые поддерживают набор инструкций SSE (т.е. Intel Pentium III, AMD Athlon XP или более новые модели). Системы с более старыми процессорами будут также переведены на использование драйвера nv при обновлении.

Поддержка видеокарт ATI "fglrx"

В версии 8.10 прекращена поддержка драйвера для видеокарт ATI, основанных на чипе r300 (видеокарты серии Radeon 9500 - X600). Если вы обладатель видеокарты из этой серии, то перед обновлением нужно выключить этот драйвер с помощью "Драйверы устройств" в меню Система/Администрирование. Более подробно смотрите ошибка №284408.

Устройства ввода в X.Org

Файл настроек X.Org (/etc/X11/xorg.conf) всё ещё содержит элементы секции InputDevice для мыши и клавиатуры, но они теперь игнорируются, поскольку используется автонастройка устройств ввода. Настройки клавиатуры теперь считываются из файла /etc/default/console-setup, для изменения которого нужно использовать команду:

sudo dpkg-reconfigure console-setup

После перенастройки необходимо перезапустить HAL и X (например, перезагрузив систему).

Несовместимость evdev xmodmap в X.Org

Коды клавиш в X, генерируемые новым драйвером ввода evdev из X.Org 1.5 не совместимы с генерируемыми в Ubuntu 8.04 LTS и ранее. Если вами были произведены настройки соответствий клавиш для пользователя при помощи файла ~/.Xmodmap, вам потребуется вручную обновить или удалить эти настройки при обновлении.

Апплет «Выход...» в GNOME

Апплет «Выход...», который в предыдущих выпусках Ubuntu по умолчанию располагался на панели, теперь не предоставляет функции завершения работы, перезагрузки, перехода в ждущий и спящий режим. Рекомендуется удалить данный апплет и заменить его на «Переключатель пользователей», который теперь включает указанные возможности. Эта замена не производится автоматически при обновлении (ошибка №274146).

Поддержка ядра реального времени в UbuntuStudio

Для ядра Linux 2.6.27, которое входит в состав Ubuntu 8.10, отсутствует мультипроцессорный (SMP) вариант ядра реального времени. Пользователям UbuntuStudio 8.04, которым требуется поддержка ядра реального времени на двухядерных, двухпроцессорных и более сложных многопроцессорных системах в настоящее время не рекомендуется обновлять систему до UbuntuStudio 8.10.

encfs больше не поддерживает шифр ssl/blowfish-v0.2, версии 2:0:1

Обратная совместимость для этого устаревшего алгоритма была прекращена в encfs версии 1.4.x, которая включена в Intrepid. Перед обновлением пользователям, которые используют этот алгоритм шифрования, необходимо вручную переписать данные с раздела, созданного старым алгоритмом шифрования, на новый раздел, зашифрованный новым алгоритмом. Или использовать старую версию модуля шифрования, чтобы иметь возможность работы с зашифрованными разделами.

Прочие известные проблемы

Зависание систем с беспроводными адаптерами Intel 4965

Версия беспроводного драйвера iwlagn для беспроводных чипсетов Intel 4965, входящая в ядро Linux версии 2.6.27, вызывает системную панику при работе с сетями 802.11n или 802.11g. Пользователи, которых это касается, могут установить пакет linux-backports-modules-intrepid для установки новой версии драйвера, в которой эта ошибка исправлена. (Известное решение требует установки нового драйвера, который в настоящий момент не планируется добавлять в основной пакет ядра.)

Не удаётся включить беспроводные сетевые карты Intel 3945/4965 если система загружена с выключенным радиомодулем

На ноутбуках с беспроводными сетевыми картами на основе чипов Intel 3945 или Intel 4965 и выключателем для радиомодуля, загрузка ноутбука с выключенным радиомодулем приводит к тому, что он впоследствии не включается этим выключателем. В качестве временной меры рекомендуется загружать систему с включенным беспроводным адаптером. Будущее обновление ядра, как ожидается, должно исправить эту проблему.

Драйвер для адаптеров беспроводных сетей Atheros ath5k не включен по умолчанию

Версия драйвера ath5k для беспроводных сетевых адаптеров от Atheros, которая входит в состав Linux 2.6.27 препятствует нормальной работе драйвера madwifi для некоторых устройств беспроводных сетей, и в результате по умолчанию отключена. Многие адаптеры от Atheros будут корректно работать с драйвером madwifi, но некоторые новые чипы могут не работать, также драйвер madwifi может не работать с аутентификацией WPA. Если вы являетесь владельцем устройства Atheros, которое не работает с madwifi, вам рекомендуется установить пакет linux-backports-modules-intrepid-generic, содержащий обновленную версию драйвера ath5k. Хотя этот драйвер не устанавливается по умолчанию, этот пакет linux-backports-modules-intrepid-generic входит в состав образов CD и DVD дисков Ubuntu 8.10 для удобства установки.

Монтирование iSCSI при загрузке

Файловые системы, хранящиеся на устройствах iSCSI могут не монтироваться автоматически при старте системы, даже если для них есть запись в /etc/fstab, если для того, чтобы их достичь нужно использовать работающий в режиме моста (bridged) или в режиме дублирования (bonded) интерфейс Ethernet. Как временную меру можно использовать ручной перезапуск сервиса open-iscsi и ручное монтирование требуемой файловой системы после загрузки ОС, когда нужный сетевой интерфейс уже поднят. Систем, оборудованных обычных интерфейсом Ethernet, это не касается. Подробнее смотрите ошибка №227848.

Не поддерживается подключение нескольких iSCSI устройств одновременно

Одновременное монтирование нескольких iSCSI устройств на данный момент не поддерживается. Системы, настроенные на использование более одного iSCSI устройства, не должны обновляться до версии Intrepid.

Более подробно о проблеме и способах её решения смотрите ошибка №289470.

Беспроводная сеть не работает после выхода из спящего режима

Беспроводные устройства использующие драйвер ядра ath_pci, такие как беспроводные карты Atheros AR5212, не смогут подключиться к сети после "пробуждения" из спящего режима. Чтобы обойти эту проблему, пользоветль может создать файл /etc/pm/config.d/madwifi содержащий всего лишь одну строку:

   SUSPEND_MODULES=ath_pci

Таким образом драйвер будет выгружен из памяти перед "засыпанием" системы и загружен обратно при "пробуждении".

В системах, установленных из образов пре-релиза, может не хватать файлов

Ошибка состоит в том, что в образах системы, установленных из ежедневных образов пре-релиза, может не хватать некоторых файлов связанных с языковой поддержкой. Для устранения проблемы нужно удалить языковые пакеты и установить их заново.

Это не затрагивает пользователей, установивших версии Ubuntu 8.10 Бета или Release Candidate.

Поддержка Bluetooth в Kubuntu

В Kubuntu 8.10 нет поддержки Bluetooth, потому что KDE ещё не поддерживает стек bluez 4.x, необходимый для совместимости с используемым в 8.10 ядром. Решение этой проблемы возможно будет включено в обновление после релиза. (ошибка №280997)

KNetworkManager не может работать с соединениями со статичным IP-адресом

Иногда KNetworkManager в Kubuntu 8.10 не работает с сетевыми подключениями, которым назначен статичный IP-адрес (ошибка №280762). Этой проблеме не подвержены соединения, использующие DHCP для получения IP-адреса.

Невозможно войти в сеанс при обновлении с Kubuntu 8.04 KDE 4 Remix

После обновления с Kubuntu 8.04 KDE 4 Remix, попытка входа в сессию возвращает опять в окно авторизации. Проблема в не обновленной ссылке x-session-manager. Выберите "KDE" в меню выбора сессии перед авторизацией и исправьте ссылку при помощи команды update-alternatives --set x-session-manager /usr/bin/startkde. (Ошибка №287488).

Использование usb-creator совместно с образами 8.04.1 (Hardy)

Простая поддержка образов 8.04.1 сломана. Если выбрана опция совместимости, то создание USB диска, при помощи usb-creator и образов 8.04.1, приводит к командной строке в busybox.

В Intel 3945 по умолчанию включены только каналы США

Драйвер беспроводной сети iwl3945 по умолчанию настроен на использование US доменов доступа, так что каналы, запрещенные Американским законодательством, но разрешенные в Европейских и Японских странах, не будут доступны "из коробки". Имеются ввиду IEEE 802.11b/g каналы 12 (Европа и Япония), 13 (Европа и Япония), и 14 (только Япония), а также все 802.11a каналы. (Могут быть затронуты некоторые другие беспроводные драйвера; если таковые есть, то вероятно мы об этом вскоре узнаем.)

Решение проблемы сводится к добавлению следующих строк в /etc/modprobe.d/options, при условии что используется этот драйвер и есть необходимость в каналах Европы:

options cfg80211 ieee80211_regdom=EU

Следующие настройки нужны для включения каналов Японии:

options cfg80211 ieee80211_regdom=JP

База данных Cyrus SASL создается с неправильными правами

Cyrus SASL создает базу данных для расширения sasldb2 с неправильными правами доступа. В итоге другие пользователи или приложения, работающие с базой, такие как cyrus-imap, не смогут получить доступ и будут аварийно завершать работу. Эта проблема не распространяется на сушествующие базы предыдущих версий. Решение проблемы заключается в переназначении группы вручную для /etc/sasldb2 на sasl:

sudo chgrp sasl /etc/sasldb2

Более подробно смотрите (ошибка №288478).

IntrepidReleaseNotes/ru (last edited 2008-11-20 10:26:13 by mmx-dimitrov)