nl


Contents

  1. Systeemvereisten
  2. Uitgave-opmerkingen voor Ubuntu 9.10 voor de ARM-architectuur
  3. Installatie
    1. Aanbevolen pakketten die standaard worden geïnstalleerd
    2. Slaapstand is mogelijk niet beschikbaar na automatisch partitioneren
    3. Pakketlijst moet handmatig worden bijgewerkt voordat u stuurprogramma's installeert
    4. Andere besturingssystemen worden niet getoond in het opstartmenu bij installatie van Ubuntu 9.10 RC
    5. Automatische opstarten van een degraded RAID array wordt niet goed geconfigureerd tijdens installatie
    6. Het pictogram "OEM Voorbereiden voor levering aan eindgebruiker" wordt niet getoond in de Kubuntu-netbookeditie
    7. UNR installatie-bevestigingsdialoog kan verborgen zijn
    8. Wubi vanaf een USB-medium met persistente opslag starten
    9. Geen snelkoppeling in Ubuntu Moblin Remix developer preview
    10. Installaties met aparte /boot-partitie
  4. Upgraden
    1. GRUB menu.lst: de versie van de onderhouder installeren vs. de huidige versie behouden
    2. Instellen van regeldomein voor draadloos-netwerk via module-optie wordt niet langer ondersteund
    3. Upgrade vanaf beta moet handmatig in gang worden gezet
    4. X-server loopt vast bij gebruik van Wacom-tablet
    5. Ubuntu Netbook Remix mist afsluitapplet na upgrade
    6. Kubuntu behoudt mogelijk het guidance power-pakket
    7. Ctrl-Alt-Backspace standaard uitgeschakeld door X-org, ingesteld via XKB
      1. Ctrl-Alt-Backspace inschakelen voor Ubuntu
      2. Ctrl-Alt-Backspace inschakelen voor Kubuntu
    8. Wijziging in het melden van beschikbare updates
    9. MySQL-upgrade
    10. MySQL Cluster-instelling
    11. /etc/event.d wordt niet langer gebruikt
    12. Syslog-opwaardering
    13. Eucalyptus 1.5-snapshots worden niet bewaard bij opwaadering naar 1.6
  5. Andere bekende problemen
    1. Overstappen naar ext4 vereist handmatige aanpassing van grub
    2. Mogelijke corruptie van grote bestanden met het ext4 bestandsysteem
    3. Ubuntu One vereist een upgrade na de installatie
    4. Upstart-taken kunnen niet worden uitgevoerd in een chroot
    5. Aanmeldscherm verschijnt voordat optionele bestandssystemen kunnen worden aangekoppeld
    6. Optionele versleutelde partities moeten gemarkeerd worden met bootwait in /etc/fstab
    7. Avahi start niet als er een .local-domein aanwezig is
    8. Uitschakelen van Ralink t2860 wifi-kaart op een EeePC met sneltoets Fn+2 zorgt voor een kernelcrash
    9. Bison Webcam-stuurprogramma in MSI Wind netbook zorgt voor fouten met USB als die webcam niet wordt uitgeschakeld
    10. Geen Xv-ondersteuning voor Intel 82852/855GM video-chips met KMS
    11. Knipperende helderheid op MSI Wind netbooks met KMS
    12. Kubuntu's grafisch pakketbeheer waarschuwt niet voor installatie uit niet-ondertekende softwarebronnen
    13. Amarok biedt geen extra codecs aan ter installatie tijdens het uitvoeren van Kubuntu vanaf de live-cd
    14. Evince PDF-viewer werkt niet met afwijkende persoonlijke mappen
    15. UEC weigert mogelijk de eerste verzoeken na het opstarten
    16. UEC-nodecontroller faalt tijdens installatie op bestaande UEC
    17. Bevestigings-e-mails worden niet naar nieuwe gebruikers van UEC verzonden
    18. UEC-gebruikersgegevens niet bruikbaar bij gast-instanties
    19. Ubuntu 8.04 LTS als KVM-gast loopt vast wanneer men gebruik maakt van de virtio netwerk-drivers
    20. Het niet authenticeren van een Windows 7-domeinlid op een Ubuntu 9.10-server met een Samba-domeincontroller
    21. Samba nmbd-daemon start niet tijdens het opstarten van de computer
    22. Sparc niet ondersteund door Ubuntu 9.10
    23. Vensters corrupt met oudere ATI-grafische kaarten

Deze uitgave-opmerkingen beschrijven bekende problemen met Ubuntu 9.10 en diens varianten.

Systeemvereisten

Er is minimaal 256 MB geheugen nodig voor Ubuntu 9.10. Let op dat een deel van het interne geheugen in beslag kan worden genomen door de grafische kaart. Wanneer uw computer slechts over de minimum-hoeveelheid geheugen beschikt zal het installatieproces langer dan normaal duren, maar wel succesvol verlopen. Eenmaal geïnstalleerd zal het systeem naar behoren functioneren.

Voor systemen met minder geheugen kunt u "Ubuntu installeren" kiezen uit het opstartmenu om alleen het installatieprogramma uit te voeren in plaats van het complete bureaublad te laden. Tevens kunt u de alternatieve installatie-cd gebruiken.

Uitgave-opmerkingen voor Ubuntu 9.10 voor de ARM-architectuur

Een aparte pagina is beschikbaar gemaakt met de uitgave-opmerkingen voor de nog in ontwikkeling zijnde armel-port van Ubuntu. De pagina is speciaal bedoeld voor mensen die zich bezig houden met en/of ontwikkelen voor Ubuntu 9.10 armel. Bekijk https://wiki.ubuntu.com/ARM/KarmicReleaseNotes (Engelstalig) voor meer informatie over het installeren van Ubuntu 9.10 op ARM.

Installatie

Aanbevolen pakketten die standaard worden geïnstalleerd

Overeenkomstig de Debian Policy Manual (waarin staat: "The 'Recommends' field should list packages that would be found together with this one in all but unusual installations"), installeert het pakketbeheer nu standaard pakketten vermeld onder de sectie "Aanbevolen" van andere geïnstalleerde pakketten evenals die onder de sectie "Afhankelijk". Als u dit wilt vermijden voor de installatie van specifieke pakketten, gebruik dan apt-get --no-install-recommends; als u dit blijvend wilt maken, stel dan APT::Install-Recommends in op "false"; in /etc/apt/apt.conf. Merk op dat dit kan leiden tot missende functionaliteit in sommige programma's.

(Deze wijziging is aangebracht in Ubuntu 8.10)

Slaapstand is mogelijk niet beschikbaar na automatisch partitioneren

Bij het onderdeel partitioneren zal het installatieprogramma in sommige gevallen een swap-partitie toewijzen die kleiner is dan het fysieke geheugen van het systeem. Hierdoor is het gebruik van de slaapstand (schijf-pauzestand) niet mogelijk omdat de systeem-image niet op de swap-partitie zal passen. Wilt u de slaapstand wel gebruiken, zorg er dan voor dat de swap-partitie minstens even groot is als het fysieke RAM-geheugen. (354126)

Pakketlijst moet handmatig worden bijgewerkt voordat u stuurprogramma's installeert

Het programma "Hardwarestuurprogramma's" (Jockey) vereist een bijgewerkte pakketlijst voordat het de hardware kan detecteren en aan kan geven dat er extra stuurprogramma's kunnen worden geïnstalleerd. Onmiddellijk na de installatie zullen de pakketten niet aanwezig zijn. Voordat u Jockey voor de eerste keer uitvoert, dient u de pakketlijst bij te werken via
Systeem->Beheer->Updatebeheer (op Ubuntu) of "KPackageKit" (op Kubuntu) (462704)

Andere besturingssystemen worden niet getoond in het opstartmenu bij installatie van Ubuntu 9.10 RC

Na installatie van Ubuntu 9.10 Release Candidate worden andere geïnstalleerde besturingssystemen niet correct getoond in het opstartmenu. Om dit te verhelpen, moeten gebruikers de opdracht sudo update-grub uitvoeren in een opdrachtprompt nadat het systeem opnieuw gestart is met het zojuist geïnstalleerde Ubuntu-besturingssysteem. Dit probleem treedt niet op bij installaties van de uiteindelijke Ubuntu 9.10. (456776)

Automatische opstarten van een degraded RAID array wordt niet goed geconfigureerd tijdens installatie

De installatie-optie "boot from a degraded array" zorgt ervoor dat het systeem niet helemaal correct wordt geïnstalleerd. Dit probleem is op te lossen na de installatie door dpkg-reconfigure mdadm uit te voeren en dan deze optie te selecteren. (462258)

Het pictogram "OEM Voorbereiden voor levering aan eindgebruiker" wordt niet getoond in de Kubuntu-netbookeditie

Wanneer u in de Kubuntu-netbookeditie kiest voor de optie OEM-installatie, wordt er geen "Voorbereiden voor levering aan eindgebruiker"-pictogram op het bureaublad getoond. Gebruikers die de OEM-installatie willen uitvoeren in de Kubuntu-netbookeditie, kunnen System->Prepare for shipping ... kiezen uit de hoofdbalk. (386099)

UNR installatie-bevestigingsdialoog kan verborgen zijn

In enkele gevallen kan het zijn dat de installatie-bevestigingsdialoog aan het einde van een succesvolle installatie van Ubuntu Netbook Remix verborgen is. Om het dialoogvenster voor herstarten te verkrijgen, kunt u er in de lijst met vensters in het bovenste paneel op klikken of u schakelt met ALT-TAB totdat het dialoogvenster voor herstarten verschijnt. (462178)

Wubi vanaf een USB-medium met persistente opslag starten

Gebruikers die Wubi willen opstarten vanaf een USB-medium met de optie persistente opslag aan, dienen dat te doen met de optie --force-wubi in de Windows-opdrachtregel. (461566)

Geen snelkoppeling in Ubuntu Moblin Remix developer preview

Het installatieprogramma is niet aanwezig als snelkoppeling in het welkomstscherm van de Ubuntu Moblin Remix developer preview. Om de installatie te starten vanuit een live-sessie opent u "Install Ubuntu" onder Applications > Settings. (439656)

Installaties met aparte /boot-partitie

Als er al een vorige Ubuntu (of andere Linux)-installatie aanwezig is en de nieuwe installatie wordt er naast geïnstalleerd (met bijv. de "auto-resize"-optie), dan kan de vorige installatie niet meer starten via het opstartmenu. Dit komt door verkeerde instellingen in het aangemaakte /boot/grub/grub.cfg. Een oplossing voor dit probleem zal in vorm van een update onmiddellijk na de uitgave van Ubuntu 9.10 verstrekt worden. (462961)

Upgraden

Gebruikers van Ubuntu 9.04 kunnen automatisch upgraden naar Ubuntu 9.10. Gebruikers van oudere versies van Ubuntu moeten eerst upgraden naar Ubuntu 9.04 en daarna naar 9.10. Volledige instructies kunt u hier vinden (Engelstalig).

Gebruikers van Kubuntu kunnen direct upgraden van Kubuntu 8.04 naar Kubuntu 9.10. Voor deze gebruikers is het raadzaam om ook de uitgave-opmerkingen voor Ubuntu 8.10 en Ubuntu 9.04 te lezen (beide Engelstalig), aangezien de daar beschreven onderwerpen ook hier van toepassing zijn.

GRUB menu.lst: de versie van de onderhouder installeren vs. de huidige versie behouden

Als u ooit de opstartladerinstellingen voor GRUB in menu.lst heeft aangepast, met de hand of met een hulpmiddel als kgrubeditor, dan wordt u tijdens het upgraden mogelijk gevraagd of u de lokale versie wilt behouden, of dat u de versie in het pakket wilt installeren. Deze vraag wordt gesteld, omdat dergelijke wijzigingen nooit met volledige zekerheid samengevoegd kunnen worden, en omdat een handmatig bewerkte configuratie niet zomaar overschreven hoort te worden.

Als u echter kiest voor "de huidige geïnstalleerde versie behouden", dan zal uw systeem niet kunnen opstarten met nieuw geïnstalleerde kernels. U moet zelf handelingen verrichten na het upgraden om uw computer te laten draaien met de nieuwste, met veiligheidsupdates ondersteunde kernel. Als u wijzigingen heeft aangebracht aan uw opstartladerinstellingen die u wilt behouden, dan wordt het aangeraden om de volgende stappen uit te voeren:

  • Kies "de huidige geïnstalleerde versie behouden" in het dialoogvenster.
  • Open /boot/grub/menu.lst met een teksteditor (bijv. sudo gedit /boot/grub/menu.lst).

  • Pas alle wijzigingen aan de opstartopties toe op de bovenstaande variabelen in het commentaargedeelte (bijv. groot, kopt, defoptions).
  • Verplaats alle handmatig toegevoegde opstartopties voor andere besturingssystemen zodanig, dat ze boven de regel

### BEGIN AUTOMAGIC KERNELS LIST
staan, of onder de regel
### END DEBIAN AUTOMAGIC KERNELS LIST

  • Sla het bestand op, en voer sudo update-grub uit op de opdrachtprompt.

  • Kies "de versie van de pakketonderhouder installeren".

Als u bijvoorbeeld de optie i915.modeset=0 aan de regel "Kernel" heeft toegevoegd:

kernel          /vmlinuz-2.6.31-14-generic root=UUID=0e7... ro quiet splash i915.modeset=0

Voeg dan dit toe aan kopt:

# kopt=root=UUID=0e7... ro i915.modeset=0

Een bijgewerkte versie van het grub-pakket zal informatie over dit probleem bevatten in het hulpscherm voor het menu.lst-prompt. (470490)

Instellen van regeldomein voor draadloos-netwerk via module-optie wordt niet langer ondersteund

Ubuntu 9.10 gebruikt het CRDA wireless regulatory framework om te controleren welke draadloze kanalen er in een bepaald gebied zichtbaar en bruikbaar zijn. Als u eerder de module-optie zoals hieronder in /etc/modprobe.d/options moest gebruiken om toegang tot bepaalde kanalen in uw buurt te krijgen zult u mogelijk ondervinden dat draadloos-internet helemaal niet meer functioneert:

  • options cfg80211 ieee80211_regdom=EU

U dient deze kernelmodule-optie te verwijderen bij het upgraden naar Ubuntu 9.10. Gebruik in plaats daarvan de opdracht iw reg.

(Deze wijziging is aangebracht in Ubuntu 9.04.)

Upgrade vanaf beta moet handmatig in gang worden gezet

Een fout in het apt-pakket van Ubuntu 9.10 beta zorgt ervoor dat er geen automatische melding wordt gemaakt van pakketupdates. Gebruikers die hun systeem naar een versie van Ubuntu 9.10 hebben opgewaardeerd die lager is dan de Release Candidate, moeten op updates controleren door update-manager te starten, op Controleren te klikken en de beschikbare updates te installeren. (449535)

X-server loopt vast bij gebruik van Wacom-tablet

Het wacom-stuurprogramma in Ubuntu 9.10 ondersteunt automatische configuratie, maar conflicteert met handmatige apparaatopties in /etc/X11/xorg.conf, waardoor de X-server tijdens het opstarten of afsluiten vastloopt. Plaats een hekje voor deze apparaatopties of verwijder ze om de vastlopers op te lossen. (358643)

Ubuntu Netbook Remix mist afsluitapplet na upgrade

Na het upgraden van Ubuntu Netbook Remix kan het zijn dat de afsluitapplet ontbreekt in het bovenste paneel. Als tijdelijke oplossing maakt u wat ruimte tussen de applets en klikt u met de rechtermuisknop op de vrijgekomen ruimte, waarna u "Indicator Applet Session" selecteert. Bekijk 461115 (Engelstalig) voor gedetailleerdere instructies.

Kubuntu behoudt mogelijk het guidance power-pakket

Na een Kubuntu-upgrade kunnen de niet langer gebruikte pakketten "kde-guidance-powermanager" of "guidance-power-manager" mogelijk achterblijven. Deze kunnen verwijderd worden.

Ctrl-Alt-Backspace standaard uitgeschakeld door X-org, ingesteld via XKB

Met ingang van Ubuntu 9.04 is de toetsencombinatie Ctrl-Alt-Backspace om X geforceerd te herstarten standaard uitgeschakeld, om te voorkomen dat deze per ongeluk wordt ingedrukt. De toetsencombinatie Ctrl-Alt-Backspace wordt nu ingesteld door een X keymap-optie (XKB), vervangt de optie "DontZap" (Engelstalig) van X-Server en maakt de configuratie per gebruiker mogelijk.

Als gevolg hiervan kan de toetsencombinatie Ctrl+Alt+Backspace nu gemakkelijk vanaf het bureaublad worden ingesteld.

Ctrl-Alt-Backspace inschakelen voor Ubuntu

  • Kies "Systeem"->"Voorkeuren"->"Toetsenbord"

  • Kies het tabblad "Indelingen" en klik op de knop "Indelingsopties...".
  • Kies "Key sequence to kill the X server" en schakel "Control + Alt + Backspace" in.

Ctrl-Alt-Backspace inschakelen voor Kubuntu

  • Klik op de Programmastarter en kies "Systeeminstellingen".
  • Klik op "Land/regio en taal".
  • Kies "Toetsenbordindeling".
  • Klik op "Toetsenbordindelingen inschakelen" (in het tabblad Indeling).
  • Kies het tabblad "Geavanceerd". Kies vervolgens "Key sequence to kill the X server" en schakel "Control + Alt + Backspace" in.

Voor meer informatie, zie: https://wiki.ubuntu.com/X/Config/DontZap (Engelstalig)

Wijziging in het melden van beschikbare updates

Ubuntu 9.10 start update-manager direct om updates te installeren in plaats van een melding weer te geven in het GNOME-paneel. Het venster opent dagelijks voor beveiligingsupdates, maar voor andere updates opent het slechts een keer per week.

Gebruikers die meldingen van nieuwe updates willen ontvangen zoals in eerdere Ubuntu-versies, moeten de volgende opdracht uitvoeren:

gconftool -s --type bool /apps/update-notifier/auto_launch false

(Deze wijziging is aangebracht in Ubuntu 9.04.)

MySQL-upgrade

In Ubuntu 9.10 is MySQL 5.1 aangesteld als de standaard MySQL-server. MySQL 5.0 is echter nogsteeds beschikbaar uit de universe-pakketbron. Een upgrade via update-manager zal de migratie van MySQL 5.0 naar MySQL 5.1 correct afhandelen. Bij een dist-upgrade gebeurt dit echter niet: mysql-server-5.0 zal dan opgewaardeerd worden in plaats van vervangen worden door mysql-server-5.1. Als MySQL 5.0 behouden dient te worden, moeten de pakketten mysql-server en mysql-client verwijderd worden alvorens de upgrade te starten.

MySQL Cluster-instelling

Als MySQL is ingesteld om de MySQL Cluster-engine (NDB-engine) te gebruiken, zal een upgrade naar MySQL 5.1 niet werken wegens gebrek aan ondersteuning voor MySQL Cluster in de mysql-dfsg-5.1-pakketten. De pakketten mysql-server en mysql-client moeten verwijderd worden alvorens de upgrade te starten, en mysql-server-5.0 moet behouden worden. Update-manager zal deze situatie dan automatisch afhandelen. Merk op dat MySQL 5.0 zich in de universe-pakketbron bevindt en dus niet dezelfde hoeveelheid ondersteuning ontvangt als MySQL 5.1 (welke in main zit).

/etc/event.d wordt niet langer gebruikt

De versie van upstart in Ubuntu 9.10 gebruikt niet langer de configuratiebestanden uit de map /etc/event.d maar uit de map /etc/init. Het is niet mogelijk wijzigingen in /etc/event.d automatisch over te zetten. Indien u wijzigingen heeft aangebracht in deze map dient u deze opnieuw handmatig aan te brengen in de map /etc/init. (402759)

Syslog-opwaardering

Het sysklogd-pakket is vervangen door rsyslog. De configuratie van sysklogd in /etc/syslog.conf wordt automatisch omgezet naar /etc/rsyslog.d/50-default. Als u de rotatie-instellingen heeft aangepast in /etc/cron.daily/sysklogd of /etc/cron.weekly/sysklogd moet u de nieuwe instellingen zelf wijzigen in /etc/logrotate.d/rsyslog. Let erop dat de vroegere rotatie met .0 begon als eerste rotatiebestand; met het nieuwe logrotate is .1 het eerste rotatiebestand.

Eucalyptus 1.5-snapshots worden niet bewaard bij opwaadering naar 1.6

Als een systeem Ubuntu Enterprise Cloud draait op Ubuntu 9.04 en wordt opgewaardeerd naar Ubuntu 9.10, dan zal elk bestaand snapshot onbruikbaar worden na de upgrade. Gebruikers die met dit probleem te maken krijgen, kunnen ervoor kiezen om de upgrade uit te stellen, totdat er een complete migratie-handleiding van Ubuntu 9.04 naar Ubuntu 9.10 beschikbaar is op een later tijdstip.
http://help.ubuntu.com/community/UEC (Engelstalig) (4298781)

Andere bekende problemen

Overstappen naar ext4 vereist handmatige aanpassing van grub

Als u uw bestandssystemen / of /boot opwaardeert van ext2 of ext3 naar ext4 (zoals beschreven op de ext4-wiki) moet u ook de opdracht grub-install uitvoeren na het upgraden naar Ubuntu 9.04 om uw opstartlader opnieuw te installeren. Als u dit niet doet kan de versie van GRUB in uw opstartsector de kernel op het ext4-bestandssysteem niet lezen en kan uw systeem dus niet opstarten.

Mogelijke corruptie van grote bestanden met het ext4 bestandsysteem

Er zijn wat meldingen gedaan over gegevenscorruptie bij het schrijven naar grote bestanden (meer dan 512 MB) op nieuwe (niet opgewaardeerde) installaties met het ext4-bestandssysteem, die gebruik maken van de Ubuntu 9.10-kernel. De kwestie wordt momenteel onderzocht en als het probleem wordt bevestigd, zal dit worden opgelost in een update na de uitgave van Ubuntu 9.10.
Gebruikers die vaak grote bestanden bewerken (meer dat 512MB) wordt aangeraden om voorlopig met ext3 te blijven werken totdat het mogelijke probleem is opgelost. (453579)

Ubuntu One vereist een upgrade na de installatie

Een serieuze fout in de Ubuntu One-client die wordt meegeleverd in Ubuntu 9.10, kan potentieel leiden tot dataverlies. Om dataverlies te voorkomen is alle bestandssynchronisatie met Ubuntu One voor deze clientversie uitgeschakeld. Gebruikers die een melding van hun Ubuntu One-client krijgen dat de mogelijkheden van client en server niet overeenkomen, moeten de laatste update van Ubuntu One installeren; hierdoor zal de mogelijkheid tot synchronisatie hersteld worden. De verwachting is dat deze update direct na het uitkomen van 9.10 beschikbaar zal zijn. De bestanden op Ubuntu One zijn ook beschikbaar via de web-interface van Ubuntu One, de web-interface is te vinden is op http://one.ubuntu.com/.
De synchronisatie van Tomboy-notities en contactpersonen wordt niet beïnvloed door dit probleem.

Upstart-taken kunnen niet worden uitgevoerd in een chroot

Upstart-taken kunnen niet worden gestart in een chroot, omdat upstart werkt als een dienst-supervisor, en processen binnen de chroot kunnen niet communiceren met de upstart die draait buiten de chroot (430224). Hierdoor zullen sommige pakketten die aangepast zijn om upstart-taken in plaats van init-scripts te gebruiken, niet succesvol upgraden binnen een chroot. Gebruikers worden geadviseerd om hun chroots in te stellen met /sbin/initctl verwijzend naar /bin/true, met de volgende opdrachten actief in de chroot:

dpkg-divert --local --rename --add /sbin/initctl
ln -s /bin/true /sbin/initctl

Aanmeldscherm verschijnt voordat optionele bestandssystemen kunnen worden aangekoppeld

Met het nieuwe upstart-gebaseerde opstartproces in Ubuntu 9.10 wordt de X-server gestart en het aanmeldscherm weergegeven zodra de core-bestandssystemen gereed zijn. Hierdoor zullen optionele bestandssystemen, die aangekoppeld worden op locaties die niet noodzakelijk zijn voor het opstarten van uw systeem, mogelijk tijdens het aanmelden nog niet aangekoppeld zijn. Als er een fout optreedt tijdens een routine bestandssysteemcontrole, is het mogelijk dat de bestandssystemen überhaupt niet aangekoppeld worden.
Gebruikers die de oude stijl van opstarten wensen kunnen dit doen door de optie bootwait toe te voegen aan deze bestandssystemen in /etc/fstab (439604)

Optionele versleutelde partities moeten gemarkeerd worden met bootwait in /etc/fstab

Behalve wat hierboven is beschreven, moeten gebruikers die versleutelde partities zo hebben ingesteld in /etc/crypttab dat ze bij het opstarten verschijnen (d.w.z.,het niet gebruiken van de noauto-optie) ervoor zorgen dat de bestandssystemen op deze volumes opgenomen worden in /etc/fstab wanneer ze niet aangekoppeld worden op een aankoppelpunt voor een standaardsysteem. Indien u dit niet doet op een desktop, zal dit leiden tot problemen omdat de X-server en cryptsetup tegelijk proberen controle te krijgen over het console. In het gunstigste geval ziet de gebruiker dan geen wachtwoordzin-prompt; in het ergste geval gaat de X-server spinnen en gebruikt dan de processor voor de volle 100%. (430496)

Avahi start niet als er een .local-domein aanwezig is

Het pakket avahi-daemon, dat de mDNS-"zeroconf"-standaard implementeert, bevat een controle die zorgt dat Avahi niet opstart als een conflicterend .local-DNS-domein aanwezig is. Er zijn meldingen binnengekomen dat sommige internetproviders een dergelijk .local-domein aanbieden op hun netwerken, waardoor Ubuntu 9.10 geen namen kan vinden op het lokale netwerk (327362).

Om het gebruik van mDNS op een dergelijk netwerk te forceren, moeten gebruikers de volgende opdrachten uitvoeren:

sudo sed -i -e'/AVAHI_DAEMON_DETECT_LOCAL/s/1/0/' /etc/default/avahi-daemon
sudo service avahi-daemon start

Op een EeePC met een Ralink rt2860 wifi-kaart(900 en 1000 series) kan bij het gebruik van Fn+2 om de wifi uit te schakelen, een kernel panic ontstaan waardoor het systeem blijft hangen. Een oplossing voor dit probleem wordt verwacht direct na de uitgave van 9.10. (404626)

Bison Webcam-stuurprogramma in MSI Wind netbook zorgt voor fouten met USB als die webcam niet wordt uitgeschakeld

Een fout in het uvcvideo-stuurprogramma voor de bison-webcam, die wordt meegeleverd met bepaalde typen MSI Wind- en gerelateerde netbooks, zorgt ervoor dat de USB-ondersteuning faalt waardoor andere USB-apparaten niet meer werken en/of pauzestand/ontwaken van de netbook niet meer werkt. Een tijdelijke oplossing is de webcam uit te zetten met de sneltoets Fn+F6. (435352)

Geen Xv-ondersteuning voor Intel 82852/855GM video-chips met KMS

Wanneer men gebruik maakt van de standaard "kernel mode settings" (KMS) optie in Ubuntu 9.10 zullen gebruikers met een Intel 82852/855GM kaart merken dat ze niet kunnen beschikken over de Xv-extensie voor het afspelen van video's. Het probleem kan tot uiting komen door een hoog processorgebruik of haperende beelden tijdens het afspelen van de video's of het niet afspelen van de video's door bepaalde applicaties. Als tijdelijke oplossing kunnen gebruikers met deze kaart een optie meegeven aan GRUB, namelijk om de kernel op te starten met nomodeset. De implementatie van deze optie verschilt per GRUB versie:

  • In GRUB 1: Open het bestand /boot/grub/menu.lst en voeg aan het bestand de optie modeset toe aan het begin van de regel die begint met # kopt=; sla de wijziging op. Daarna dient men de opdracht sudo update-grub uit te voeren om KMS uit te schakelen.

  • In GRUB 2: Open het bestand /etc/default/grub en voeg aan het bestand de optie nomodeset toe bij GRUB_CMDLINE_LINUX; sla de wijziging op. Daarna dient men de opdracht sudo update-grub uit te voeren om KMS uit te schakelen.

Voor meer informatie over deze fout: (395932).

Knipperende helderheid op MSI Wind netbooks met KMS

Door een fout in de kernel-mode-setting (KMS) welke onder andere de helderheid afhandelt, kan het zijn dat bepaalde MSI Wind-netbooks, waaronder de U90, U100, U120, een knipperende helderheid krijgen wanneer men de helderheid wijzigt, aangezien de helderheid bij herhaling wordt verhoogd en dan weer verlaagd. Een tijdelijke oplossing voor het probleem is het uitschakelen van KMS zoals hierboven beschreven. Voor meer informatie over deze fout: (415023).

Kubuntu's grafisch pakketbeheer waarschuwt niet voor installatie uit niet-ondertekende softwarebronnen

Het pakketbeheer kpackagekit in Kubuntu 9.10 geeft geen melding aan gebruikers als zij pakketten installeren die komen uit softwarebronnen die niet beveiligd zijn met PGP. Gebruikers die niet-ondertekende softwarebronnen in hun /etc/apt/sources.list-configuratiebestand hebben en een melding willen ontvangen als ze dergelijke pakketten installeren, moeten het opdrachtregelprogramma apt-get gebruiken als tijdelijke oplossing. (256245)

Amarok biedt geen extra codecs aan ter installatie tijdens het uitvoeren van Kubuntu vanaf de live-cd

Wanneer gestart in een live-sessie zal Amarok geen aanvullende mediacodecs ter installatie aanbieden wanneer dat nodig is. Het is dan dus niet mogelijk om bijvoorbeeld MP3-bestanden af te spelen. Na installatie op de harde schijf werkt dit naar behoren. (362538)

Evince PDF-viewer werkt niet met afwijkende persoonlijke mappen

Evince, GNOME's documentviewer, wordt nu geleverd met een beveiligend AppArmor-profiel. Dit verhoogt de veiligheid aanzienlijk door gebruikers te beschermen tegen fouten in de van oudsher problematische programmabibliotheken voor PDF en afbeeldingen. Gebruikers die een afwijkende locatie voor hun persoonlijke mappen gebruiken moeten deze aanpassen in /etc/apparmor.d/tunables/home. Zie https://wiki.ubuntu.com/DebuggingApparmor#Adjusting%20Tunables voor details.

UEC weigert mogelijk de eerste verzoeken na het opstarten

Tijdens het opstarten van het UEC-systeem kan het zijn dat de eerste verzoeken niet correct worden afgehandeld; als antwoord op een verzoek krijgt men bijvoorbeeld "403 Forbidden"-fouten terug. Het probleem wordt veroorzaakt door een deadlock in de database welke na een aantal pogingen verdwijnt. Als tijdelijke oplossing kan men Eucalyptus herstarten op de cluster controller door na het starten van UEC de opdracht sudo restart eucalyptus uit te voeren. (444352)

UEC-nodecontroller faalt tijdens installatie op bestaande UEC

Het uitbreiden van een bestaande Ubuntu Enterprise Cloud kan leiden tot het falen van de nodecontroller, tijdens installatie die gestart is met de optie "Install Ubuntu Enterprise Cloud" van de cd. De installatie van de node meldt dat:
"the preseed file cannot be downloaded from the Cluster Controller, because the wrong IP address is used to connect to the Cluster Controller."
Een tijdelijke oplossing is om eerst de standaard Ubuntu 9.10 server te installeren en vervolgens het eucalyptus-nc pakket na herstart van de server te installeren. Tevens dient men de primaire ethernet interface te configureren als bridge en dient de publieke ssh-sleutel van Cloud Controller's eucalyptus gebruiker handmatig te worden gekopieerd naar het authorized_keys-bestand van de nodecontroller's eucalyptusgebruiker. Gedetailleerdere informatie kan worden gevonden bij stap drie van de UEC Package Install tutorial.https://help.ubuntu.com/community/UEC/PackageInstall (Engelstalig) (458904)

Bevestigings-e-mails worden niet naar nieuwe gebruikers van UEC verzonden

Wanneer er een nieuwe gebruiker wordt aangemaakt in de admin-interface van UEC wordt er een e-mail naar de gebruiker verzonden ter bevestiging van de registratie. Door een fout in de smtp-configuratie van UEC worden deze e-mails niet geaccepteerd door de Cloud Controller en worden ze ook niet doorgestuurd naar de gebruiker. Een tijdelijke oplossing is om het postfix-configuratiebestand op de cloud controller (/etc/postfix/main.cf) aan te passen door de optie mynetworks uit te schakelen met een # en de mynetworks_style-optie ervoor in de plaats te zetten.

 #mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
  mynetworks_style = host

Daarna dient u postfix te herladen met sudo service postfix reload (458904).

UEC-gebruikersgegevens niet bruikbaar bij gast-instanties

Wanneer gebruikersgegevens worden doorgegeven aan een instantie die gestart is met euca-run-instances met bijvoorbeeld de volgende argumenten -d, --user-data of -f, --user-data-file worden de gegevens, teruggegeven op http://169.254.169.254/latest/user-data, gecodeerd (base64-encoded). Voor ec2-init zijn deze gebruikersgegevens onbruikbaar omdat ze eerst gedecodeerd moeten worden. Een oplossing voor dit probleem wordt verwacht direct na de release van Ubuntu 9.10. (461156)

Ubuntu 8.04 LTS als KVM-gast loopt vast wanneer men gebruik maakt van de virtio netwerk-drivers

Ubuntu 8.04 LTS kan als KVM-gast vastlopen waneer men gebruikt maakt van de virtio-stuurprogramma's en men Ubuntu 9.10 als host gebruikt. Als tijdelijke oplossing kan men gebruik maken van het e1000- of rtl839-netwerkmodel. Er wordt op dit moment gewerkt aan een oplossing die opgenomen zal worden in de update van het qemu-kvm-pakket in Karmic. (458521)

Het niet authenticeren van een Windows 7-domeinlid op een Ubuntu 9.10-server met een Samba-domeincontroller

Na het upgraden van een Samba domeincontroller naar Ubuntu 9.10 kunnen Windows 7-domeinleden er niet authenticeren, zelfs als men het register aanpast zoals het wordt beschreven in: http://wiki.samba.org/index.php/Windows7 (Engelstalig) voordat men Windows 7 probeert aan te melden. Een oplossing wordt verwacht onmiddellijk na de release van Ubuntu 9.10 in de vorm van een update. (462626)

Samba nmbd-daemon start niet tijdens het opstarten van de computer

Op een Ubuntu 9.10 systeem met Samba geïnstalleerd, kan het voorkomen dat de nmbd niet start tijdens het opstarten van de computer. Een tijdelijke oplossing is het handmatig starten van de nmbd-deamon nadat de computer volledig is opgestart met de opdracht sudo service samba restart. Een oplossing voor het probleem wordt verwacht na de uitgave van Ubuntu 9.10 in de vorm van een update. (462169)

Sparc niet ondersteund door Ubuntu 9.10

Het init-systeem upstart in Ubuntu 9.10 werkt niet op de sparc-architectuur vanwege een onbekende SIGBUS-fout. Ubuntu-gebruikers op het sparc-platform wordt aangeraden om Ubuntu 9.04 te behouden en niet te upgraden naar Ubuntu 9.10. Hulp bij het verhelpen van deze architectuur-specifieke fout is welkom voor Ubuntu 10.04. (436758)

Vensters corrupt met oudere ATI-grafische kaarten

Met oudere ATI grafische kaarten met 32MB of minder video-RAM-geheugen worden sommige direct gerenderde vensters, zoals het OSD-notificatiesysteem, niet goed weergegeven. U kunt dit omzeilen door 'RenderAccel' uit te schakelen bij de Xorg-instellingen. (426582)

Om dit te doen, gaat u eerst naar de console via de volgende opdracht:

  • sudo service gdm stop

Vervolgens maakt u een Xorg-configuratiebestand aan met deze opdracht:

  • sudo Xorg -configure

Voeg daarna de optie 'RenderAccel' toe aan /etc/X11/xorg.conf:

  • Section "Device"
                  ...
                  Driver "radeon"
                  Option "RenderAccel" "off"
          EndSection

en start X/GDM opnieuw.

sudo service gdm start

KarmicKoala/ReleaseNotes/nl (last edited 2009-11-15 14:14:16 by cumulus-007)