ThinkpadT40

Current Issues

Dapper BETA

It appears that evolution will hang after a suspend/resume. See bug 19388 for details. Evolution Hangs: 19388

Hardware details

Hardware Information

Device

Works?

Bug #

in Hoary?

in Breezy?

in Dapper?

Screen & Monitors

Screen

Tested OK

Tested OK

Tested OK

Correct resolution?

Tested OK

Tested OK

Tested OK

Correct refresh rate?

Tested OK

Untested

Tested OK

3D Acceleration

Tested OK

Tested OK

Tested OK

External monitor works?

Tested OK

Tested OK

Tested OK

External monitor - mirrors

Tested OK

Tested OK

Untested

External monitor - extend desktop

Untested

Untested

Power Management

Battery detected?

Tested OK

Tested OK

Tested OK

Hibernates?

Tested OK [1]

Tested OK

Tested OK

Sleep

Broken

ACPI tested OK, APM untested

Tested OK

ACPI suspend: 20495

Dim/Blank monitor?

Tested OK

Tested OK[7]

Tested OK[7]

Sound

Sound works?

Tested OK

Tested OK

Tested OK

Correct volume?

Tested OK

Tested OK

Tested OK

Hardware volume switch

Tested OK

Tested OK

Tested OK

Headphone jack

Untested

Tested OK

Tested OK

Mic jack

Untested

Tested OK

Tested OK

Built-in Mic

Tested OK

Tested OK

Tested OK

Networking

Wired NIC

Tested OK

Tested OK

Tested OK

Wireless NIC

Cisco MPCI 350 Tested OK using Cisco supplied ACU

Tested OK [2]

Untested

Modprobe Airo after hibernation: 20090

PCMCIA NIC

Untested

Tested OK

Untested

Firewire

N/A

N/A

N/A

Bluetooth

N/A

N/A

N/A

Modem

Untested

Tested OK

Tested OK

Infrared

Tested OK [5]

Untested

Untested

Tested OK[6] with Breezy Colony 3 (20497)

Touchpad & Mice

Touchpad

Tested OK

Tested OK

Tested OK

Touchpad - Doubletap = double click

Tested OK

Tested OK

Tested OK

Touchpad - Scroll down side

Tested OK

Tested OK

Tested OK

External mouse - USB

Untested

Tested OK

Tested OK

External mouse - Serial

N/A

N/A

N/A

Docking Station/Port Replicator

AC through replicator

Tested OK

Untested

Untested

USB

Untested

Untested

Untested

Serial

Tested OK

Untested

Untested

Parallel

Untested

Untested

Untested

External Monitor - VGA

Tested OK

Untested

Untested

External Monitor - DVI

Untested

Untested

Untested

Modem

Untested

Untested

Untested

NIC

Tested OK

Untested

Untested

PS/2

Untested

Untested

Untested

Additional Hardware

Fingerprint reader

N/A

N/A

N/A

CD/DVD drive

Tested OK, read/write CD, DVD playback untested

Tested OK

Tested OK

PCMCIA/Cardbus cards

Cardbus cards tested OK

Tested OK

Untested

Function and other keys

Fn key

Operation

Keycode

Works?

Bug #

in Hoary?

in Breezy?

in Dapper?

+ Space

Zoom

Doesn't work (not implemented?)

Broken

Broken

+ F3

Turn screen off

Tested OK

Tested OK

Tested OK

+ F4

Suspend

Broken

Tested OK

Tested OK

+ F5

Wireless on/off

Broken

Broken

Tested OK

+ F7

Switch video output (internal/external/both)

Broken

Untested

Tested OK

+ F12

Hibernate

Tested OK [1]

Tested OK

Untested

+ Home

Increase backlight

Tested OK (hardware implemented?)

Tested OK

Tested OK

+ End

Decrease backlight

Tested OK (hardware implemented?)

Tested OK

Tested OK

+ PgUp

Keyboard light

Tested OK (hardware implemented?)

Tested OK

Tested OK

Notes

[1] Recently had one case where the machine didn't hibernate properly - sat there spinning the HD for 10 minutes after which I power cycled it. Happened when doing the FN+F12 to hibernate. First time in ~20 hibernates it has failed.

[2] After resume from hibernate, it is extremely confusing trying to get the card working again. Method to get interface working is to unload the 'airo' module, then reload it, bring up ACU, then run 'dhclient3' to grab an IP address (if using DHCP). The cause of this bug is documented in bug 13850.

[3] When docked on the docking station, the image will come out of a connected monitor, but not on the laptop screen (tested once thus far - may be an anomoly).

[4] Backlight remains on.

[5] Must be enabled in the BIOS. See ThinkpadT40IrdaHowto for details of how to get it working with the FIR driver.

[6] Need to install irda-utils and modify default config. Tested using FIR as installed via ThinkpadT40IrdaHowto . Doesn't automatically resume operation after resume from hibernation.

[7] Blanks and locks the screen when FN-F3 is pressed. Backlight remains on.

===================================================

  • Contact: KenyonKarl

  • Make: IBM
  • Brand: Thinkpad
  • Model: T40 Type 2373-8cu
  • Ubuntu Hardware Database: 8e850b25b0ab7af9e8ed242d36a638b4
  • Website:

Current Issues

System Info

From Lenovo Support Web Site. Product: ThinkPad T40 2373-8CU [change] Operating system: All [change]

Original description: P M 1.5GHz, 256MB RAM, 40GB 5400rpm HDD, 14.1 XGA(1024x768) TFT LCD, 32MB ATI Radeon 7500, 24x-8x DVD(slim), Modem(CDC), Ethernet(LOM), Wireless upgradeable, Secure Chip(TCPA), UltraNav, 6 cell battery, WinXP Pro

It is possible that my specifications have changed since it was recently reconditioned by Wincycle.org of Windsor VT.

Hardware details

Screen & Monitors

Device

Works?

Bug #

in Gutsy Final Live

in Feisty Final

Screen

Tested OK

Tested OK

Correct resolution?

Tested OK

Tested OK

Correct refresh rate?

Tested OK

Tested OK

3D Acceleration

No

Yes

External monitor works?

Untested

Untested

External monitor - mirrors

Untested

Untested

External monitor - extend desktop

Untested

Untested

Power Management

Battery detected?

Tested OK

Tested OK

Hibernates?

Untested

Untested

Suspend

Untested

Tested OK [2]

Dim monitor on battery

Tested OK

Tested OK

Blank monitor on inactivity

Tested OK

Untested

Lid Close

Untested

Untested

Cpu frequency scaling

Supported

Supported

Sound

Sound works?

Tested OK

Tested OK

Correct volume?

Tested OK

Tested OK

Hardware volume switch

Tested OK

Untested

Headphone jack

Tested OK

Untested

Mic jack

Untested

Untested

Networking

Wired NIC

Untested

Untested

Wireless NIC

Untested

Untested

PCMCIA NIC

Untested

Untested

Firewire

Untested

Untested

Bluetooth

Untested

Untested

Modem [3]

Broken

Untested

178682

Infrared

Untested

Untested

Touchpad & Mice

Touchpad

Tested OK

Tested OK

Touchpad - Doubletap = double click

Untested

Untested

Touchpad - Scroll down side

Untested

Untested

External mouse - USB

Untested

Untested

External mouse - Serial

Untested

Untested

Docking Station/Port Replicator

AC through replicator

Untested

Untested

USB

Untested

Untested

Serial

Untested

Untested

Parallel

Untested

Untested

External Monitor - VGA

Untested

Untested

External Monitor - DVI

Untested

Untested

Modem

Untested

Untested

NIC

Untested

Untested

PS/2

Untested

Untested

Additional Hardware

Fingerprint reader

Untested

Untested

CD/DVD drive

Tested OK

Tested OK

PCMCIA cards

Untested [1]

Untested [1]

178680

Parallel Ports

Untested

Untested

Card reader(s)

Untested

Untested

Function and other keys

Fn key

Operation

Keycode

Works?

Bug #

in Ubuntu 6.06 LTS?

in Edgy (current development)?

+ Space

Untested

Untested

+ Esc

Untested

Untested

+ F1

Untested

Untested

+ F2

Untested

Untested

+ F3

Untested

Untested

+ F4

Untested

Untested

+ F5

Untested

Untested

+ F6

Untested

Untested

+ F7

Untested

Untested

+ F8

Untested

Untested

+ F9

Untested

Untested

+ F10

Untested

Untested

+ F11

Untested

Untested

+ F12

Untested

Untested

Other special keys

Key

Operation

Keycode

Works?

Bug #

in Ubuntu 6.06 LTS

Edgy (current development)

KEY

Untested

Untested

Notes

[1] can't find PCMCIA in KinfoCenter display which presumably means that it wasn't detected by Linux at startup. Note that PCMCIA is supported in Linspire 5.0.347 but apparently not Linspire 5.1.427, Freespire 1.0 (all based upon Debian). PCMCIA likewise not found by Kubuntu 7.04, Freespire 2.0, Linspire 6.0, and Kubuntu 7.10. [2] entered hibernation from logout panel OK, but returned with a blank screen. pushing the escape key produced an opportunity to enter my password. note that usb modem wasn't found after return from hibernation. after quick reboot, it was found but didn't work correctly. fortunately a cold reboot resolved all issues. [3] Internal winmodem works in Linspire 5.1.427 (based upon Debian) but apparently not in Kubuntu 7.10

LaptopTestingTeam/Old/ThinkpadT40 (last edited 2010-02-27 00:25:49 by primes2h)