10.04release_notes

Ubuntu Studio Lucid Lynx 10.04

Ubuntu Studio is a multimedia editing/creation flavor of Ubuntu, built for the GNU/Linux audio, video, and graphics enthusiast or professional.

The Ubuntu Studio team is very excited over its seventh release: Lucid Lynx 10.04, available as a 1.3GB DVD iso image from http://ubuntustudio.org/downloads/ Numerous improvements have been implemented for this release, but here are some of the more notable.

Upgraded Applications:

Audio

  • Aeolus 0.8.2 from 0.8.1
  • alsa-tools-gui (echomixer, eny24 control, HDSPcontrol, DPSPmixer, RME digicontrol) 1.0.22 from 1.0.20
  • Ardour 2.8.6 from 2.8.2
  • Audacity 1.3.11 from 1.3.9
  • freqtweak 0.7.2 from 0.7.0
  • GNE Denemo 0.8.10 from 0.8.6
  • Hydrogen 0.9.4
  • jackbeat 0.7.4 from 0.7.2
  • mixxx 1.7.2 from 1.6.1
  • Muse 1.0.1 from 0.8.1a
  • puredata 0.42.5 from 0.41.4
  • Qsynth 0.3.4 from 0.2.5
  • SooperLooper 1.6.14 from 1.0.8c

  • SoundRecorder (gnome-media) 2.29.91 from 2.28.1

  • Virtual Midi Keyboard (vkeybd) 0.1.18d from 0.1.17b
  • Zynaddsubfx 2.4.0 from 2.2.1

Graphics

  • Blender 2.49.2 from 2.49a
  • FontForge 0.0.20090923 from 0.0.20090622

  • FontMatrix 0.6.0 from 0.4.2

  • F-Spot 0.61.5 from 0.61.3
  • Gimp 2.6.8 from 2.6.7
  • Hugin Patch Processor 2009.2.0 from 0.8.0
  • Hugin Panorama Creator 2009.2.0 from 0.8.0
  • Inkscape 0.47.0 from 0.47~pre4

Video

  • Kino 1.3.4 from 1.3.3

New Applications:

  • Rakarrack 0.3.0
  • MuseScore 0.9.6

  • Subtitleeditor 0.30.0

Deprecated Application:

  • Creox

Applications Moved Into the Main Repository:

  • libffado
  • JACK

JACK support for applications:

  • Pulseaudio
  • Xine
  • Portaudio

/etc/security/limits.conf

Beginning with the Ubuntu package jack-audio-connection-kit-0.118+svn3796-1ubuntu2 editing of /etc/security/limits.conf should not be required. JACK will write the following during post-installation to /etc/security/limits.d/audio.conf

# generated by jackd's postinst.
# Do not edit this file by hand, use
# dpkg-reconfigure -p high jack
# instead
@audio - rtprio 99
@audio - memlock unlimited
#@audio - nice -19

Please note that creating or modifying /etc/security/limits.conf may cause conflicts with the JACK written /etc/security/limits.d/audio.conf settings.

Email from Linux Audio Users mailing list: http://linuxaudio.org/mailarchive/lau/2010/3/5/166428
Debian Bug #507248: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507248

LV2 Support and Plugins:

  • upgrade to lv2core 3.0 from 1.0
  • invada-studio-plugins-lv2 - a set of LV2 audio plugins
  • liblv2dynparam1 - lv2dynparam is a LV2 plugin interface extension
  • libslv2-9 - A library for simple use of LV2 plugins
  • slv2-jack - Jack support for LV2 plugins
  • Ardour - built with lv2 support
  • gir1.0-gst-plugins-base-0.10 - lv2 support for gstreamer
  • calf plugin - pack of audio plugins - effects and instruments

Kernels

  • Amd64
    • -generic will be installed if ubuntustudio-audio meta is NOT selected during installation process
    • -preempt kernel will be installed if ubuntustudo-audio meta IS selected during installation process
    • -lowlatency kernel is also available in Abogani's PPA - https://launchpad.net/~abogani/+archive/ppa

    • -realtime kernel will be available in Ubuntu Studio PPA
  • I386

Pulse Audio/JACK integration

  • Pulse Audio built against Jack is available
  • but qjackctl still disables Pulse Audio via pasuspender on start
  • further integration between Pulse Audio and JACK should occur in Maverick most likely via DBus

Further general Ubuntu Lucid release notes can be read here: http://www.ubuntu.com/getubuntu/releasenotes/1004

Hopefully you find this release to be our best yet, and we encourage any feedback you might have. We also encourage users of all expertise levels to join the Ubuntu Studio community in both documenting this release, and working towards our next release.

We hope you enjoy it!

UbuntuStudio/10.04release_notes (last edited 2010-04-27 15:06:27 by slavender)